How to use UVAS Help

UVAS Help has been developed in order to provide the user with whole information about UVAS handling and implemented techniques. In particular, this help system has several parts for different purposes:

General information: Use this section to learn how to configure UVAS.

Creating and running a simulation: In this section, it will be explained how to create and run a simulation, with whole information about UVAS commands.

Particles and defects in DADOS: It is essential that the user understands the particles and defects names used in DADOS.

Viewing results: Use this section in order to learn how to access results in DADOS interface.

Input physical parameters (advanced users): Use this section to understand the parameters read from the DDP file.

Physical magnitudes (advanced users): Physical magnitudes related to DADOS are explained here.

DADOS mechanisms (advanced users): Use this section in order to know the mechanisms used by DADOS to implement physical models.

UVAS Help also provides with a full links network in order to relate parameters, magnitudes and mechanisms.

Some parameters in the program are not implemented yet or are not accurately calibrated. This will be indicated when necessary.

Some references have been included in the help. In this page, you can see the list. In other sections, liks with bibliography have been implemented this way.


UVAS Help

University of Valladolid Atomistic Simulator

UVAS is an atomistic simulator fully developed by the Department of Electronics of the University of Valladolid, Spain. It can be used to simulate a large amount of processes in a very short time compared with other classical simulators because its core, DADOS (Diffusion of Atomistic Defects, Object Oriented Simulator), is based on atomistic technique kinetic Monte Carlo (kMC) (Martin-Bragado 2004, Jaraiz et al., 1996, Jaraiz et al., 1998, Jaraiz et al., 2001). UVAS also allows to display simulation results by means of a complete data structure, both in graphic and text modes.

In this section, these topics will be explained:

  • How to install and run UVAS.

  • UVAS overview.

  • Properties and options.

Last update: September 2006

This help has been developed by Luis Miguel Vega

Comments & suggestions about UVAS Help: lvegfid@ribera.tel.uva.es

Comments & suggestions about DADOS: mjaraiz@ele.uva.es


How to install and run UVAS

No installation program is provided with UVAS. The default input parameter s file is dados.ddp (can be anyname.ddp). We will refer to them simply as UVAS.exe and dados.ddp. Please follow these straightforward steps to successfully run UVAS:

Unzip DADOS.zip, config.zip, eel.zip and the UVAS.zip executable. If the drive is C: you should build the following directory tree:

Directory / File | Description
C:\DADOS\BIN\ | Includes pgnuplot.exe, wgnupl32.exe (to save graphics into GIF files) and RASMOL UVAS.exe (to see atomic configurations).
C:\DADOS\config\ | Configuration files.
C:\DADOS\ImplantFiles\ | IMPLANT files, that store cascades when simulating implant processes.
C:\DADOS\eel\ | Stopping power files, to simulate change in trajectory when a particle is moving.
C:\DADOS\temp\ | Temporary files.
C:\DADOS\UVAS.exe | Executable file (double click on it to run UVAS).
C:\DADOS\dados.ddp | Parameters file.
C:\DADOS\UVAS_Help.chm | Help system.
C:\DADOS\TestSuite\ | A full collection of examples to see physical properties simulated with DADOS.

Your simulation files can be located anywhere, as well as modified versions of the DDP parameters file .


Overview

UVAS Overview

UVAS has a very easy environment to work with. When running a simulation, its aspect is like this:

UVAS main parts are listed below:

  • Commands window: It shows the process script or simulation details.

  • Commands description: A brief description of the selected command is given.

  • Data browser: A full data tree can be seen here, with whole information about the current simulation.

  • Data printer: It is a way to transfer results into a file.

  • Vectors control: It is a way to access simulation results.

  • Data viewer: Results will be shown here in text mode.

  • Messages window: Information about simulation progress is shown in this window.

  • Progress bar: Indicates the progress over the command being executed.

  • State bar: It shows the process being executed at the moment.

UVAS uses symbols in order to indicate properties:

Non executed command
Executed command
Vector (array of data)
Read vector (array of data) in Commands Window
Decimal number
Read decimal number in Commands Window
Integer
Enumeration
Integer
Read integer in Commands Window
Text
Read text in Commands Window
Pointer


Properties and Options

UVAS options can be found by clicking on View -> Properties. Once there, three sections are offered to be modified:

File

  • Binary save: If this option is selected, simulations will be saved as a binary file. Otherwise, they will be saved with ASCII format.

  • Verbosity: Indicates the level of information to be shown in the messages window. This level is an integer between 0 (no information) and 4 (full information). Level 2 is established as default.

Data Browser

  • Limit vector list: You can specify the number of elements shown in order to save memory and computerization capabilities. It is not recommended to establish a low value in order not to lose results.

  • Show pointers: It shows or hides pointers in the Data browser. Pointers are a special type of data in UVAS.

  • Change to last value warning: When selected, if you set a value in the "Index" item of the Vectors Control higher than the highest, UVAS will automaticaly change to the last one.

  • Ask for simulation and object: If this option is selected, UVAS will ask to user about data origin which have been read from a file, in case they are not stored in memory.

  • Enumerate vector elements: Shows a counter for the elements listed in vectors to be shown.

  • Write output to disk instead of print: While checked, results will be written in files instead of printed on the window.

Script Wizard

  • Autoexpand: While creating Script Wizard tree, it expands different items associated with it.

  • Max. historic in: When you set a value in the "Index" item of the Vectors Control, UVAS will save the last ones. With this parameter you can specify how many of then you want to save.


Creating and Running a Simulation

In this section, you will learn how to create scripts and run simulations with detailed characteristics.

In this section, these topics will be explained:

  • Creating a script.

  • UVAS Commands.

  • Running a script.

  • Data files.


Creating a script

A script is a set of commands that indicate UVAS the process to simulate. To create it please follow these steps:

  • Click on File -> New... and give a name for the simulation.

  • Click on Commands and choose from the given options. Full information about available commands can be found here.

  • Once added all necessary commands, the script is defined. We can save it by selecting File -> Save... and we will get an UVA file which can be used to be simulated afterwards.


Commands

UVAS Commands

UVAS provides with these commands for simulations:

  • CreateDADOS.

  • Anneal.

  • Apply_Strain_Profile. [TO BE DEVELOPED]

  • Implant.

  • Implant_Read_Profile.

  • Input_Data_Series.

  • Load_To_Continue. [TO BE DEVELOPED]

  • Open_Graphics.

  • Read_Profile.

  • Run_Next_Simulation.

  • Save_3D_Config. [TO BE DEVELOPED]

  • Save_Output_Plots.

  • Save_Simulation.

  • Save_To_Continue. [TO BE DEVELOPED]

  • Set_Ge_Fraction_Profile.

  • Set_Material.

  • Set_Output_Options.

  • Surface_IV_gen_rec.

  • Take_Snapshot.

CreateDADOS

It should be the first command for every simulation. With this command, a silicon simulation box is created as simulation domain.

Parameters:

  • Object label and Client data: It is not necessary to be worried about it as these words are only used by internal code to work. Only give a name for them.

  • Parameters file: It is the DDP file where the simulation parameters are defined.

  • Minimum x, Minimum y, Minimum z, Maximum x, Maximum y, Maximum z: The simulation box used by DADOS to work is simply defined by two 3D points (see figure below), indicating the two opposite sides of the box (distances must be expressed in NANOMETERS). Obviously, the larger the box is, the more accurate and statistically significant the simulation will be, although a longer time will be needed to simulate. DADOS uses as internal minimun x the value zero, this means that if you use a different value for Minimum x, a part of the simulation box will not be shown in the results.

This command will be shown in every command as it is the basic one. It can be checked that when this command has been executed, a tick appears not only in the main command but in all the others.

Click here if you want to learn more about box handling.

With the command Set_Material, UVAS can create different regions for simulations:

When executed (verbosity level 2), the following is shown in the messages window. As we can see, UVAS shows full information about boxes and amorphization parameters.

Anneal

The annealing process is simulated by changing the temperature.

Parameters:

  • Initial Temperature and Final Temperature: UVAS makes a linear interpolation (short steps), as it works with discrete parameters. These temperature must be expressed in DEGREES CENTIGRADE.

  • Time s: The time between initial and final time must be expressed in SECONDS.

If a constant temperature for annealing is required, please set two annealing processes: the first one will last a little time (e.g. 0.5 s for each 100 °C), from initial temperature up to the final one, and in the second anneal maintain equal both temperatures for the required time:

This technique is not compulsory, a discontinuity in temperature is allowed in DADOS but it is highly recommended setting slopes as shown.

Apply_Strain_Profile [TO BE DEVELOPED]

This command will be used to create a simulation box with a variable in-plane lattice parameter depending on the depth (x).

Implant

DADOS uses the MARLOWE code, a program based on the binary collisions approach (BCA) in order to generate cascades to implant in silicon (Robinson et al. 1974). After the cascades have been generated, DADOS stores them in an IMPLANT file, which is saved in the ImplantFiles directory. This way, in the next simulation, it is not necessary to re-calculate the cascades. However, if the simulation box is modified, IMPLANT file will be modified as well. It is very important that only one similar implant in the same directory can be simulated at the same time, in order not to overwrite the file.

When executed (verbosity level 2), the following is shown in the messages window. In the example, as it didn't exist the IMPLANT file, UVAS creates it:

Parameters:

  • Implant species: A species to implant can be selected here from a list. Not all the species are implemented (see figure below). For those who are not, DADOS only creates the damage. If you want to do the same with other implemented species, please set a negative energy.

  • Energy: It is the implant energy, expressed in KILOELECTRONVOLTS.

  • Tilt: See figure below. When tilt is zero, the implant direction is <100>.

  • Rotation: See figure below.

  • Dose: Total concentration to implant, expressed in IONS PER SQUARE CENTIMETER.

  • Dose rate: Implant rate, expressed in IONS PER SQUARE CENTIMETER AND PER SECOND.

  • Mask Y min: See figure below.

  • Mask Y Max: See figure below.

  • Mask Height: See figure below.

  • Mask Angle: See figure below.

  • Window Z Max: See figure below.

  • Temperature: Implant temperature expressed in DEGREES CENTIGRADE. This is an important parameter as implant results (damage) depends on temperature.

  • Target Structure: A target structure can be selected here from a list.

  • MaxDifferentCascades: MARLOWE generates the number of cascades indicated by this parameter. DADOS repeats them in different positions randomly chosen. It should be big enough to avoid statistic errors but not huge.

It is obvious that implant time can be obtained as dose/dose_rate, as it is a linear process.

DADOS implements two types of conditions for cascades: periodic and mirror.

Tilt and Rotation definition:

Parameters for the mask:

If you want to eliminate the mask, please set Mask Y Min higher than Mask Y Max.

Implant_Read_Profile

This command should be used at any moment after loading a profile file with Read_Profile. It implants all the profiles opened so far simultaneously.

Parameters:

  • Time: Time used to implant the profile. This parameter must be expressed in SECONDS. Time can be set to zero, but at high temperatures, if the particles are mobile, a great amount of processes are happening that can affect the computer stability; therefore, it is highly recommended using a non-zero value if the particles are mobile.

  • Temperature: Implant temperature expressed in DEGREES CENTIGRADE. This is an important parameter as implant results (damage) depends on temperature.

This command is useful for:

  • Epitaxial grown doping.
  • Academic purposes.
  • Introduction of profile and damage in different stages.

Input_Data_Series

A DA2IN file can be inserted here to be plotted as external data for visualization purposes. Please see data file format for more information.

Load_To_Continue [TO BE DEVELOPED]

This command must be used with a RESTART file, generated with Save_To_Continue. It is used to continue with a simulation.

Open_Graphics

When this command is reached during the simulation, UVAS opens the graphics structure defined in the indicated GPH file. Its function is similar to the one provided by Main Menu. Click here to know more about graphics.

Read_Profile

This command is useful for creating profiles in silicon. At any moment after this command, Implant_Read_Profile should be called in order to implant it. As shown in the figure, it is necessary to provide a file with the information of the implant as symply as giving two columns: one for depth and the other one for concentration (please see data file format for more information). The particle type is given by the file extension:

.int | Interstitials
.dam | Damage
.vac | Vacancies
.ars | Arsenic
.bor | Boron
.car | Carbon
.flu | Flourine
.hyd | Hydrogen
.ind | Indium
.oxy | Oxygen
.pho | Phosphorus
.ant | Antimony

Run_Next_Simulation

Once a script has been saved, it can be opened using this command in order to continue with a new simulation after another one have been finished. This way, several simulations can be chained to be executed (at different times, not simultaneously).

Commonly, this command is preceded by a save command, such as Save_Output_Plots or Save_Simulation.

Save_3D_Config [TO BE DEVELOPED]

This command saves the 3D particle configuration data to a 3D file. The saved configuration is the one at the moment of this command has been called.

WARNING: In general, it is not recommended to set this command during or just after the implant process, as a lot of memory would be required due to the fact that ion implementation generates a great amount of interstitials and vacancies, anc the required memory to store their coordinates would be very high.

Save_Output_Plots

This command is used by UVAS to store the output plots into a GIF file (one per plot). Its function is similar to the one provided by Main Menu. This command uses the program GNUPLOT, located in BIN directory. The name of the file will be the name of the simulation followed by a dot and followed by the name of the graph. For instance, if the name of the simulation is "Amorph_Threshold" and the name of the graphic is "Amorph vs Time", the GIF file will be Amorph_Threshold.Amorph vs Time.gif. Click here to know more about graphics.

This command does not save the entire simulation (for doing this, please use Save_Simulation). However, it can be useful for well-known simulations, in order to save memory.

Save_Simulation

When UVAS reads this command, the simulation with its current results are saved into an UVA file. Its function is similar to the one provided by Main Menu. The information stored is the present at the moment UVAS reads this command. After a simulation has been saved as an UVA file, it cannot be run any more. For running it again, please use Save_To_Continue command.

With this command, the entire simulation is saved, including results. Notice that a great amount of memory might be required, depending on the output options (number of snapshots, 3D structures, etc.).

Save_To_Continue [TO BE DEVELOPED]

Sometimes, simulations are long, specially if simulation box is large. In this case, it can be interesting to pause the simulation after a step. For doing this, just set Save_To_Continue command when pause is required and UVAS will save all the information in the file with RESTART extension. For restarting the simulation, please use Load_To_Continue command with the RESTART file saved before.

Compare this command with the "Save" function.

Set_Ge_Fraction_Profile [TO BE DEVELOPED]

Use this command to set the germanium fraction profile along "x" axis. Information about it must be included in the SIGE file. Click here to know the structure.

Set_Material

It is used to properly define the interface in silicon. If this command is not used, DADOS assumes that there is neither surface nor interface; therefore, there is no simulation of generation or recombination there. Remember that point defects are generated in the surface under equilibrium conditions, thus, the use of this command is highly recommended in most simulations. Generation and recombination in the volume are not implemented in DADOS, as their frequency is extremely low, in order to save memory and computerization resources. Silicon oxide or Ambient are the most common materials employed but other ones can be chosen from those shown below.

Parameters:

  • Initial x, Initial y, Initial z: Initial coordinates for the new material, expressed in NANOMETERS. Click here to know more about domain definitions.

  • Final x, Final y, Final z: Final coordinates for the new material, expressed in NANOMETERS. Click here to know more about domain definitions.

As DADOS works with boxes, and the number of boxes for materials must be integers, it is not guaranteed that the final material size is going to be the specified one but DADOS will do its best. For example, if the box size is X = 100 nm, Y = 10 nm, Z = 10 nm, with 19 bits, the x size of small boxes is 0.78125 nm, which means that the size of material in x axis will be of two boxes, i.e., 1.5625 nm, and not 1.5 nm (the specified one).

Set_Output_Options

This is an important command as UVAS doesn't save every result in order not to waist a lot of memory. It must be set BEFORE the commands which provide results. Here, you will indicate what you want to save. Please click here in order to know more about UVAS data structure.

Parameters:

  • Start output time (s): It is the time when the first snapshot is taken. It has the same function as InitOutputTime in the parameters file, although the value here is the one UVAS will take for the simulation.

  • Snapshots per decade: Indicates the number of snapshots saved per time decade. If this value is set to zero, UVAS will save a snapshot only when the material changes (if checked this option), or when the charge is updated (if checked this option). Notice that, this way, the snapshot will reflect the worst correlation between majority carriers and dopants. This is useful only for testing the approximation (not valid for physical outputs).

  • Enable events/snapshot: When selected, UVAS saves a snapshot when a number of events specified in Events per Snapshot happen.

  • Snapshot before ChgUpdate: When selected, UVAS saves a snapshot just before the charge is updated.

  • Snapshot after change Material: When selected, UVAS saves a snapshot when the material changes : amorphous to crystalline or crystalline to amorphous.

  • Incremental events: When selected, UVAS shows the hops and supersaturation averaged over the last snapshot interval. If not, UVAS will average this magnitudes over the whole simulation time.

  • Save 3D: When selected, UVAS saves 3D structures, useful for plotting atomic configurations. WARNING: In general, it is not recommended to set this command during or just after the implant process, as a lot of memory would be required due to the fact that ion implementation generates a great amount of interstitials and vacancies, anc the required memory to store their coordinates would be very high.

  • Save last n: Please indicate here the number of snapshots UVAS will save. If more than "n" are generated, UVAS will discard the first ones.

  • 1Dprofiles nX: Number of points in 1D profiles for abscissas. It is not recommended that this parameter is too high in order to save memory.

  • 2Dprofiles nY: Number of points in 2D profiles for ordinates. The number of points in abscissas axis is taken from 1Dprofiles nX. It is not recommended that this parameter is too high in order to save memory.

Surface_IV_gen_rec

After defining another material by means of Set_Material, it is necessary to define the interface characteristics. This command is also interesting to simulate oxidation and nitridation processes.

Parameters:

  • RecL I: Recombination length for interstitials. If this value is zero, it means that surface is a perfect sink for interstitials. If this value is set to "-1", the surface will neither recombine nor emit interstitials. This parameter must be expressed in NANOMETERS. DADOS uses a value to initialize, specified in the DDP file, RecLnm.

  • SuperSat I: It is used so that the interstitials concentration at the interface is different to the equilibrium one. It is useful to simulate oxidation or nitridation processes. DADOS uses a value to initialize, specified in the DDP file, SuperSat.

  • RecL V: Recombination length for vacancies. If this value is zero, it means that surface is a perfect sink for vacancies. If this value is set to "-1", the surface will neither recombine nor emit vacancies. This parameter must be expressed in NANOMETERS. DADOS uses a value to initialize, specified in the DDP file, RecLnm.

  • SuperSat V: It is used so that the vacancies concentration at the interface is different to the equilibrium one. It is useful to simulate oxidation or nitridation processes. DADOS uses a value to initialize, specified in the DDP file, SuperSat.

Take_Snapshot

When this command is found in a simulation, UVAS takes a snapshot of current configuration and is saved in the final data structure.


Running a script

Once defined a script, please follow these steps to run it:

  • For simulating the script, please click on Simulation -> Start.

  • Simulation can be paused and continued when necessary or stopped. For doing this, click on View menu:

When the simulation is paused, commands which have not been executed can be eliminated or other commands can be added.

  • When the simulation has finished, a message will appear in the Messages Window indicating "Script done". Now, the results can be saved by selecting File -> Save..., and an UVA file will be created. Now, the UVA file contains the results which can be opened with UVAS, but the script used cannot either be modified or run again. Therefore, it is highly recommended not to run an original script if you want to simulate it several times (copy it and give a different name instead).

Notice that when a commands has been fully executed in a simulation, a tick sign appears on its symbol in the Commands Window.

Other options

  • Update output: Creates a snapshot.

  • Next command: Skips the command which is being currently executed and runs the next one.

  • Step [NOT IMPLEMENTED].


Data files

UVAS uses several types of data files in the commands to add external data to the simulations and also in the DDP file.

In general, these files are organised in two columns, with pairs of data, like in abscissas and ordinates axis.

Concentrations

No interpolation is made in the in-plane lattice parameter. The program only maintains the value until the next one. Data (x,y) must be numbers. Pairs of data must be in different lines.

DDP file (I): One variable dependance. Binding energies

A linear interpolation is made among discrete data. A "-1" is required at the end of the list to indicate DADOS that there are no more data. If a value is not included, DADOS uses the default value. Data (x,y) must be numbers. Pairs of data must be in different lines.

DDP file (II): One variable dependance. Amorphous pockets energies

A linear interpolation is made among discrete data. A "-1" is required at the end of the list to indicate DADOS that there are no more data. Data (x,y) must be numbers. Pairs of data must be in different lines.

DDP file (III): Two variables dependance

Data here are organized in a matrix where the first two columns indicate the index while the third one is used for the parameter value. A "-1" is required at the end of the list to indicate DADOS that there are no more data. Data (x,y) must be numbers. It is not necessary that the data are in columns; DADOS will read them in order. An example is shown:

DA2IN files

No interpolation is made. Data (x,y) must be numbers. Pairs of data must be in different lines.


Particles and defects

Particles and defects in DADOS

DADOS implements both particles and defects. According to atomistic theories, only particles in defects are handled in DADOS. Click below in order to know more about the notation used by the program:

  • Particles.

  • Defects.


Particles

Please see comments below.

DADOS name | Definition | Material
Single neutral "native defects"
I | Neutral interstitial | Silicon
V | Neutral vacancy | Silicon
Charged "native defects"
IP | Positive interstitial | Silicon
IM | Negative interstitial | Silicon
VP | Positive vacancy | Silicon
VPP | Doubly positive vacancy | Silicon
VM | Negative vacancy | Silicon
VMM | Doubly negative vacancy | Silicon
Single impurities
O | Oxygen | Silicon
C | Carbon | Silicon
B | Negative boron | Silicon
F | Fluorine | Silicon
H | Hydrogen | Silicon
In | Negative indium | Silicon
As | Positive arsenic | Silicon
Ph | Positive phosphorous | Silicon
Sb | Positive antimony | Silicon
Impurity-"native defect" pairs
Ci | Interstitial-carbon | Silicon
Bi | Neutral interstitial-boron | Silicon
BiP | Positive interstitial-boron | Silicon
BiM | Negative interstitial-boron | Silicon
InV | Neutral vacancy-indium | Silicon
InVM | Negative vacancy-indium | Silicon
Ini | Neutral interstitial-indium | Silicon
IniM | Negative interstitial-indium | Silicon
AsV | Neutral vacancy-arsenic | Silicon
AsVP | Positive vacancy-arsenic | Silicon
AsVM | Negative vacancy-arsenic | Silicon
Asi | Neutral interstitial-arsenic | Silicon
AsiP | Positive interstitial-arsenic | Silicon
PhV | Neutral vacancy-phosphorous | Silicon
PhVP | Positive vacancy-phosphorous | Silicon
PhVM | Negative vacancy-phosphorous | Silicon
Phi | Neutral interstitial-phosphorous | Silicon
PhiP | Positive interstitial-phosphorous | Silicon
Impurities in other materials
AsAmorphousSi | Arsenic in amorphous | Amorphous silicon
AsNitride | Arsenic in nitride | Silicon nitride
AsOxide | Arsenic in oxide | Silicon oxide
BAmorphousSi | Boron in amorphous | Amorphous silicon
BNitride | Boron in nitride | Silicon nitride
BOxide | Boron in oxide | Silicon oxide
PhAmorphousSi | Phosphorous in amorphous | Amorphous silicon
PhNitride | Phosphorous in nitride | Silicon nitride
PhOxide | Phosphorous in oxide | Silicon oxide

Comments

  • The "Material" column indicates the material where the particle can be found. For silicon, silicon-germanium [TO BE DEVELOPED] is included, with is a similar structure but with different lattice parameter and different values for some magnitudes.

  • We use "P" to indicate positive state of charge (plus) and "M" to indicate negative state of charge (minus).

  • The symbol of phosphorous in DADOS is "Ph" instead of the traditional "P" because this one is used to indicate positive state of charge.

  • DADOS does not describe the microscopic configuration. For instance, a pair boron plus interstitial is the same for DADOS than a boron atom in interstitial position; in both configurations, there is a boron atom plus an extra atom.


Defects

DADOS uses these kinds of defects for simulations (please click on them for more information):

  • Amorphous.

  • AmorphousPockets.

  • Complex.

  • DLoops.

  • I311.

  • Platelet.

  • PointD.

  • SiInterface.

  • SuperSat.

  • Voids.

Amorphous, SiInterface are not exactly defects, but they have associated events (read below).

SuperSat is not a defect but are included here for an easier handling and visualization.

DADOS distinguishes between events and interactions for simulating:

  • Events happen by themselves, with a frequency that depends on the temperature. For example: point defects jumps.

  • Interactions are related with capture distance. As we will see later, the only mobile defects implemented in DADOS are point defects, and therefore the interactions are going to take place between (mobile) point defects and any other defect. For example: cluster growth. Interactions occur in DADOS depending on:
    • Whether or not the interaction is allowed,
    • Involved barrier energies,
    • Charge states.

To clarify ideas, emissions are always events whereas captures are always interactions.

Particles in DADOS are always associated to defects, which are the ones used to create events.

The events are shown in the messages window, as we can see in the figure below. These events are basically associated to jumps, because these are the most frequent ones.

All implemented defects are neutral except, in some cases, point defects.

Amorphous

Description

Amorphous silicon [1].

Particles involved

None [2, 3, 4].

Events allowed

  • Recrystallization.

Interactions allowed

None.

Related DADOS mechanisms

  • Amorphous implementation.

  • Trapping.

Comments

  1. It is important to make the difference between amorphous as a defect and amorphous box:
    • Amorphous silicon is not crystalline with a lot of defects. It is a different material, although DADOS implements it as crystalline silicon with a concentration of native defects that has reached a certain threshold.
    • Amorphous silicon is a defect for DADOS as events occur there and in order to view concentrations: The program provides with a concentration for amorphous boxes (but they are not real particles).

  2. When a dopant is in an amorphous box, it is not considered to belong to the amorphous defect but is considered to be a new point defect to whose name is added "AmorphousSi", e.g. "BAmorphousSi". We call this "impurities in other materials".

  3. Both interstitials and vacancies are used for visualization, but they are not actually amorphous particles. Amorphous boxes contribute to the interstitials and vacancies profiles with concentration values similar to the amorphization threshold.

  4. Internally, DADOS keeps the balance of I-V particles.

AmorphousPockets

Description

Amorphous pocket: Initial damage structure, with interstitials and/or vacancies in an irregular shape.

Particles involved

Single neutral native defects [1].

Events allowed

  • IV recombination, i.e. shrinkage [2].

  • Neutral interstitials emission [4, 5].

  • Neutral vacancies emission [4, 6].

Interactions allowed

  • I capture [5], but only if:

    • Captured I is neutral OR,

    • Captured I is charged but the amorphous pocket contains one or more vacancies.

  • V capture [6], but only if:

    • Captured V is neutral OR,

    • Captured V is charged but the amorphous pocket contains one or more interstitials.

  • Bi capture [7] but only if:

    • Amorphous pocket contains one or more interstitials and one or more vacancies.

Related DADOS mechanisms

  • Amorphization.

  • Amorphous pocket implementation.

  • Amorphous pocket to I311 transformation.

  • Amorphous pocket to void transformation.

Comments

  1. Small and irregularly shaped I clusters or V clusters are regarded as a particular case of amorphous pockets with only one type of particles.

  2. Amorphous pockets can shrink due to emissions and recombinations. However, although both effects are implemented in DADOS, the latter is more important, as its frequency is much higher.

  3. Particles in amorphous pockets are immobile.

  4. Obviously, emission of interstitials or vacancies is allowed only if there are any.

  5. Let's suppose some cases:

    Im + I <-> Im+1

    This reaction is allowed in both directions as DADOS implements both emission and capture of neutral particles. However, it is allowed neither the emission nor capture of charged particles. If this phenomena were implemented, then emission frequency would depend on Fermi level. What DADOS does is to maintain this rate constant and include the charges effects in charge update handling.

    ImVn + I <-> Im+1Vn, m≥0, n>0

    The reaction above is allowed in both directions but the the reverse one (<-) is not frequent due to the shrinkage occurs before more likely.

    ImVn + Ij -> Im+1Vn + j

    "j" is an integer that represents the charge and jh+ (or je-) are the holes (or electrons) required to balance the charge reaction. This reaction is only allowed in the forward direction. In DADOS, it is not allowed the emission of charged particles. If this phenomenon was implemented, then emission frequency would depend on Fermi level. What DADOS does is to maintain this rate constant and the charges effects are included in charge update handling.

  6. Let's suppose some cases:

    Vm + V <-> Vm+1

    This reaction is allowed in both directions as DADOS implements both emission and capture of neutral particles. However, it is allowed neither the emission nor capture of charged particles. If this phenomena were implemented, then emission frequency would depend on Fermi level. What DADOS does is to maintain this rate constant and include the charges effects in charge update handling.

    ImVn + V <-> ImVn+1, n≥0, m>0

    The reaction above is allowed in both directions but the the reverse one (<-) is not frequent due to the shrinkage occurs before more likely.

    ImVn + Vj -> ImVn+1 + jh+

    "j" is an integer that represents the charge and jh+ (or je-) are the holes (or electrons) required to balance the charge reaction. . This reaction is only allowed in the forward direction. In DADOS, it is not allowed the emission of charged particles. If this phenomenon was implemented, then emission frequency would depend on Fermi level. What DADOS does is to maintain this rate constant and the charges effects are included in charge update handling.

  7. In order to simulate the immobilization of Bis by amorphous pockets, we assume the following reaction:

    Bi + ImVn -> I2B + Im-1Vn

    We assume that the interaction of Bis with an amorphous pocket with only one type of particle (Im or Vn) is not allowed because there is no evidence that boron activation in vacancies clusters or boron pile-up in interstitials clusters is observed experimentally.

  8. With reasonable values of binding energy (Eb), the rate of the mechanism Vn -> Vn+1 + I or In -> In+1 + V is negligible. Therefore, this event is not implemented. WARNING: If binding energy is higher (or much higher) than formation energy, the simulation can give inaccurate results as the suppositions are not true.

  9. The trasformation from an amorphous pocket with only one type of particle to either a I311 or a void is a particular type of event, depending on the temperature.

  10. Amorphous pockets accumulation generates amorphous regions.

  11. Amorphous pockets are considered to be electrically neutral.

Complex

Description

Complex, i.e., structures of impurities (dopants) and interstitials or vacancies.

Implemented types: ImBn, ImCn, VmAsn, VmOn, VmFn, VmPhn. "n" and "m" are the number of particles of each type. "m" can be zero, therefore impurities clusters are included here.

Particles involved

Two types of particles:

  • "Back particles": Single neutral "native defects".

  • "Front particles": Single impurities.

Events allowed [1]

  • Back particle emission: emits a back particle.

  • Front particle emission:

    • Mobile particles are emitted as single particles (e.g. fluorine).

    FnVm -> VmFn-1 + F

    • Immobile particles are emitted as a pair, for example:

    BnIm -> Bn-1Im-1 + Bi
    AsnVm -> Asn-1Vm-1 + AsV

  • Complementary particle emission (e.g. VmAsn -> Vm+1Asn + I). This event is a generalization of Frank-Turnbull mechanism. [2].

Interactions allowed

  • Neutral point defect capture,

    • with growth (e.g. VnAsm + V -> VnAsm+1) or,
    • with recombination (e.g. VnAsm + Asi -> Vn-1Asm+1) [3].

  • Complex capture (e.g. VnAsm + AsV -> Vn+1Asm+1).

Related DADOS mechanisms

  • Complex implementation.

  • Pile-up.

Comments

  1. Emitted particles are neutral and, consequently, the reverse processes of these (interactions) are only allowed with neutral point defects, in order to maintain microscopic reversibility.

  2. Complementary particle emission is implemented here and not in amorphous pockets because in complexes it is much more frequent. Notice that in some particular cases, due to the complexes energies, this process could be frequent; therefore, in this case, it would not be consistent to allow recombination with charged native point defects.
    3. (Pinacho et al. 2005)

  3. Recombination is immediate as, in DADOS, activation energy for complex shrinkage is assumed to be zero.

  4. Complexes are considered to be neutral and they are responsible for electrical deactivation of some dopants (such as boron or arsenic) (Pelaz et al. 1997).

  5. Complexes dissolution implies an electrical reactivation (Pelaz et al. 1999).

  6. Particles in complexes are immobile.

DLoops

Description

Faulted dislocation loop [1]: Planar extended defect of interstitials in {111} orientations.

Particles involved

Neutral interstitials.

Events allowed

  • Neutral interstitials emission [2].

Interactions allowed [3]

  • Captures of:

    • Neutral interstitials.
    • Interstitial boron.

Related DADOS mechanisms

  • Dislocation loop implementation.

  • I311 to dislocation loop transformation.

  • Pile-up.

Comments

  1. Perfect dislocation loops are not implemented in the current version of DADOS (Cristiano et al. 2000).

  2. Neutral vacancies emission and captures are not implemented yet. [TO BE DEVELOPED]

  3. Interactions for dislocation loops are the reverse process of neutral interstitials emission.

  4. Particles in dislocation loops are immobile.

  5. In the current version of DADOS, dislocation loops in DADOS are formed from I311.

I311

Description

Extended defect of neutral interstitials in {311} orientations.

Particles involved

Neutral interstitials.

Events allowed

  • Neutral interstitials emission.

  • Transformation into a dislocation loop (large I311s).

Interactions allowed

  • Neutral interstitials capture (growth).

  • V capture and recombination [2].

  • Capture of some types of dopants, although only indium is implemented [3].

Related DADOS mechanisms

  • Amorphous pockets to I311 transformation.

  • I311 implementation.

  • I311 to dislocation loops transformation.

  • Pile-up.

Comments

  1. Particles in I311 clusters are immobile.

  2. Recombination is immediate, as in DADOS, activation energy for shrinkage is assumed to be zero. Captures and recombination with charged vacancies is allowed as vacancies emission from Im structures is going to be very unlikely.

  3. When a mobile Indium-vacancy or Indium-interstitial pair meets a 311 cluster, the Indium atom piles up:

    Ini(-) + Im -> In(-) + Im+1
    InV(-) + Im -> In(-) + Im-1

    This way, the indium atom maintains the negative charge.

  4. I311 are normally created from amorphous pockets with only interstitials at enough temperature.

Platelet [TO BE DEVELOPED]

Description

Platelet: Extended defect in {100} orientations.

Particles involved

Neutral vacancies and hydrogen.

Comments

  1. Particles in platelets are immobile.

  2. This defect is under development.

PointD

Description

Native point defects: They are formed by one particle (either single neutral "native defects", charged "native defects", single impurities or impurity-"native defect" pairs).

They can be:

  • Native defects, such as interstitials, vacancies, neutral (I, V) or charged (IP, IM, VM, VMM, VP, VPP).

  • Substitutional dopants pairs, such as Bi (boron + interstitial), AsV (arsenic + vacancy), etc. [1]

Particles involved

Any particle.

Events allowed

  • Migration [1].

  • Break-up (for pairs only):

    • Releasing an interstitial (e.g. Asi -> As + IM).

    • Releasing a vacancy (e.g. AsV -> As + VM).

Interactions allowed

  • Interactions among point defects are set in the DDP file, section PointD Interactions. PointD Interactions are set to be false by default. To enable one interaction please use the keyword "EnableInteraction" and then write the two species to interact, the result of the interaction (AmPock, PointD or ImpCluster) and the type of ImpCluster (I or V) or the resulting point defect (none for AmPock). For instance, if we want to enable the interaction between boron and interstitial to create an interstitial boron, we should add to DDP file:

    EnableInteraction I B     PointD Bi

    Please, see [2, 3, 4, 5, 6, 7] for further information.

  • Interactions with other defects are explained in the corresponding sections of those defects.

Related DADOS mechanisms

  • Charge update.

  • Point defect implementation.

Comments

  1. All mobile particles are point defects, but not all point defects are mobile. All defects are implemented in the same way, and for those which are immobile, the prefactor of migration is set to zero.

  2. Break-up reactions implemented in DADOS are those that keep the total charge (Martin-Bragado et al. 2005). For instance, AsV (neutral) would break up as As + VM (because the charges or As and VM are +1 and -1 respectively).

  3. Break-up mechanism can not be currently cancelled using the EnableInteraction keyword [4] in the DDP file.

  4. It is not recommended to allow an interaction that would be the reverse process of a break-up reactions in which the charge would not be (and that, in consequence, is not implemented [3]) kept. For instance,

    EnableInteraction IP C        PointD Ci

    Because CiP, the hypothetical result, is not implemented, and problems of microscopic reversibility would appear.

  5. Interactions among point defects that eventually would lead to recombination can be allowed with no noticeable problems of microscopic reversability because their reverse reactions (involving generation) would be in any case very infrequent.

  6. In the EnableInteraction sentence, we do not specify the charge in the resulting point defect because DADOS handles it. For instance: EnableInteraction I B PointD Bi, will give as a result BiM, or EnableInteraction I AsVM PointD As will give as a results AsP because in the recombination process it is not necessary to keep the charge.

  7. It is not allowed the interaction of particles of the same charge sign in order to assess short range coulombic repulsions.
    8. Long range coulombic attractions and repulsions in DADOS, are implemented by means of the electric drift (Martin-Bragado et al. 2005).

SiInterface

Description

Silicon interface: Two materials are needed here. One of them must be silicon and the other can be silicon oxide, silicon nitride or ambient [2] (these are the ones currently implemented in DADOS).

Particles involved

SiInterface is not formed by particles, but it counts the number of single impurities trapped on it (see trapping).

Events allowed [1,3]

  • Single neutral native defects emission. [5,6]

  • Dopants emission: AsV, Asi, Bi, Ci, F, Phi, PhV.

Interactions allowed [3]

  • Captures of: mobile neutral point defects: I, V, AsV, Asi, Bi, Ci, F, Phi, PhV.

Related DADOS mechanisms

  • Interface implementation.

  • Segregation.

  • Trapping.

Related physical magnitudes

  • Recombination length. [4]

  • Solubility.

Comments

  1. Events are the reverse processes of captures.

  2. Silicon-amorphous is not managed as an interface because it neither traps nor emit interstitials or vacancies (at least not in the same way as others).

  3. Both interactions and events are only implemented with neutral particles.

  4. The probability of capture of interstitials and vacancies is controlled by the recombination length, defined in the DDP file by the parameter RecLnm.

  5. The emission rate for interstitials and vacancies can be set different from the equilibrium one by using the command SuperSat.

  6. No interfaces are considered in the border between silicon and silicon-germanium or silicon-germanium and silicon-germanium (alloys) because they neither trap nor emit interstitials or vacancies (at least not in the same way as others). [TO BE DEVELOPED]

SuperSat

See Supersaturation.

Comments

  1. Supersaturation is included here to help visualization. After choosing the particle (interstitials or vacancies), you are allowed to choose the SuperSat option in defects.

Voids

Description

Voids: Rounded extended defects of neutral vacancies.

Particles involved

Neutral vacancies.

Events allowed

  • Neutral vacancy emission [3].

Interactions allowed

  • Neutral vacancy capture (growth).

  • Interstitial capture and recombination [1].

Related DADOS mechanisms

  • Amorphous pocket to void transformation.

  • Void implementation.

Comments

  1. Recombination is immediate, as in DADOS, activation energy for void shinkage is assumed to be zero.

  2. Particles in voids are immobile.

  3. Neutral interstitial emission will be developed.


Viewing results

UVAS provides a wide data structure in order to view all results from complex simulations.

In this section, these topics will be explained:

  • Data structure.

  • Extracting and viewing results.


Data structure

At certain moments during the simulation, UVAS collects all the information about it and saves it. This is called a snapshot. Data structure are then build by snapshots, which can be seen as vector elements:

In each snapshot, you can find a lot of information about the current simulation. These data include:

  • Time (in seconds).

  • Number of events occurred.

  • Temperature (in degrees centigrade ).

  • SheetRho: Sheet resistance (in ohms).

  • Atomic Configuration:

    • Coordinates (x,y,z): Positions where an element (defect point, dopant,...) is found.

    • Particle type: See particles.

    • Dopant type: See dopants.

    • Defect type: See defects.

    • Defect size: See defects.

  • Profile points: A plot of profiles along the x axis. The number of points shown is defined by the command Set_Output_Options. Some data are shown here:

    • x: Depth.

    • Electrons and holes per cm-3.

    • Conduct and valence band energies in eV.

    • Biaxial strain: Lattice parameter deviation from the silicon standard. [TO BE DEVELOPED]

    • Ge fraction. [TO BE DEVELOPED]

    • Ge per cm-3. [TO BE DEVELOPED]

    • Average concentration: Concentration of mobile particles (interstitials and vacancies, either single or associated with a dopant). As it is difficult to get these particles in each snapshots, UVAS makes a time average by counting the hops. If there are no hops (immobile particles or too low temperature or too short time between snapshots) this average concentration will not be reliable.

    • Instantaneous concentration of different particle types: Concentration of immobile particles.

    • Total number of particle types. The sum of the last two parameters.

  • Dopants XY, dopants concentration distribution in XY plane, including information listed:

    • Position in the simulation box.

    • Defect type: See defects.

  • Extended defect histogram gives full information about I or V in amorphous pockets, I311, dislocation loops and voids.

  • Amorphous pockets histogram (structure) provides with information about the number of interstitials and vacancies in amorphous pockets and its concentration.

  • Amorphous pockets histogram (min(I,V)) gives the concentration of the number of interstitial-vacancy pairs in amorphous pockets.

  • Amorphous pockets histogram (I+V) gives the concentration of the total number of interstitials and vacancies in amorphous pockets.

  • Binary complex map collects information about complexes during process, such as interstitials with B or C, or vacancies with As, F, O or P.

  • Bulk shows the concentration of particles in amorphous pockets, complexes, dislocation loops, 311 clusters, platelets, point defects, Si interfaces, interstitials supersaturation and voids in the bulk.

    • The concentrations shows for amorphous is used to visualize amorphous regions.

  • Interface stores the number of particles in the interface between material 0 and material 1.

Data structure can be accessed through Data browser in UVAS interface:


Extracting results

Extracting and viewing results

When a simulation has started, data structure is created and is being filled with information from the current simulation. Remembering the data structure, we can work with it as elements of a vector. Each element is a snapshot, and each snapshot has a lot of information, some of them can be seen as new vectors.

Two ways are available to see simulation results: text and graphic mode.

Text mode

Use Data browser in order to access data values. First of all, please click on "Snapshots" in the results tree. By using the vector treatment section, you can choose the snapshot whose information you want to access to. In the example shown, simulation has yielded 9 snapshots.

Once selected, you can click on any element of the snapshot. Please notice that some elements can be vectors, in whose case, this symbol will appear: . In this case, you can select new elements from these vectors, in an iterative way.

Graphic mode

Most of times, it is much better to see graphics in order to analyse better the results. Every element from data structure can be graphically represented. Basically, two types of graphics are implemented in UVAS:

  • 2D Graphs: Used for representing profiles in one dimension (depth, x), concentrations versus time, etc.

  • 3D Graphs: Used for representing atomic profiles.

Click here in order to know how to plot generic data in UVAS.

Transferring data into a file

Sometimes, it might be useful to have the results of a simulation in a text file. For doing this (see figure below):

  1. Click on the series to save in the Series Selector.

  2. Click on ">> Graph" in the Data Printer. You will see the series title in the box next to the button.

  3. Click on "Print" and you will get the results in a text mode.

  4. Select all the text by right clicking and copy it into a file.

"Clear" button is used to erase the content shown in the box whereas "Remove" eliminates the series in the Data Printer.


2D Graphs

2D graphs UVAS implementation has an appearance as shown:

XY coordinates change automatically only my moving the mouse cursor onto the graph area.

Subwindows appear by double-clicking on the indicated areas of the 2D graph window.

  • Title options: Both title and font size can be changed.

  • Legend properties:

    • Margin.

    • Text: Size of text.

    • Number of symbols: Number of symbols in the legend. They represent values from simulation in the graph.

  • Axis options (valid for both abscissas and ordinates axis):

    • Title.

    • Axis values: You can limit the axis values and setting tics for it. Log scale and grid are also available in UVAS.

  • Series selector: This is the most important part of UVAS graphics. Here is where UVAS is indicated what to draw. In terms of appearance, you can set here the title for each series, and the symbols and sizes employed. If you want to learn how to plot results, please click here.

If you right click on the draw area, you will find interesting options:

  • Autoscale: Automatically adjusts axis to their minimum and maximum values.

  • Series...: Opens series selector.

  • Export...: Creates files with different formats (GIF, PNG, EPS,...).


3D Graphs

3D graphs in UVAS is basically used to plot atomic configuration in the simulation box. Its general appearance is shown below:

As can be seen, only interesting elements are plotted (point defects, dopants,...) according to atomistic simulation principles. Coordinates are shown by both angles on the top left corner and by cartesian axis on the top right. If you click on the draw area and keep pushed, you can move the box and therefore change the angle of view.

Many of the available options are the same as in 2D Graphs, and can be checked here. By right clicking, on access a sub-menu with these options:

  • Series...: Opens series selector.

  • Miller indices...: Changes miller indices.

  • View...:

    • Bigger and Smaller: Changes the size of the box.

    • Fix in window: It is the autoscale option.

    • External viewer.

  • Export...: Creates files with different formats (GIF, PNG, EPS,...). One of the most useful one is the xyz format, because it generates a file which can be opened with RASMOL. Figure below shows an example of this:


Plotting data

For all cases, please create a new 2D or 3D graph, as required. After that, open the results tree and double click on the draw area in order to open Series Selector.

You can use all the graphs you want and save them. For doing this, click on View -> Save graphics. A GPH file will be created, that can be opened for other simulations (it is not compulsory to use it with the same type of simulation as this file does only work with the data structure, but not with specific scripts).

You only need to know what you want to plot. Remember data and snapshots structures. Choose parameters to be shown in the Data Browser and, when selected, click on "x", "y" or "z" in the Series Selector. Let´s see some examples:

  • Plotting the number of electrons or holes versus depth.

  • Plotting the concentration of a mobile type of particle versus depth.

  • Plotting the concentration of an immobile type of particle versus depth.

  • Plotting the concentration of a type of particle versus time.

  • Plotting the concentration of a type of particle versus temperature.

  • Plotting the atomic configuration.

  • Plotting only some structures from the atomic configuration.

  • Viewing the evolution in different times.

  • Plotting amorphous pockets histograms (I): I+V or min(I,V).

  • Plotting amorphous pockets histograms (II): I and V contained.

  • Plotting complex maps.

  • Plotting a particular complex versus time.

  • Plotting dopants histograms.

  • Plotting more than one graph in the same draw area.

Plotting the number of electrons or holes versus depth

See carriers and Fermi levels.

A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "Last Value". We are going to plot only the last snapshot, corresponding to the last simulated time (click here to learn how to plot different times).

  2. Open <ProfilePoints> and select "All Values", because we want to see all the information from the last snapshot.

  3. Select "x" and click on "x" in the Series Selector.

  4. Do the same with "Electrons/cm3" and "y".

  5. Click on "Update".

This method is also valid to plot conduction band, valence band, biaxial strain, Ge fraction and Ge concentration.

Plotting the concentration of an immobile type of particle versus depth

See concentrations.

A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "Last Value". We are going to plot only the last snapshot, corresponding to the last simulated time (click here to learn how to plot different times).

  2. Open <ProfilePoints> and select "All Values", because we want to see all the information from the last snapshot.

  3. Select "x" and click on "x" in the Series Selector.

  4. Click on "Instant.Conc.<P_type>" and select "Index", where you will be able to choose the type of particle (I, V, dopants,...).

  5. Do the same for <Defect type> and choose the state of the particle (point defect, amorphous,...). Remember you will get plotted here only immobile particles, such as I or V in clusters, amorphous pockets, substitutional dopants,...

  6. Click on "y" while "Profile" is selected and update the graph.

Plotting the concentration of a mobile type of particle versus depth

See concentrations.

A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "Last Value". We are going to plot only the last snapshot, corresponding to the last simulated time (click here to learn how to plot different times).

  2. Open <ProfilePoints> and select "All Values", because we want to see all the information from the last snapshot.

  3. Select "x" and click on "x" in the Series Selector.

  4. Click on "Average Conc.<P_type>" and select "Index", where you will be able to choose the type of particle (I, V, dopants,...). Remember you will get plotted here only mobile particles, such as free I or V, interstitial dopants,...

  5. Click on "y" while "Particles/cm3" is selected and update the graph.

Notice that the concentration here is much lower than in the case of immobile particles, in agreement with theoretical results.

The last option in <ProfilePoints> is "Total: <Particle Type>" which is obviously used to plot both mobile and immobile particles. The algorithm followed to do it is exactly the same than for plotting mobile particles.

Plotting the concentration of a type of particle versus time

See concentrations.

A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "All Values". We are going to plot all the snapshots, as we want to see the entire simulation.

  2. While "Time" item selected, click on "x" in Series selector.

  3. Open <ProfilePoints>, select "Index", and choose the type of particle. If you want to plot immobile particles, do exactly the same for "Instant.Conc.<P_type>" and finally, choose the state of the particle from the "Index" item in <Defect type>. If you want to plot mobile particles, do the same for "Average Conc.<P_type>".

  4. Click on "y" while Profile is selected and update the graph.

Plotting the concentration of a type of particle versus temperature

See concentrations.

Plotting a concentration versus temperature is similar to the plot versus time. Let's give an example with the number of electrons.

A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "All Values". We are going to plot all the snapshots, as we want to see the entire simulation.

  2. While "Temperature" item selected, click on "x" in Series selector.

  3. Open <ProfilePoints> and select "Last Value".

  4. While "Electrons/cm3" item selected, click on "y" in Series selector.

  5. Click on "Update".

Plotting the atomic configuration

A new 3D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "Last Value". We are going to plot only the last snapshot, corresponding to the last simulated time (click here to learn how to plot different times).

  2. Open <AtomConfig> and select "All Values", because we want to see all the information from the last snapshot.

  3. While selected <AtomConfig>, click on "x" and the three dimensions will be automatically set in the Series Selector.

  4. Click "Update" to plot.

If we uncheck the "Fixed" option, UVAS will draw with different colors according to the type of particle:

Plotting only some structures from the atomic configuration

Let's supposse we have an atomic configuration plotted on a 3D graph. Series selector provides with a tool for selecting only some particles to be drawn. First of all, the particle type must be chosen (I, V, dopants,...), and then, if necessary, a configuration can be, as well, selected (amorphous, I311,...). UVAS allows to select different conditions in order to provide a wide range of possibilities, such as plotting only I in 311 (==), everything but I (!=), etc. When you have everything defined, please click on "Update". In the figure below, we have plotted arsenic in any configuration except in amorphous:

Particle type | == | As
Defect type | != | Amorphous

Viewing the evolution in different times

This is valid for both 2D and 3D graphs, but not plots versus time obviously.

  1. Once plotted, please move up to the last frame.

  2. Select the "Time" item in the results tree and click on the indicated part of the Series Selector.

  3. When moving the bar, graph will be automatically updated. Notice that now, in the box next to this bar, the time will be shown.

Plotting amorphous pockets histograms (I): I+V or min(I,V)

See amorphous pockets.

Use this solution in order to plot the number of I+V or min(I,V) versus depth. A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "Last Value". We are going to plot only the last snapshot, corresponding to the last simulated time (click here to learn how to plot different times).

  2. Open "AmPock histo" (the one you prefer, <minIV> or <IplusV>) and select "All Values", because we want to see all the information from the last snapshot.

  3. While selected "Particles/cm3", click on "y" in the Series Selector.

  4. Click "Update" to plot.

Plotting amorphous pockets histograms (II): I and V contained

See amorphous pockets.

Use this solution in order to plot the number of I and V contained in the amorphous pockets. A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "Last Value". We are going to plot only the last snapshot, corresponding to the last simulated time (click here to learn how to plot different times).

  2. Open "AmPock histo: <Struct>" and select "All Values", because we want to see all the information from the last snapshot.

  3. While selected "number of I", click on "x" in the Series Selector.

  4. Do the same for "number of V" and "y", and for "Particles/cm3" and "z".

  5. In the Series Selector, use "Rectangle" as a symbol with a big size in order to get an homogeneous result.

  6. Uncheck the "Fixed" option and click on "From" button. Automatically, "Particles/cm3" will appear in the box on the right. This means we are going to use a range of colors to plot the different amount of amorphous pockets of each size.

  7. Now, we have to define the limits: the lower is usually zero, and the top level is normally set to a value a bit higher than the highest in the results vector, which can be seen in the Data viewer by clicking on "Particles/cm3". For very large spans, it is highly recommended to check the option "Log color".

As we can see in the picture below, the plot shows the different amount of amorphous pockets in the simulation. Abscissas axis indicates the number of interstitials, while ordinates axis is used for the number of vacancies. Actually, it is a 3D plot in which the third coordinate is plotted by means of colors.

Plotting complex maps

See complexes.

Use this solution in order to plot the number of particles contained in complexes. A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "Last Value". We are going to plot only the last snapshot, corresponding to the last simulated time (click here to learn how to plot different times).

  2. Open "<BinComplexMap>" and select "All Values", because we want to see all the information from the last snapshot.

  3. While selected "n", click on "x" in the Series Selector.

  4. Do the same for "m" and "y".

  5. Open "<Type>" and and choose one of the available options for complexes: InBm, InCm, VnAsm, VnOm, VnFm, VnPhm. Index "n" represents the number of native defects in the complex and index "m" represents the number of dopants in the complex.

  6. While selected "# of defects" in the Data browser, uncheck the "Fixed" option and click on "From" button. Automatically, "# of defects" will appear in the box on the right. This means we are going to use a range of colors to plot the different amount of amorphous pockets of each size.

  7. Now, we have to define the limits: the lower is usually zero, and the top level is normally set to a value a bit higher than the highest in the results vector, which can be seen in the Data viewer by clicking on "# of defects". For very large spans, it is highly recommended to check the option "Log color".

As we can see in the picture below, the plot shows the different amount of complexes in the simulation. Abscissas axis indicates the number of interstitials, while ordinates axis is used for the number of dopants. UVAS limits both "n" and "m" with a maximum of 9 each one.

Plotting a particular complex versus time

See complexes.

Remember how to plot complex maps. Index "n" is used by UVAS to represent number of I or V and index "m" was employed for number of dopants. If we want to represent the number of a complex, such as VnAsm, we have to represent it just by indicating subindex "nm". For example, for V1As2, set index "12".

A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "All Values". We are going to plot all the snapshots, as we want to see the entire simulation.

  2. While "Time" item selected, click on "x" in Series selector.

  3. Open <BinComplexMap>, select "Index", and choose the index correspondent to the complex you want to plot.

  4. Click on "Type" and choose the generic complex.

  5. Click on "y" while "# of defects" is selected and update the graph.

Plotting dopants histograms

Use this solution in order to plot the concentration of dopants contained in a projection over the XY plane. A new 2D graph is required for this.

  1. Select <Snapshots> item in the Data browser and then click on "Last Value". We are going to plot only the last snapshot, corresponding to the last simulated time (click here to learn how to plot different times).

  2. Open <DopantsXY> and select "All Values", because we want to see all the information from the last snapshot.

  3. While selected "x", click on "x" in the Series Selector.

  4. Do the same for "y" and "y".

  5. In the "Dopants" section, select the dopant from the "Index" part. Select also the "Defect type", which can be complex or point defect.

  6. While selected "Dopants/cm3", select "z" in the Series Selector.

  7. In the Series Selector, use "Rectangle" as a symbol with a big size in order to get an homogeneous result.

  8. Uncheck the "Fixed" option and click on "From" button. Automatically, "Dopants/cm3" will appear in the box on the right. This means we are going to use a range of colors to plot the different concentration of dopant in each position.

  9. Now, we have to define the limits: the lower is usually zero, and the top level is normally set to a value a bit higher than the highest in the results vector, which can be seen in the Data viewer by clicking on "Dopants/cm3". For very large spans, it is highly recommended to check the option "Log color".

As we can see in the picture below, the plot shows the different concentration of dopant. Abscissas axis indicates the X, while ordinates axis is used for the Y. Actually, it is a 3D plot in which the third coordinate is plotted by means of colors.

Plotting more than one graph in the same draw area

Obviously, you are only allowed to plot more than one graphs in the same draw area if abscissas are the same.

  1. Create a new series in the Series Selector by clicking in "New".

  2. Do the same as for plotting the former.

  3. Use this way to plot as many data as required.


Physical parameters

Input physical parameters

Input parameters file is the file used to store all the parameters used in simulations. When a simulation is executed (see how to create a simulation), UVAS asks for a DDP file, whose name is usually dados.ddp but it can be whatever.

In the following sections, an interrogation mark (?) is used to stand for a particle. For instance, Eb_? is the binding energy for particle "?", such as Eb_Ci (binding energy for interstitial-carbon).

Input parameters file is divided into different sections, which are explained by clicking on the items below:

  • Global options.

  • Thermal generation.

  • Point defects migration.

  • Point defects binding.

  • Electronic levels.

  • Band gap.

  • Amorphization and recrystallization.

  • Clusters.

  • I311.

  • Dislocation loops.

  • Platelets.

  • Voids.

  • Complexes.

  • Interfaces.


DDP File

DDP File (Last version)

This is a file where UVAS reads the physical parameters for the simulation.

DDP file has key words representing parameters and its values. These words can be:

  • Single: One key word plus the parameter value. For instance: Em_C 5 (the migration energy for carbon is 5 eV).

  • Compound: One key word plus another value indicating a particle plus the parameter value. For instance: D0_ClusterProp V 10 (this prefactor for vacancies clusters is 10 cm2/s).

Also, some parameters for clusters and complexes are defined with different values depending on the size. Click here to know more about the data structure for these ones.

Comments

  1. Parameters can be in any position within the file.
  2. If the key word is not given, the parameter is skipped.
  3. Comments can be added to the DDP file but they must not include key words, since UVAS would treat them as real parameters.

(WARNING: search // for possible changes)
060628 new As and B parameters
060626 new Phosphorus parameters
060615 Version 14, new BIC parameters
060612 different IV gen/rec at Si interfaces
060606 new amorphiz. parameters
-------------------------------
(GLOBAL OPTIONS)

randomSeed 1 (int from 1 to 31327)
BitsBoxes 19 (max. number of boxes = 2^bitsbxs)
ChargeVarPercent 0.20 (maximum relative error allowed in Fermi level updates)
InitOutputTime 1.0 s
DebugFlag 4 (0:Normal, no debug; 1:No interactions between particles;
2:Intrinsic Fermi level; 3:MB statistics;
4:extended defects periodic in YZ, but diffusion jumps always mirror)

T-ramps: intervals from T-high are pow(dTBase,nInit+n) up to their max. (dTLimit)
dTBase 2.0 (>1.) nInit 1 (int) dTLimit 20.0 degrees
--------------------------------------------------------------------------------

(POINT DEFECTS)

(Interstitial and Vacancy thermal generation)
C0relEq_I 1e4 (adim.) Eform_I 4.0 (eV)
C0relEq_V 1300 (adim.) Eform_V 3.8 (eV)

(Single Point Defects: migration)
Dm_V 1.e-3 (cm2/s) Em_V 0.4 (eV)
Dm_I 5e-2 Em_I 0.8
Dm_O 0.13 Em_O 2.53
Dm_C 0. Em_C 5.
Dm_B 0. Em_B 5.
Dm_F 5e-3 Em_F .8
Dm_H 1e-3 Em_H 1.1 (??)
Dm_In 0. Em_In 5.
Dm_As 0. Em_As 5.
Dm_Ph 0. Em_Ph 5.
Dm_Sb 0. Em_Sb 5.

(Charged Single Point Defects V-, V--, V+, V++, I-, I+: migration)
Dm_VM 1.e-3 (cm2/s) Em_VM 0.4 (eV)
Dm_VMM 1.e-3 (cm2/s) Em_VMM 0.5 (eV)
Dm_VP 1.e-3 (cm2/s) Em_VP 0.6 (eV)
Dm_VPP 1.e-3 (cm2/s) Em_VPP 0.8 (eV)
Dm_IM 5e-2 Em_IM 0.8
Dm_IP 5e-2 Em_IP 0.8

(Ci atom)
Dm_Ci 1.e-3 (cm2/s) Em_Ci 0.87 (eV) (migration)
Db_Ci 2.5 (cm2/s) Eb_Ci 1.7 (eV) (binding)

(Bi- atom)
Dm_BiM 1.e-3 (cm2/s) Em_BiM 0.3 (eV) (migration)
Db_BiM 0.9 (cm2/s) Eb_BiM 0.25 (eV)

(Bi atom)
Dm_Bi 1.e-3 (cm2/s) Em_Bi 0.1 (eV) (migration)

(Bi+ atom)
Dm_BiP 1.e-3 (cm2/s) Em_BiP 1.4 (eV) (migration)

(InV- Pair)
Dm_InVM 0. (cm2/s) Em_InVM 5. (eV) (migration)
Db_InVM 1.5e-3 (cm2/s) Eb_InVM 1.6 (eV) (binding)

(InV Pair)
Dm_InV 0. (cm2/s) Em_InV 5. (eV) (migration)

(Ini- atom)
Dm_IniM 2. (cm2/s) Em_IniM 2.2 (eV) (migration)
Db_IniM 0 (cm2/s) Eb_IniM 1.8 (eV) (bind)

(Ini atom)
Dm_Ini 1.6e-6 (cm2/s) Em_Ini 0.9 (eV) (migration)

(AsV+ Pair)
Dm_AsVP 1.5e-4 (cm2/s) Em_AsVP 1.3 (eV) (migration)
Db_AsVP 1e-3 (cm2/s) Eb_AsVP 1.01 (eV) (binding)

(Arsenic-Vacancy Pair)
Dm_AsV 1.5e-4 (cm2/s) Em_AsV 1.3 (eV) (migration)

(AsV- Pair)
Dm_AsVM 1.5e-4 (cm2/s) Em_AsVM 1.6 (eV) (migration)

(Asi+ atom)
Dm_AsiP 4e-2 (cm2/s) Em_AsiP 1.4 (eV) (migration)
Db_AsiP 5e-2 (cm2/s) Eb_AsiP 0.3 (eV) (binding)

(Asi atom)
Dm_Asi 4e-2 (cm2/s) Em_Asi 1.4 (eV) (migration)

(PhV+ Pair)
Dm_PhVP 0. (cm2/s) Em_PhVP 5. (eV) (migration)
Db_PhVP 5.e-3 (cm2/s) Eb_PhVP 0.6 (eV) (binding)

(Phosphorus-Vacancy Pair)
Dm_PhV 0. (cm2/s) Em_PhV 5. (eV) (migration)

(PhV- Pair)
Dm_PhVM 0. (cm2/s) Em_PhVM 5. (eV) (migration)

(Phi+ atom)
Dm_PhiP 2e-4 (cm2/s) Em_PhiP 1.3 (eV) (migration)
Db_PhiP 5e-2 (cm2/s) Eb_PhiP 1.5 (eV) (binding)

(Phi atom)
Dm_Phi 2e-4 (cm2/s) Em_Phi 1.3 (eV) (migration)

(Point defects. Electronic levels at T=0, in eV)
e_VMM0 1.06 (Fahey)
e_VM0 0.6 (Fahey)
e_VP0 0.03 (Watkins)
e_VPP0 0.13 (Watkins)
e_IM0 1.0 (J.Zhu)
e_IP0 0.35 (Bracht)
e_BiM0 0.8 (Ec-0.37 in agreement with Watkins)
e_BiP0 1.04 (Ec-0.13 in agreement with Watkins)
e_AsVM0 0.77 (Arsenic)
e_AsVP0 0.2 (Arsenic)
e_IniM0 0.6 ???(Indium)
e_InVM0 0.7 ???(Indium)
e_AsiP0 0.1
e_PhVM0 0.7 ? (Ec-0.45 after Watkings ?)
e_PhVP0 0 ???
e_PhiP0 1.1

(Band gap)
Eg0 1.17 (eV)
Agap 4.73e-4 (eV/K)
Bgap 636. (K)
Nc300 3.2e19 (cm-3)
Nv300 1.8e19 (cm-3)
expNc 1.5
expNv 1.5

(Band gap narrowing, Jain & Roulston's model.
Values, in eV, from Persson et al, JAP 86, 4419 (1999) )
Acn1_4 0
Acn1_3 -14.84e-3
Acn1_2 0.78e-3
Acp1_4 -16.27e-3
Acp1_3 0
Acp1_2 -0.18e-3
Avn1_4 15.08e-3
Avn1_3 0
Avn1_2 0.74e-3
Avp1_4 0
Avp1_3 18.46e-3
Avp1_2 -2.63e-3

---------------------------------------------------------------
(AMORPHIZATION-RECRYSTALLIZATION)

V0recryst 1.7e8 (cm/s) Erecryst 2.7 (eV) (recryst. velocity)
recrysDepositProb_As 0.3 recrysMaxActive_As 1e21 (cm-3) maxDepositedCxSize_As 4
recrysDepositProb_B 1.0 recrysMaxActive_B 3.5e20 (cm-3) maxDepositedCxSize_B 3
recrysDepositProb_Ph 0.3 recrysMaxActive_Ph 1e21 (cm-3) maxDepositedCxSize_Ph 3
recrysDepositProb_Sb 0.3 recrysMaxActive_Sb 1e21 (cm-3) maxDepositedCxSize_Sb 3

inRelDamChange 0.05 (controls the damage update frequency)
AmorphizationThreshold 1.5e22 (I+V / cm3)
MaxIVStorage 1e24 (set it to less than 1e22 for very large simulations to use less memory)
LatticeCollapse_nm3 40

ExponentAmorphousPocket 1 (prefactor dependence on size)
D0AmorphousPocket 3e-4 (cm2/s)
Eac(minIV), NObarrier, maxmergesize=50
piecewise linear interpolation, default=recryst. energy
Eb_AmorphousPocket
1 0.68
80 1.0
235 2.7
-1

---------------------------------------------------------------

(CLUSTERS)

Vacancy Clusters:

D0_ClusterProp V 10 (cm2/s)

Default energies:
Eb_SmallestCluster V 1.5 (eV)
Eb_LargeCluster V 3.7 (eV)
exponent_Cluster V 0.6667

Reassigned energies from Staab et al., PRB 2002
(No voids rippening allowed by the moment)

Eb_Cluster V
2 1.4
3 1.4
4 2.4
5 3.0
6 3.4
7 0
8 2.4
9 3.4
10 3.4
11 0
12 2.4
13 3.0
14 3.0
15 0
16 0
17 0
-1 (-1 == end of array )

---------------------------------------------------------------
Interstitial Clusters

D0_ClusterProp I 100. (cm2/s)

Default energies:
Eb_SmallestCluster I 2.48 //2.57 (eV)
Eb_LargeCluster I 3.06 //3.34 (eV)
exponent_Cluster I 0.75 //0.9

Reassigned energies (modified Cowern set):

Eb_Cluster I
2 2.45
3 2.45
4 2.62
5 2.53
6 2.7
7 2.36
8 3.15
9 2.63
10 2.58
11 2.83
12 2.92
13 2.823
14 2.823
15 2.824
16 2.824
17 2.825
18 2.825
19 2.825
20 2.826
21 2.826
22 2.827
23 2.827
24 2.827
25 2.828
26 2.828
27 2.829
28 2.829
29 2.829
30 2.83
31 2.83
32 2.831
33 2.831
34 2.831
35 2.832
36 2.832
37 2.833
38 2.833
39 2.833
40 2.834
41 2.834
42 2.835
43 2.835
44 2.835
45 2.836
46 2.836
47 2.837
48 2.837
49 2.837
50 2.838
51 2.838
52 2.839
53 2.839
54 2.839
55 2.84
56 2.84
57 2.841
58 2.841
59 2.841
60 2.842
61 2.842
62 2.843
63 2.843
64 2.843
65 2.844
66 2.844
67 2.845
68 2.845
69 2.845
70 2.846
71 2.846
72 2.847
73 2.847
74 2.847
75 2.848
76 2.848
77 2.849
78 2.849
79 2.849
80 2.85
81 2.85
82 2.851
83 2.851
84 2.851
85 2.852
86 2.852
87 2.853
88 2.853
89 2.853
90 2.854
91 2.854
92 2.855
93 2.855
94 2.855
95 2.856
96 2.856
97 2.857
98 2.857
99 2.857
100 2.858
101 2.858
102 2.859
103 2.859
-1 (-1 == end of array )

---------------------------------------------------------------
(THREEONEONEs)

MIN311SIZE 33

size0_Clusterto311 0.3 (prefactor for cluster to 311 transition size)
EClusterto311 0.35 (eV)(-Eact for cluster to 311 transition size)

---------------------------------------------------------------
(DISLOCATION LOOPS)

Transition size model:
size0_311toDLoop 1.6 (prefactor for 311 to DLoop transition size)
(set to negative to deactivate the model)
E311toDLoop 0.68 (eV)(-Eact for 311 to DLoop transition size)

Transition rate model:
R0_311ToDL 0 //4.5e11 (s-1) (set to zero to deactivate the model)
Ebar0_311ToDL 3. (eV)
Ebar1_311ToDL 3. (eV)
expo_311ToDL 2. (Ebarr=Ebar0+Ebar1/(n/N0-1)**expo)

D0DLoopProp 2e5

gamma 0.4375
mu 472
nu 0.3
burgVectMod 0.3135

---------------------------------------------------------------
(PLATELETS)

D0PlateletProp 2e5

---------------------------------------------------------------
(VOIDS)

MINVoidsSIZE 27
size0_ClustertoVoids 0.3 (prefactor for cluster to Voids transition size)
EClustertoVoids 0.35 (eV)(-Eact for cluster to Voids transition size)

---------------------------------------------------------------
(COMPLEXES)

(I_B complex)

D0F_ComplexProp I B 200. (cm2/s)

Etotal_Complex I B
1 4 -3.6 2 4 -6.7 3 4 -9.5 4 4 -11.5 5 4 -11.5
1 3 -3.4 2 3 -3.8 3 3 -6.8 4 3 -6.8
0 2 +1.7 1 2 -1.0 2 2 -3.5 3 2 -5.4
2 1 -2.5
-1 (-1 == end of array )

EbarrierB_Complex I B
-1

EbarrierF_Complex I B
-1
---------------------------------------------------------------
(I_C complex) RP
Etotal_Complex I C
0 2 -1.2
1 2 -2.3
2 2 -7
1 3 -1.7
2 3 -9.7
3 3 -11.5
2 4 -12.5
3 4 -13.7
4 4 -16
3 5 -13
4 5 -20.5
5 5 -25
4 6 -25.4
5 6 -26.9
6 6 -30.9
7 7 -35.6
8 8 -40.3
9 9 -45
-1

EbarrierB_Complex I C
-1

EbarrierF_Complex I C
-1

---------------------------------------------------------------
(V_As complex)
Etotal_Complex V As

0 4 0 1 4 -5.4
0 3 0 1 3 -4.4
0 2 0 1 2 -3.9

-1

EbarrierB_Complex V As
-1

EbarrierF_Complex V As
-1

---------------------------------------------------------------
(V_Ph complex) uncalibrated
Etotal_Complex V Ph

0 4 0 1 4 -6 2 4 -10.3
0 3 0 1 3 -6
0 2 0 1 2 -5

-1

EbarrierB_Complex V Ph
-1

EbarrierF_Complex V Ph
-1

---------------------------------------------------------------
(V_F complex)
Etotal_Complex V F
1 1 -2.38
1 2 -4.63
1 3 -7.08
1 4 -7.12
1 5 -8.5
1 6 -9.7
1 7 3
0 2 -0.5
0 3 -1
0 4 -1.5
0 5 -3
0 6 -4.5
2 1 -4.20
2 2 -7.07
2 3 -9.04
2 4 -11.47
2 5 -13.29
2 6 -16.09
-1

EbarrierB_Complex V F
-1

EbarrierF_Complex V F
-1

---------------------------------------------------------------

Other MATERIALS:
INTERFACES and IMPURITY PARAMETERS

TRAPPING --------------------------

Oh-Ward model:
Set Csol0_ to its negative value to simulate impurity IN-DIFFUSION
into the Silicon side.
Set Surf_h0 to zero to simulate impurity MIRROR interface.
Set Surf_e_a0 to zero to simulate impurity SINK interface.

(Arsenic)
Csol0_As 2.2e22 Esol_As 0.47 (electrical[substitutional] solubility)
Surf_h0_As 2.31e-2 Surf_Eh_As 0.766
Surf_e_a0_As 0.4 Surf_Ee_a_As 0
SurfMaxTrap_As 3.0e14

(Boron)
Csol0_B 1.e24 Esol_B 1.
Surf_h0_B 1.66e-2 Surf_Eh_B 0.486
Surf_e_a0_B 0.178 Surf_Ee_a_B -0.086
SurfMaxTrap_B 2.0e14

(Phosphorus)
Csol0_Ph 1.e20 Esol_Ph 0.
Surf_h0_Ph 0.715 Surf_Eh_Ph 1.75
Surf_e_a0_Ph 4e-3 Surf_Ee_a_Ph -0.37
SurfMaxTrap_Ph 6.8e14

(Carbon)
Csol0_C 0 Esol_C 0.
Surf_h0_C 100 Surf_Eh_C 0
Surf_e_a0_C 4e-3 Surf_Ee_a_C -0.37
SurfMaxTrap_C 1e18

(Fluorine)
Csol0_F 0 Esol_F 0.
Surf_h0_F 100 Surf_Eh_F 0
Surf_e_a0_F 4e-3 Surf_Ee_a_F -0.37
SurfMaxTrap_F 1e18

----------------------------------------------------

Possible material names: Oxide, Nitride, AmorphousSi.
Append the material name to the PointD parameter name.
(do not add material name for Silicon)

Set RecLnm_X to -1 for no X(I or V) surf emiss/recombination.
Set Segreg_pref_ to zero to prevent jumps to the other side.
Set Segreg_pref_ to its negative value to simulate impurity IN-DIFFUSION
into the other material.

(OXIDE) ----------------------------------------------

(Si/Oxide Interface gen/recomb)
RecLnm_VOxide 0
RecLnm_IOxide 0
SuperSat_VOxide 1
SuperSat_IOxide 1

(Arsenic)
Segreg_pref_AsOxide 0.1 Segreg_eV_AsOxide 0.0
Dm_AsOxide 2.94e-4 Em_AsOxide 3.15

(Boron)
Segreg_pref_BOxide 3.3 Segreg_eV_BOxide 0.0
Dm_BOxide 3.12e-3 Em_BOxide 3.93

(Phosphorus)
Segreg_pref_PhOxide 30.0 Segreg_eV_PhOxide 0.0
Dm_PhOxide 14.2 Em_PhOxide 4.86

(NITRIDE) ----------------------------------------------

(Si/Nitride IV gen/recomb)
RecLnm_VNitride 0
RecLnm_INitride 0
SuperSat_VNitride 1
SuperSat_INitride 1

(Arsenic)
Segreg_pref_AsNitride 30.0 Segreg_eV_AsNitride 0.0
Dm_AsNitride 2.94e-4 Em_AsNitride 3.15

(Boron)
Segreg_pref_BNitride 30.0 Segreg_eV_BNitride 0.0
Dm_BNitride 3.12e-3 Em_BNitride 3.93

(Phosphorus)
Segreg_pref_PhNitride 30.0 Segreg_eV_PhNitride 0.0
Dm_PhNitride 14.2 Em_PhNitride 4.86

(AMORPHOUS Si) ----------------------------------------------

(Si/AmorphousSi IV gen/recomb)
RecLnm_VAmorphousSi 0
RecLnm_IAmorphousSi 0
SuperSat_VAmorphousSi 1
SuperSat_IAmorphousSi 1

(Arsenic)
Segreg_pref_AsAmorphousSi 1.0 Segreg_eV_AsAmorphousSi 0.0
Dm_AsAmorphousSi 0.0 Em_AsAmorphousSi 5

(Boron)
Segreg_pref_BAmorphousSi 1.0 Segreg_eV_BAmorphousSi 0.0
Dm_BAmorphousSi 0.0 Em_BAmorphousSi 5

(Phosphorus)
Segreg_pref_PhAmorphousSi 1.0 Segreg_eV_PhAmorphousSi 0.0
Dm_PhAmorphousSi 0.0 Em_PhAmorphousSi 5

____________________________________________________________________________

--PointD Interactions------------------------------------------------------

--PointD Interactions are set to false by default. To enable one interaction
--use the keyword "EnableInteraction" and then write the two species to
--interact, the result of the interaction (AmPock, PointD or ImpCluster) and the
--type of ImpCluster (I or V) or the resulting point defect. (none for AmPock)

--I--
EnableInteraction I I AmPock none
EnableInteraction I V AmPock none
EnableInteraction I As PointD Asi
EnableInteraction I B PointD Bi
EnableInteraction I C PointD Ci
EnableInteraction I In PointD Ini
EnableInteraction I Ph PointD Phi
EnableInteraction I AsV PointD As
EnableInteraction I AsVM PointD As
EnableInteraction I AsVP PointD As
EnableInteraction I Bi ImpCluster I
EnableInteraction I Ci ImpCluster I
EnableInteraction I IM AmPock none
EnableInteraction I IP AmPock none
EnableInteraction I PhV PointD Ph
EnableInteraction I PhVM PointD Ph
EnableInteraction I PhVP PointD Ph
EnableInteraction I VM AmPock none
EnableInteraction I VMM AmPock none
EnableInteraction I VP AmPock none
EnableInteraction I VPP AmPock none
--V--
EnableInteraction V V AmPock none
EnableInteraction V As PointD AsV
EnableInteraction V F ImpCluster V
EnableInteraction V O ImpCluster V
EnableInteraction V Ph PointD PhV
EnableInteraction V Asi PointD As
EnableInteraction V AsiP PointD As
EnableInteraction V AsV ImpCluster V
EnableInteraction V Bi PointD B
EnableInteraction V BiM PointD B
EnableInteraction V BiP PointD B
EnableInteraction V Ci PointD C
EnableInteraction V IM AmPock none
EnableInteraction V IP AmPock none
EnableInteraction V Ini PointD In
EnableInteraction V IniM PointD In
EnableInteraction V Phi PointD Ph
EnableInteraction V PhiP PointD Ph
EnableInteraction V PhV ImpCluster V
EnableInteraction V VM AmPock none
EnableInteraction V VMM AmPock none
EnableInteraction V VP AmPock none
EnableInteraction V VPP AmPock none
--As--
EnableInteraction As AsVM ImpCluster V
EnableInteraction As IM PointD Asi
EnableInteraction As VM PointD AsV
EnableInteraction As VMM PointD AsV
--B--
EnableInteraction B Bi ImpCluster I
EnableInteraction B IP PointD Bi
--C--
EnableInteraction C Ci ImpCluster I
--F--
EnableInteraction F F ImpCluster V
--H--
EnableInteraction H H Platelet none
--In--
EnableInteraction In IP PointD Ini
--O--
EnableInteraction O O ImpCluster V
--Ph--
EnableInteraction Ph IM PointD Phi
EnableInteraction Ph PhVM ImpCluster V
EnableInteraction Ph VM PointD PhV
EnableInteraction Ph VMM PointD PhV
--Asi--
EnableInteraction Asi AsV ImpCluster V
EnableInteraction Asi VM PointD As
EnableInteraction Asi VMM PointD As
EnableInteraction Asi VP PointD As
EnableInteraction Asi VPP PointD As
--AsiP--
EnableInteraction AsiP VM PointD As
EnableInteraction AsiP VMM PointD As
--AsV--
EnableInteraction AsV AsV ImpCluster V
EnableInteraction AsV IM PointD As
EnableInteraction AsV IP PointD As
--AsVM--
EnableInteraction AsVM IP PointD As
--AsVP--
EnableInteraction AsVP IM PointD As
--Bi--
EnableInteraction Bi Bi ImpCluster I
EnableInteraction Bi VM PointD B
EnableInteraction Bi VMM PointD B
EnableInteraction Bi VP PointD B
EnableInteraction Bi VPP PointD B
--BiM--
EnableInteraction BiM VP PointD B
EnableInteraction BiM VPP PointD B
--BiP--
EnableInteraction BiP VM PointD B
EnableInteraction BiP VMM PointD B
--Ci--
EnableInteraction Ci Ci ImpCluster I
--IM--
EnableInteraction IM IP AmPock none
EnableInteraction IM PhV PointD Ph
EnableInteraction IM PhVP PointD Ph
EnableInteraction IM VP AmPock none
EnableInteraction IM VPP AmPock none
--IP--
EnableInteraction IP PhV PointD Ph
EnableInteraction IP PhVM PointD Ph
EnableInteraction IP VM AmPock none
EnableInteraction IP VMM AmPock none
--Ini--
EnableInteraction Ini VM PointD In
EnableInteraction Ini VMM PointD In
EnableInteraction Ini VP PointD In
EnableInteraction Ini VPP PointD In
--IniM--
EnableInteraction IniM VP PointD In
EnableInteraction IniM VPP PointD In
--Phi--
EnableInteraction Phi PhV ImpCluster V
EnableInteraction Phi VM PointD Ph
EnableInteraction Phi VMM PointD Ph
EnableInteraction Phi VP PointD Ph
EnableInteraction Phi VPP PointD Ph
--PhiP--
EnableInteraction PhiP VM PointD Ph
EnableInteraction PhiP VMM PointD Ph
--PhV--
EnableInteraction PhV PhV ImpCluster V
--PhVM--
--PhVP--
--VM--
EnableInteraction VM VP AmPock none
EnableInteraction VM VPP AmPock none
--VMM--
EnableInteraction VMM VP AmPock none
EnableInteraction VMM VPP AmPock none
______THIS_IS_THE_LAST_LINE_OF_THIS_ddp_FILE________


Global options

randomSeed

It is an integer from 1 to 31327 that DADOS uses as a seed to generate random numbers for simulations, according to Monte Carlo techniques. It can be changed in order to force to modify random values during simulations but the results will be essentially the same if the simulation box is large enough and, thus, the simulation results are statistically relevant.

BitsBoxes

Number of bits used by DADOS to split the simulation box. The default value for this parameter is 19, which means that the maximum number of boxes will be 524288. See box split for more information.

ChargeVarPercent

Parameter is used by DADOS to establish charge update frequency. It is maximum relative error allowed in Fermi level updates. It can be a value between 0 and 1. See charge update for details.

InitOutputTime

It is the time when the first snapshot is taken. It has the same function as Start Output Time in the Set_Output_Options command, although the value here is just to initialize the simulation.

DebugFlag

This parameter is only used for academic purposes. Different options can be set:

0 - Normal, no debug.

1 - No interactions between particles: DADOS will not simulate pairing, recombinations, captures, clustering,... only suface effects will take place.

2 - Intrinsic Fermi level: Silicon will be simulated as an intrinsic materials, independently of the dopants. It can be used either for testing or for speeding up simulations where there are no dopants.

3 - Maxwell-Boltzman statistics instead of Fermi-Dirac: DADOS uses, by default, Fermi-Dirac statistics instead of Maxwell-Boltzman approximation, because it is more accurate. This parameter should only be set for academic purposes, in order to compare simulation results with analytic solutions using Maxwell Boltzman approximation. No relevant speeding of the simulation is expected.

4 - Extended defects periodic in YZ plane. By default, the growth of extended defects ins constrained by the simulation box walls. This will result in a simulation artifact where no very large lateral (YZ) dimensions are used in cases with planar symmetry. The present option would avoid such an artifact. Notice that this option does not set periodicity for mobile point defects but only for extended defects (I311, dislocation loops, voids, platelets,...). Do not use this option for cases with no planar symmetry.

T-ramps: dTBase, nInit, dTLimit

DADOS implements temperature change by means of a discrete process, i.e., following a set of steps. However, at low temperatures, the number of events (basically jumps), is lower than at high ones. That is why DADOS has implemented a new method: The steps width (in time) depends on the temperature. The figure below shows this:

The algorithm is:

  1. We start at the highest temperature, dTBase.
  2. The time width for following steps is defined by Δtn = 2nInit+n, where n = 0,1,2,...
  3. If the time width is higher than dTLimit, we use dTLimit as new value.

This way, we approximately guarantee that the number of events occured in every step is the same.


Thermal generation

Eform_?

Definition

Formation energy in silicon: Neccesary energy to create a native defect from crystalline silicon.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, Eform_I is the formation energy for interstitials.

Involved particles

Single neutral "native defects".

Units

Electron-volts (eV).

Related physical magnitudes

  • Concentrations: Eform_? is the activation energy of the equilibrium concentration of single neutral "native defects" from silicon surface and interface.

Related DADOS mechanisms

  • Surface emission: Eform_? affects the emission frequency of single neutral native defects from silicon surface and interface.

Comments

  1. This formation energy affects also, as a consequence, to the formation energy of charged species and to the formation energy of impurity-"native defect" pairs.

  2. Generation of single neutral "native defects" in the volume is not implemented in DADOS, as its frequency is extemely low.

C0relEq_?

Definition

Prefactor of relative single neutral "native defects" concentration under equilibrium conditions.

Where:

  • C?,0* is the prefactor of neutral interstitials or vacancies concentration in equilibrium conditions.
  • See symbol list.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, C0relEq_I is used for interstitials.

Involved particles

Single neutral "native defects".

Units

Dimensionless.

Related physical magnitudes

  • Concentrations: C0relEq_? is the prefactor of single neutral "native defects" emission under equilibrium conditions.

Related DADOS mechanisms

  • Surface emission.

Comments

  1. For these particles, it is usual the use of the product of diffusivity and concentration in equilibrium to indicate the flux: C0relEq_? · Dm_?. When one of this parameters is modified, the other should me properly changed in order to maintain the results, at least at annealing temperatures.

  2. This prefactor affects also, as a consequence, to the prefactor emission of charged species and to the prefactor emission of impurity-"native defect" pairs.

  3. Generation of single neutral "native defects" in the volume is not implemented in DADOS, as its frequency is extemely low.


Migration

Point defects migration

Dm_?

Definition

Prefactor of diffusivity.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, Dm_Ci is the prefactor of migration for interstitial carbon.

Involved particles

Any particle.

Units

Square centimeters per second (cm2/s).

Related physical magnitudes

  • Diffusivities: Dm_? is the prefactor of diffusivity of any particle.

Related DADOS mechanisms

  • Particles jumps: Dm_? is proportional to the prefactor of Jump frequency of the particle.

Comments

  1. For some immobile species, such as B, As, C,... the diffusivity prefactor is usually set to zero. This is due to the fact that they only diffuse by means of I and V, and do not diffuse only by themselves. See effective diffusivity.

  2. For these particles, neutral interstitials and vacancies, it is usual the use of the product of diffusivity and concentration in equilibrium to indicate the flux: C0relEq_? · Dm_?. When one of this parameters is modified, the other should me properly changed in order to maintain the results, at least at annealing temperatures.

Em_?

Definition

Migration energy.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, Eb_Ci is the migration energy for interstitial carbon.

Involved particles

Any particle.

Units

Electron-volts (eV).

Related physical magnitudes

  • Diffusivities: Em_? is the activation energy of diffusivity of any particle. If the particle is an impurity-"native defect" pair, it affects to the effective diffusivity of the dopant. However, if the particle is a native defect (either neutral or charged), it affects the self-diffusivity.

Related DADOS mechanisms

  • Particles jumps: Em_? affects the Jump frequency of the particle.


Point defects binding

Db_?

Definition

Prefactor of break-up frequency, expressed in diffusivity units.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, Db_Ci is the prefactor of binding for interstitial carbon.

Involved particles

Impurity-"native defect" pairs.

Units

Square centimeters per second (cm2/s).

Related physical magnitudes

  • Effective diffusivity of impurities.

  • Long-hop distance of immobile impurities.

  • Concentration of trapped native defects.

Related DADOS mechanisms

  • Break-up.

  • Emission from complexes.

  • Particles jumps.

Comments

  1. This parameter is only used for pairs.

  2. When the impurity-"native defect" pair has several possible charge states, DADOS only reads the Db value of one of them, as the break-up prefactors of the different charge states are related. See break-up of charged pairs. DADOS reads the Db value of the species with the same charge state as the impurity, e.g., BiM has the charge state ''-1'', the same as B.

Eb_?

Definition

Binding energy.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, Eb_Ci is the binding energy for interstitial carbon.

Involved particles

Impurity-"native defect" pairs.

Units

Electron-volts (eV).

Related physical magnitudes

  • Effective diffusivity of impurities.

  • Long-hop distance of immobile impurities.

  • Concentration of trapped native defects.

Related DADOS mechanisms

  • Break-up.

  • Emission from complexes.

Comments

  1. This parameter is only used for pairs.


Electronic levels

e_?0

Definition

Charge level at 0 K, measured from the valence band edge.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, e_AsVP0 is the charge level at 0 K for positive arsenic-vacancy [1].

  • If the particle indicated by interrogation mark (?) is positive, with charge "j", e_?0 denotes the charge level (at 0 K) for the transition between charge states "j-1" and "j". For instance, e_AsVP0 is the charge level for the transition between AsV and AsV+, and can be also denoted by eAsV(+,0).

  • If the particle indicated by interrogation mark (?) is negative, with charge "j", e_?0 denotes the charge level (at 0 K) for the transition between charge states "j" and "j+1". For instance, e_VMM0 is the charge level for the transition between V- - and V-, and can be also denoted by eAsV(-,- -).

Involved particles

Charged particles with other possible charge state. See particles list.

Units

Electron-volts (eV).

Related physical magnitudes

  • Concentrations.

  • Formation energies for charged species

Related DADOS mechanisms

  • Probabilities and charge states.

Comments

  1. According to this notation, if the particle is neutral, this parameter is not defined and it would be ignored if found in the DDP file.

  2. When the Fermi level, eF, is at e(j-1,j), the probability of "j-1" and "j" states is the same.

  3. e_?0 sets the relation among the binding energies of different charge states of an impurity-"native defect" pair.


Band gap

Eg0

Definition

Silicon band gap witdh at 0 K.

Units

Electron-volts (eV).

Related physical magnitudes

  • Fermi level.

  • Intrinsic density and intrinsic levels.

Related DADOS mechanisms

  • Temperature dependance of band structure.

Agap

Definition

Constant used for band gap width calculation (see temperature dependance of band structure).

Units

Electron-volts per kelvin (eV/K).

Related DADOS mechanisms

  • Temperature dependance of band structure.

Bgap

Definition

Constant used for band gap width calculation (see t temperature dependance of band structure).

Units

Kelvin (K).

Related DADOS mechanisms

  • Temperature dependance of band structure.

Nc300

Definition

Effective density of states of the conduction band at 300 K.

Units

States per cubic centimeter (cm-3).

Related physical magnitudes

  • Fermi level.

  • Intrinsic density and intrinsic levels.

Related DADOS mechanisms

  • Temperature dependance of band structure.

Nv300

Definition

States density in the valence band at 300 K.

Units

States per cubic centimeter (cm-3).

Related physical magnitudes

  • Fermi level.

  • Intrinsic density and intrinsic levels.

Related DADOS mechanisms

  • Temperature dependance of band structure.

expNc

Definition

Exponent used to calculate the states density in the conduction band.

Units

Dimensionless.

Related physical magnitudes

  • Fermi level.

  • Intrinsic density and intrinsic levels.

Related DADOS mechanisms

  • Temperature dependance of band structure.

expNv

Definition

Exponent used to calculate the states density in the conduction band.

Units

Dimensionless.

Related physical magnitudes

  • Fermi level.

  • Intrinsic density and intrinsic levels.

Related DADOS mechanisms

  • Temperature dependance of band structure.

A??1_?

Definition

Parameters used to calculate carrier-related band gap narrowing (see b and gap narrowing).

Interrogation marks (?) are used to indicate the use of this set of parameters in different expressions. For instance: Acp1_3 is used for the conduction band (c) in a p-semiconductor (p); last value (3) is used used as a denominator in exponents in the band gap calculation.

Units

Dimensionless.

Related DADOS mechanisms

  • Band gap narrowing.


Amorphization

Amorphization and Recrystallization

V0recryst

Definition

Prefactor of recrystallization velocity.

Units

Centimeters per second (cm/s).

Related DADOS mechanisms

  • Recrystallization.

Erecryst

Definition

Activation energy for the recrystallization.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Recrystallization.

recrysDepositProb_?

Definition

Probability that an impurity stays as a substitutional structure in an amorphous box which is going to recrystallize instead or being transferred into another amorphous box following the direction indicated by the recrystallization front.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, recrysDepositProb_As is the probability for arsenic.

Involved particles

  • Single impurities.

Units

Dimensionless.

Related DADOS mechanisms

  • Recrystallization.

recrysMaxActive_?

Definition

Maximum concentration of active impurities that can be deposited as complexes in an amorphous box which has recrystallized.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, recrysMaxActive_As is the maximum concentration of arsenic.

Involved particles

  • Impurities in amorphous regions.

  • Single impurities.

Units

Particles per cubic centimeters (cm-3).

Related DADOS mechanisms

  • Recrystallization.

maxDepositedCxSize_?

Definition

Maximum number of atoms that can be included in a complex created from impurities deposit in an amorphous box which has recrystallized.

Interrogation mark (?) is used to indicate the particle for which the parameter is defined, for instance, maxDepositedCxSize_As is the maximum number of arsenic atoms in a complex in the recrystallization process.

Involved particles

  • Single impurities.

Units

Dimensionless.

Related DADOS mechanisms

  • Recrystallization.

inRelDamChange

Definition

When the damage profile has been modified in a percentage indicated by this parameter, an update will take place.

Units

Dimensionless

Related DADOS mechanisms

  • Amorphization.

AmorphizationThreshold

Definition

Minimum level of interstitials plus vacancies concentration to consider a region to be amorphous. These particles can be point defects or belong to an amorphous pocket.

Units

Particles per cubic centimeter (cm-3).

Related DADOS mechanisms

  • Amorphization.

MaxIVStorage

Definition

Maximum level of interstitials plus vacancies concentration to store each particle's coordinates in memory. From this level, DADOS will only count the number of particles (Rubio et al. 2004).

Units

Particles per cubic centimeter (cm-3).

Related DADOS mechanisms

  • Amorphization.

Comments

  1. Obviously, if resources saving is wanted, MaxIVStorage must be lower than AmorphizationThreshold, due to the fact that over this concentration, silicon is transformed into amorphous silicon and no particles are stored for this material.

  2. If the concentration is too low, DADOS will convert it into the minimum value, with is the equivalent to one particle per box size.

LatticeCollapse_nm3

Definition

If a silicon region is surrounded by amorphous silicon and its volume is equal or lower than the one indicated by this parameter, it will amorphize. This avoids to have small non-amorphous regions which are a source of recrystallization.

Units

Cubic nanometers (nm3).

Related DADOS mechanisms

  • Amorphization.

ExponentAmorphousPocket

Definition

Exponent used for the activation energy calculation.

Units

Dimensionless.

Related DADOS mechanisms

  • Amorphous pocket implementation.

D0AmorphousPocket

Definition

Proportional to the prefactor of dynamic annealing for amorphous pockets.

Units

Square centimeters per second (cm2/s).

Related DADOS mechanisms

  • Amorphous pocket implementation.

Eb_AmorphousPocket

Definition

Activation energy for dynamic annealing in amorphous pockets.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Amorphous pocket implementation.


Clusters

Both interstitials and vacancies clusters are similarly implemented in DADOS.

D0_ClusterProp ?

Definition

Proportional value to the prefactor of emission for extended defects.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, D0_ClusterProp I is the value for interstitials clusters.

Involved particles

Single neutral "native defects".

Units

Square centimeters per second (cm2/s).

Related DADOS mechanisms

  • Cluster implementation.

Eb_SmallestCluster ?

Definition

Limit in binding energy for lowest cluster size (2) when using generic function.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Eb_SmallestCluster I is the lowest limit in binding energy for interstitials clusters.

Involved particles

Single neutral "native defects".

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Cluster implementation.

Eb_LargeCluster ?

Definition

Limit in binding energy for highest cluster size when using generic function.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Eb_LargeCluster I is the highest limit in binding energy for interstitials clusters.

Involved particles

Single neutral "native defects".

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Cluster implementation.

exponent_Cluster ?

Definition

Exponent used for the binding energy calculation when using generic function.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, exponent_Cluster I is the value for interstitials clusters.

Involved particles

Single neutral "native defects".

Units

Dimensionless.

Related DADOS mechanisms

  • Cluster implementation.

Comments

  1. This parameter must be lower than 1 and higher or equal to 0, in order to get a convergent function.

Eb_Cluster ?

Definition

Binding energy for clusters when using generic function.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Eb_Cluster I is the binding energy for interstitials clusters.

Involved particles

Single neutral "native defects".

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Cluster implementation.

Comments

  1. Click here to know the data structure in the DDP file.


I311

MIN311SIZE

Definition

Minimum size of an interstitials cluster to be converted into a I311 (see amorphous pocket to I311 transformation).

Units

Dimensionless (number of particles).

Related DADOS mechanisms

  • Amorphous pocket to I311 transformation.

  • I311 implementation.

Comments

  1. This parameter is relevant only at annealing temperatures.

size0_Clusterto311

Definition

Prefactor of threshold in the simulation of I311.

Units

Dimensionless (number of particles).

Related DADOS mechanisms

  • Amorphous pocket to I311 transformation.

  • I311 implementation.

Comments

  1. This parameter is relevant only at low temperatures.

EClusterto311

Definition

Threshold energy in the simulation of I311.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Amorphous pocket to I311 transformation.

  • I311 implementation.

Comments

  1. This parameter is relevant only at low temperatures.


Dislocation loops

size0_311toDLoop

Definition

Prefactor of threshold for the transition size model in the simulation of dislocation loops.

Units

Dimensionless (number of particles).

Related DADOS mechanisms

  • Dislocation loop implementation.

  • I311 to dislocation loop transformation.

Comments

  1. Set this parameter to negative to deactivate transition size model.

E311toDLoop

Definition

Threshold energy for the transition size model in the simulation of dislocation loops.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Dislocation loop implementation.

  • I311 to dislocation loop transformation.

R0_311toDL

Definition

Prefactor of transformation rate for the transition rate model in the simulation of dislocation loops.

Units

Seconds-1 (s-1).

Related DADOS mechanisms

  • Dislocation loop implementation.

  • I311 to dislocation loop transformation.

Comments

  1. Set this parameter to zero to deactivate transition rate model.

Ebar0_311ToDL

Definition

Limit barrier energy for high structure sizes to be converted into dislocation loops.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Dislocation loop implementation.

  • I311 to dislocation loop transformation.

Ebar1_311ToDL

Definition

Prefactor used to calculate the barrier energy to create dislocation loops from I311. It defines the growth level in the rate.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Dislocation loop implementation.

  • I311 to dislocation loop transformation.

expo_311ToDL

Definition

Exponent used to calculate the barrier energy to create dislocation loops from I311. It defines the growth level in the rate.

Units

Dimensionless.

Related DADOS mechanisms

  • Dislocation loop implementation.

  • I311 to dislocation loop transformation.

D0DLoopProp

Definition

Proportional value to the prefactor of emission in dislocation loops.

Units

Dimensionless.

Related DADOS mechanisms

  • Dislocation loop implementation.

  • I311 to dislocation loop transformation.

gamma

Definition

Stacking fault energy per unit area used to calculate formation energy of faulted dislocation loops.

Units

Electron-volts per square nanometer (eV/nm2).

Related DADOS mechanisms.

  • Dislocation loop implementation.

mu

Definition

Shear modulus used to calculate formation energy of faulted dislocation loops.

Units

Electron-volts per cubic nanometer (eV/nm3).

Related DADOS mechanisms

  • Dislocation loop implementation.

nu

Definition

Poisson's ratio for dislocation loops.

Units

Dimensionless.

Related DADOS mechanisms

  • Dislocation loop implementation.

burgVectMod

Definition

Modulus of the Burgers vector for dislocation loops.

Units

Nanometers (nm).

Related DADOS mechanisms

  • Dislocation loop implementation.


Platelets

D0PlateletProp

[TO BE DEVELOPED]


Voids

MINVoidsSIZE

Definition

Minimum size of a vacancies cluster to be converted into a void (see amorphous pockets to voids transformation)

Units

Dimensionless (number of particles).

Related DADOS mechanisms

  • Amorphous pocket to void transformation.

  • Void implementation.

Comments

  1. This parameter is relevant only at annealing temperatures.

size0_ClustertoVoids

Definition

Prefactor of threshold in the simulation of voids.

Units

Dimensionless (number of particles).

Related DADOS mechanisms

  • Amorphou pocket to voids transformation.

  • Void implementation.

Comments

  1. This parameter is relevant only at low temperatures.

EClustertoVoids

Definition

Threshold energy in the simulation of voids.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Amorphous pocket to voids transformation.

  • Void implementation.

Comments

  1. This parameter is relevant only at low temperatures.


Complexes

D0F_ComplexProp ? ?

Definition

Proportional value to the prefactor of impurities emission for complexes. The emitted particle will be:

  • A single impurity if it is mobile (F, O,...).

  • An impurity native-defect pair if the single impurity is immobile (As, B, C) and it is emitted as a point defect (AsV, Bi, Ci,...).

Interrogation marks (?) indicate the particles of the complex for which the parameter is defined, for instance, D0F_ComplexProp I B is used for ImBn complex.

Involved particles

  • Single neutral "native defects".

  • Single impurities.

Units

Square centimeters per second (cm2/s).

Related DADOS mechanisms

  • Complex implementation.

Comments

  1. The proportional prefactor for emission of single neutral "native defects" is taken to be equal to the one of the corresponding clusters (see D0_ClusterProp).

Etotal_Complex ? ?

Definition

Total energy: Energy to separate all particles from a complex XmAn. Formation energies of native defects particles are not included.

Interrogation marks (?) indicate the particle for which the parameter is defined, for instance, Etotal_Complex I C is used for CnIm complex.

Involved particles

  • Single neutral "native defects".

  • Single impurities.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Complex implementation.

Comments

  1. The format used in the DDP file can be seen here.

  2. The lower the values, the higher the complex stability.

  3. If there is no energy included in the DDP file, DADOS assumes that this configuration is unstable and it gives a value of +5 eV to the potential energy to avoid the creation of this kind of complexes.

EbarrierB_Complex ? ?

Definition

Barrier energy for capture and emission of back particles.

Interrogation marks (?) indicate the particle for which the parameter is defined, for instance, EbarrierB_Complex I C is used for ImCn complex.

Involved particles

Single neutral "native defects".

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Complex implementation.

Comments

  1. This energy is implemented for both and capture as the process must be reversible.

EbarrierF_Complex ? ?

Definition

Barrier energy for capture and emission of front particles.

Interrogation marks (?) indicate the particle for which the parameter is defined, for instance, EbarrierF_Complex I C is used for ImCn complex.

Involved particles

Single impurities.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Complex implementation.

Comments

  1. This energy is implemented for both emission and capture as the process must be reversible.


Interfaces

Csol0_?

Definition

Prefactor of solubility [1].

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Csol0_As is used for calculate solubility in arsenic.

Involved particles

  • Single impurities.

  • Impurities-"native defect" pairs.

  • Impurities in other materials.

Units

Particles per square centimeter (cm-2).

Related physical magnitudes

  • Solubility.

Related DADOS mechanisms

  • Emission from surface.

  • Trapping.

Comments

  1. We only consider electrical (substitutional) solubility.

  2. Set this parameter to its negative value to simulate impurity in-diffusion into the silicon side.

Esol_?

Definition

Solubility energy [1].

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Esol_As is used for calculate solubility in arsenic.

Involved particles

  • Single impurities.

  • Impurities-"native defect" pairs.

  • Impurities in other materials.

Units

Electron-volts (eV).

Related physical magnitudes

  • Solubility.

Related DADOS mechanisms

  • Emission from surface.

  • Trapping.

Comments

  1. We only consider electrical (substitutional) solubility.

Surf_h0_?

Definition

Prefactor of coefficient "h", which is related to the trapping.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Surf_h0_B is used for boron.

Involved particles

  • Single impurities.

  • Impurities-"native defect" pairs.

  • Impurities in other materials.

Units

Centimeters per second (cm/s).

Related DADOS mechanisms

  • Emission from surface.

  • Trapping.

Comments

  1. Set this parameter to zero to simulate impurity mirror interface.

Surf_Eh_?

Definition

Energy of coefficient "h", which is related to the trapping.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Surf_Eh_B is used for boron.

Involved particles

  • Single impurities.

  • Impurities-"native defect" pairs.

  • Impurities in other materials.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Emission from surface.

  • Trapping.

Surf_e_a0_?

Definition

Prefactor of the ratio of emission to absorption probabilities for the interface.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Surf_e_a0_B is used for boron.

Involved particles

  • Single impurities.

  • Impurities-"native defect" pairs.

  • Impurities in other materials.

Units

Dimensionless.

Related DADOS mechanisms

  • Emission from surface.

  • Trapping.

Surf_Ee_a_?

Definition

Energy of the relation between emission and absorption probabilities for the interface.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Surf_Ee_a_B is used for boron.

Involved particles

  • Single impurities.

  • Impurities-"native defect" pairs.

  • Impurities in other materials.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Emission from surface.

  • Trapping.

SurfMaxTrap_?

Definition

Maximum concentration of trapped particles allowed at the interface side indicated by "?", for instance, SurfMaxTrap_B is used for boron.

Involved particles

  • Single impurities.

  • Impurities-"native defect" pairs.

  • Impurities in other materials.

Units

Particles per square centimeter (cm-2).

Related DADOS mechanisms

  • Emission from surface.

  • Trapping.

Segreg_pref_?

Definition

Prefactor of the segregation coefficient.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Segreg_pref_BOxide is used for boron in oxide silicon.

Involved particles

  • Single impurities.

  • Impurities-"native defect" pairs.

  • Impurities in other materials.

Units

Dimensionless.

Related DADOS mechanisms

  • Segregation.

  • Trapping.

Segreg_eV_?

Definition

Segregation energy.

Interrogation mark (?) indicates the particle for which the parameter is defined, for instance, Segreg_eV_BOxide is used for boron in oxide silicon.

Involved particles

  • Single impurities.

  • Impurities-"native defect" pairs.

  • Impurities in other materials.

Units

Electron-volts (eV).

Related DADOS mechanisms

  • Segregation.

  • Trapping.

RecLnm_?

Definition

Recombination length for the interface shown in "?", for instance, RecLnm_IOxide is used for interstitials in oxide silicon.

Involved particles

Single neutral native defects.

Units

Nanometers (nm).

Related physical magnitudes

  • Recombination length.

DADOS mechanisms

  • Surface recombination.

Comments

  1. Recombination of single neutral native defects in the volume is not implemented in UVAS, as its frequency is extremely low.

SuperSat_?

Definition

Interstitial or vacancy supersaturation in the material indicated by "?". For example: SuperSat_V is the vacancy supersaturation in oxide silicon.

Involved particles

Single neutral native defects.

Units

Dimensionless.

Related physical magnitudes

  • Supersaturation.

Comments

  1. This value is used by DADOS to initialize, as it will change during the simulation.


Physical magnitudes

In this seccion, a description of the main magnitudes used by DADOS will be made. They are related to the mechanisms implemented.

  • Concentrations.

  • Diffusivities.

  • Electronic magnitudes.

  • Surface and interfaces properties.


Concentrations

Equilibrium concentration of neutral native defects

The concentration of single neutral native defects under equilibrium conditions is determined by:

Where:

  • C?,0* is the prefactor, related to DADOS parameter C0relEq_? under equilibrium conditions as follows:

  • Ef? is the formation energy, that is equal to the input parameter Eform_?.

  • See symbol list.

Supersaturation

Supersaturation is defined for both interstitials and vacancies as the ration between its concentration and the equilibrium one.

Supersaturation does not depend on the charge state. This is because the rations Cj-1/Cj do not depend on the excess of defects, but only on Fermi level (Fahey et al. 1989).

Concentration ratio of charged species

The relative concentration between the of charged species is:

Where:

  • CXj is the concentration of X with charge "j".

  • gj is the degeneracy factor. We assume it to be the same for all charge states, i.e. there is no entropy change associated to charge transitions.

  • eF is the Fermi level.

  • e(j,j-1) is the electronic level for species X at temperature T. In the DDP file, this parameter is defined but for T = 0 K.

  • See symbol list.

According to the equation, the following expressions are valid:

See Fahey et al. 1989 and Martin-Bragado et al. 2005.

Break-up of charged pairs: Boron case

The pairing, break-up and charge reactions related to Bi are represented by the reactions:

Comments

  • Substitutional boron is always immobile and ionized (B-).

  • Horizontal reactions (pairing and break-up) conserve the charge while vertical reactions establish the electrical equilibrium.

  • The rate of the horizontal reactions will not depend on Fermi level.

  • Direct break-up of Bi+ is not included because I++ is not implemented.

  • The activation energy for Bi- break-up will be Eb(Bi-)+Em(I0) (see figure below), where Eb is the binding energy and Em is the migration energy.

  • Considering energy conservation, we can conclude: Eb(Bi0)=Eb(Bi-)+eBi(0,-)-eI(+,0),where e(j,j-1) is the electronic level for species at temperature T. Electronic levels scale with gap energy, introducing a slight temperature dependance in binding energy for Bi0.

  • The number of broken Bi- per unit of volume and time will be CBi-nbk(Bi-) and the number of new formed CB-CI0νm(I0)vcapt, where vcapt is the effective capture volume for pairing reaction. Consequently, in local equilibrium conditions:

  • And, from equilibrium conditions it can be also derived that the break-up prefactors, νbk,0 must fulfill:

See Martin-Bragado et al. 2005.


Diffusivities

Direct diffusivity of single impurities

For single impurities non assisted by interstitials or vacancies (e.g. F, H,...):

Where:

  • D0,? is the prefactor of diffusivity for particle "?".

  • Em? is the migration energy for particle "?", Em_?.

  • See symbol list.

Effective diffusivity of native defects

For I or V, the relevant magnitude is the DC product. Thus, the effective diffusivity of I or V can be defined as (Fahey et al. 1989):

Where:

  • D is the prefactor of diffusivity.

  • C* is the concentration under equilibrium conditions.

  • CSi is the atomic density in crystalline silicon.

Thus:

The activation energy of Deff* is:

Edif = Ef + Em

Where:

  • Ef is the formation energy.

  • Em is the migration energy.

Silicon self-diffusion

The diffusivity of silicon in silicon (self-diffusion) is given by (Bratch et al. 1998):

Where fx is taken to be 0.72 for interstitials and 0.5 for vacancies.

Effective diffusivity of dopants

For immobile impurities, diffusivity through mobile pairs, AX:

Let's use the boron (negative ion is substitutional positions).

Where:

  • Def is the effective diffusivity.

  • CX is the concentration of X.

  • eX is the energy level or X.

  • eF is the Fermi level.

  • p is the holes concentration.

  • ni is the holes or electrons intrinsic concentration.

  • See symbol list.

The proportionalities to p/ni and (p/ni)2 are valid only within the Maxwell-Boltmann approximation (non-degenerated material).

The activation energies of the terms in the previous equation (diffusion energies, Edif) are represented in the figure below. The diffusion energy value for boron under intrinsic conditions in the figure below (Edifint) will be similar to the activation energy of the Arrhenius plot of equilibrium boron diffusivity in intrinsic condition. In the figure, it can be seen that Bi0 is a metastable state but is the main contributor for boron diffusion in a wide range of Fermi levels. All the three terms of the equation are proportional to:

Note that DICI is the DC product of neutral interstitials. Thus, boron diffusion does not depend on the charge states of I, but on those of Bi.

See Fahey et al. 1989 and Martin-Bragado et al. 2005.

Long-hop distance

In the figure below, we can see that, after Bi formation, this point defect migrates through the material an average distance, Λ (long-hop distance) until it breaks up.

The long-hop distance can be expressed as:

The energy associated to this process can be calculated as follows:

This energy is negative.


Electronic magnitudes

Carriers and Fermi levels

Usually, the Fermi level, eF, is calculated from the majority-carrier concentration. The process is explained in the Mechanisms section. But, also, the minority-carrier concentration can be found from Fermi level:

Where:

  • Nc is the effective density of states in the conduction band.

  • Nv is the effective density of states in the valence band.

  • F1/2 is the Fermi-Dirac function:

  • See symbol list.

Intrinsic carrier concentration and intrinsic level

Intrinsic carrier concentration is defined as follows:

Where:

  • Nc is the effective density of states in the conduction band.

  • Nv is the effective density of states in the valence band.

  • Eg is the band gap width.

  • See symbol list.

Intrinsic electronic level is defined as follow:

Where:

  • Eg is the band gap width.

  • Nc is the effective density of states in the conduction band.

  • Nv is the effective density of states in the valence band.

  • See symbol list.

Probabilities and charge states

DADOS implements two parameters depending on the charge:

  • Diffusivities. Each species has its own migration energy and prefactor, that is assumed to be Fermi level independent.

  • Proportion of concentrations. Probability of a particle "X" with charge "j" to be in a charge state. It can be calculated as follows:

Where:

  • CXj is the concentration of particle "X" with charge "j".

This probability is calculated using the expresions shown in the concentration ratio of charged species section.

Formation energies for charged species

The formation energy for a species "X" with charge "j" is given by:

Where:

  • eF is the Fermi level.

  • e(j,j-1) is the electronic level for species X at temperature T. In the DDP file, this parameter is defined but for T = 0 K.

Formation energy for vacancies is plotted in dashed lines in the figure below. The total effective formation is the lowest one. That is given by:

Where:

  • Ef is the formation energy.

  • Em is the migration energy, assumed to be independent on the Fermi level.

Solid lines represent the activation energy of DC* product of charged species.

The situation for interstitials is analog.

Electric drift

The relation between the electric field (F) and the Fermi level (eF) is:

And, also, the relation between the formation energy (Ef) and the electric field (F) is:

The figure below shows electric drift as a natural consequence of the local dependance on the formation energies of charged particles.

The relation between the migration frequency in the positive and negative directions along the x axis for a point defect with charge "jq" is (assuming constant band gap):

where:

  • Ex is the electric field in "x" direction.

  • λ is the capture distance.

  • Ef is the formation energy.

  • See symbol list.

Sheet resistance

Let's suppose this structure:

As its top surface is square, we can define the sheet resistance as follows:

Where

  • r is the resistivity.

  • L and t are the box dimensions (see figure).

In an electronic device, under extrinsic conditions, the sheet resistence can be approximated by:

Where:

  • xj is the juction depth.

  • m is the majority-carrier mobility.

  • N(x) is the net impurity concentration.

  • See symbol list.

For a given diffusion profile, sheet resistance is uniquely related to the surface concentration of the diffused layer and the background concentration of the wafer.


Surface and interfaces properties

Recombination length

Recombination length is defined as:

Where:

  • λ is the jump distance.

  • p is the probability of being captured at the surface.

The probability affects emission frequency of single neutral native defects. Thus, the recombination length does not affect the equilibrium concentration, C*.

Solubility

Let's assume a negative dopant, A-. Its solubility in intrinsic conditions (eF = ei) is given as:

Where:

  • [A]maxextrinsic is the maximum concentration for extrinsic conditions, that can be measured this way:

  • eF is the Fermi level.

  • ei is the intrinsic level.

  • See symbol list.


DADOS mechanisms

DADOS mechanisms are the ways used by the simulator to implement physical models.

  • Amorphous implementation.

  • Amorphous pocket implementation.

  • Charge model implementation.

  • Cluster implementation.

  • Complex implementation.

  • Dislocation loop implementation.

  • I311 implementation.

  • Interface implementation.

  • Point defect implementation.

  • Simulation box.

  • Transformations.

  • Void implementation.


Amorphous implementation

Amorphization

DADOS uses AmorphizationThreshold to change the box state into amorphous. In this state, DADOS only counts the number of particles instead of store full data.

Amorphous boxes properties:

  • When an interstitial or vacancy comes into an amorphous region, it is deleted. DADOS only counts the amount (basically, the difference, I-V).

  • Impurities coming into an amorphous region are also deleted.

When a concentration is higher than MaxIVStorage, DADOS will only count the number of particles instead of store full data. With this algorithm, a lot of memory can be saved and the computerization needs cut down drastically.

DADOS converts into amorphous a region whose size is smaller than the value indicated by LatticeCollapse_nm3 if it is surrounded by an amorphous structure. Sometimes, a box should become amorphous but there are not enough particles and it does not. This could also be an important drawback as this non amorphous regions would be an important source of errors in recrystallization processes.

In order to prevent from physically incorrect effects, DADOS also smoothes amorphous regions with sizes higher than LatticeCollapse_nm3 by homogeneously distributing the concentrations.

Information about these parameters can be found in the messages window at the beginning of a simulation:

Recrystallization

Recrystallization occurs at high temperature and only in the amorphous-crystalline interfaces, according to research, following a direction called "recrystallization front", towards the amorphous side.

The velocity of recrystallization is defined by means of an Arrhenius plot:

Where:

  • V0recryst is the prefactor of recrystallization velocity.

  • Erecryst is the recrystallization velocity energy.

  • See symbol list.

The number of interstitials and vacancies in an amorphous box which is going to recrystallize do not have to be the same. Thus, the box will have extra interstitials or vacancies. DADOS will transfer these particles into the next amorphous box, following the direction indicated by the recrystallization front (see figure below). If this front finds a surface, interstitials and vacancies will be eliminated there. If not, they will form clusters that, after annealing will evolve towards extended defects.

In an amorphous box which is going to recrystallize, there can be impurities. These ones can stay in the box as substitutional structures or be transferred into the next amorphous box following the direction indicated by the recrystallization front. In order to choose what to do, DADOS uses a probability, recrysDepositProb_?. But the maximum number of impurities particles that can be deposited in the box is limited by recrysMaxActive_?. The excess is deposited as complexes, with a maximum number of impurities in them defined by maxDepositedCxSize_?.


Amorphous pockets implementation

Amorphous pocket implementation

Amorphous pockets are implemented as irregular shapes containing single neutral "native defects".

Emission

Once all the IV pairs have been recombined, the amorphous pockets tries to be dissolved. The particles not recombined wait for a dissolution event, calculated with the frequency:

Where:

  • λ is the jump distance.

  • D0AmorphousPocket is a prefactor in diffusivities units.

  • Edissol is the activation energy.

  • See symbol list.

Growth

When a mobile particle is near enough to the amorphous pocket (closer than the capture distance), it is captured by it and is inserted into it. See amorphous pocket interactions for further information.

Xn + X -> Xn+1

If the amorphous pocket has a large size (higher than a threshold), DADOS only counts the number of particles being captured by it (hidden particles), in order to save memory.

An impurity can also be captured by the amorphous pocket:

  • If it is a single impurity, it doesn't affect the amorphous pocket size.

  • If it is an impurity-"native defect" pair, DADOS splits it into a single impurity, which doesn't affect the size, and a single neutral "native defect", which does.

Shrinkage

Interstitials and vacancies, however, can be recombined inside the structure. This is called dynamic annealing or shrinkage. This process is energetically more favorable than emission. The frequency associated to this event is given as follows (Mok et al. 2005):

Where:

  • λ is the jump distance.

  • D0AmorphousPocket is a prefactor in diffusivities units.

  • "m" is the number of interstitials in the amorphous pocket.

  • "n" is the number of vacancies in the amorphous pocket.

  • size is the minimum between "m" and "n".

  • ExponentAmorphousPocket is an exponent.

  • Eb_AmorphousPocket is the activation energy.

  • See symbol list.


Charge model implementation

Simulated particles can have different charge states. As other parameters such as diffusion depend on the charge, DADOS implements charged particles as different species (click here for DADOS names):

Physical Particle | Implemented species | Particle types names
I | I+ I0 I- | IP I IM
V | V++ V+ V0 V- V- - | VPP VP V VM VMM
As | As+ | As
Asi | Asi+ Asi0 | AsiP Asi
AsV | AsV+ AsV0 AsV- | AsVP AsV AsVM
B | B- | B
Bi | Bi+ Bi0 Bi- | BiP Bi BiM
C | C0 | C
Ci | Ci0 | Ci
In | In- | In
InV | InV0 InV- | InV InVM
Ini | Ini0 Ini- | Ini IniM
P | P+ | Ph
Pi | Pi0 Pi+ | Phi PhiP
PV | PV+ PV0 PV- | PhVP PhV PhVM

DADOS assumes some hypotheses:

  • Temperature dependance of charge levels and gap narrowing of charge levels dependance is the same as for the band gap.

  • Charge is adapted and updated instantaneously, as charge reactions are much faster than structural ones.

  • Substitutional dopants are always ionized and in the same charge state.

Band gap narrowing

Shifts of the minimum value of conduction band and maximum value of valence band are calculated by DADOS using the following expressions, according to Jain & Roulston model (Jain et al. 1991):

  • For n-semiconductors:

  • For p-semiconductors:

Where:

  • N is the effective concentration of active dopants (with sign): N = N+ - N-, where N+ is the active donors concentration and N- is the active acceptors concentration.

  • A??1_? are constants.

In every charge update, DEc and DEv are calculated.

For the rest of the electronic levels, DADOS assumes a proportional variation with the band gap narrowing as given by the expression:

Where:

  • Ec is the conduction band energy.

  • Ev is the valence band energy.

  • e_? is a generic energy charge level.

See Sze 1981.

Charge attractions and repulsions

DADOS implements electrostatic interactions in both short and long range:

  • For short range, repulsions are implemented by forbidding the interaction among charged particles (not neutral) with the same charge.

  • For long range, electrostatic interactions (attractions and repulsions) are automatically included due to the electric drift in the migration (this process depends on the Fermi level).

Charge update

There are two mechanisms to control the charge states probabilities:

  • Dynamic update: The charge state is updated whenever the particle jumps, in order to follow the probabilities of charged species in each box. These probabilities have been previously calculated as a function of the Fermi level during the static update. This is suitable for particles jumping at low frequencies.

  • Static update: The charge state is updated every some time.

DADOS uses a counter to simulate charge update and calculate Fermi level in all boxes. Every time an electrically active dopant is created or destroyed, the counter is raised. When the counter value is higher than a threshold, DADOS updates the charge state for all particles.

The threshold changes during the simulation, according the charge variations. With ChargeVarPercent, this mechanism can be controlled. This parameter indicates the maximum relative error allowed in Fermi level updates. The higher ChargeVarPercent is, the less updates are done. It is NOT recommended changing this parameter because DADOS is very sensitive to variations in this value. Modifications of this parameter should be allowed only for advanced users because:

  • If ChargeVarPercent is very low, calculations will be made very frequently, and the simulation will become slower.

  • If ChargeVarPercent is very high, updates will not be frequent enough, and physically incorrect values might be obtained.

Electric drift implementation

As the formation energy of charged species depends on the Fermi level, mobile charged point defects are going to find an energy barrier to jump into boxes in which the formation energy is higher. Electric drift is implemented in DADOS as a discrete process, setting a constant Fermi level for each box:

Fermi level calculation

DADOS calculates the Fermi level in each box using its smoothed dopant concentration, Nsm:

  • If Nsm > 0 (n-type boxes):

  • If Nsm < 0 (p-type boxes):

Where:

  • Ec is the conduction band energy.

  • Ev is the valence band energy.

  • F1/2 is the Fermi-Dirac function and F-11/2 is its inverse. Those functions, when required, are calculated with analytical approximations.

  • ni is the intrinsic carrier concentration.

  • See symbol list.

See Sze 1981.

Smoothing the dopant distribution

DADOS checks all the boxes and stores the dopants per box. After that, DADOS smoothes the dopant concentration using a locally-dependent radius equal to the Debye length:

Where:

  • N is the effective concentration of active dopants (with sign): N = N+ - N-, where N+ is the active donors concentration and N- is the active acceptors concentration.

  • See symbol list.

In order to avoid excessive computerization, the maximum number of boxes for Debye length is set to 7.

The smooth dopant concentration, Nsm, will be used in the Fermi level calculation of each box using the neutrality approximation. This smoothed neutrality approximation is a computer-efficient method with intermediate precision between the simple local neutrality approximation and the time consuming solution of Poisson equation.

Temperature dependance of band structure

Band gap width

The band gap width depends on the temperature, T, following the expression:

Where:

  • Eg0 is the band gap width at 0 K.

  • Agap and Bgap are constant parameters.

  • See symbol list.

Charge levels

We denote by e_? the charge level associated to a charged particle, ?, at the current temperature, T. e_? is measured from the valence band edge.

DADOS assumes that all charge levels temperature dependancy is the same as band gap width one, thus:

Where:

  • e_?0 is the charge level at 0 K.

  • Eg(T) is the band gap width at temperature T.

Related physical magnitudes

  • Equilibrium concentration of charged species.

  • Formation energies of charged species.

Effective density of states

DADOS implements the states density in both conduction and valence band as follows:

Where:

  • Nc300 and Nv300 are the effective densities of states in the conduction and valence band respectively at 300 K.

  • expNc and expNv are exponents to calculate the density of states in the conduction and valence band respectively.

  • See symbol list.


Clusters implementation

Cluster implementation

Clusters are implemented as a special type of amorphous pockets with only one particle type, interstitials or vacancies.

Emission

Clusters emit particles releasing them as a point defect:

Xn -> X + Xn-1

The emission frequency is given by the expression:

Where:

  • λ is the jump distance.

  • D0ClusterProp is proportional to the prefactor.

  • n is the cluster size.

  • Eb is the binding energy.

  • Em is the migration energy of the released point defect.

  • See symbol list.

Growth

When a mobile particle of the same type (X, interstitial or vacancy) that those of the cluster is near enough to the cluster (closer than the capture distance), it is captured and is inserted into it.

Xn + X -> Xn+1

The energies associated to the emission and growth are plotted below:

Binding energy

Examples of the binding energy for clusters are represented below (Cowern et al. 1999, Staab et al. PRB 2002):

According to experimental measurements and to calculation results, for high size values, the binding energies are fitted by a potential function. However, for low size values, the energies are irregular. DADOS implements a technique which allows insert values for specific sizes and a generic function for other sizes.

Specific values

They can be inserted by means of Eb_Cluster ?, with the DADOS data file format.

Generic function

The exponential function is implemented as follows (Jaraiz et al. 1996):

Where:

  • Eb(?n) is the binding energy for an interstitials or vacancies cluster (?) of size n.

  • Eb_LargeCluster ? is the limit in binding energy for highest cluster size.

  • Eb_SmallestCluster ? is the limit in binding energy for lowest cluster size (2).

  • n is the cluster size.

  • exponent_Cluster ? is an exponent.

This expression comes from assuming that the total binding energy of the cluster of size "n" depends on "n".

Shrinkage

When a mobile particle of complementary type (vacancy or interstitial) of those of the cluster is near enough to the cluster (closer than the capture distance), it is recombined (with an opposite particle). When only one particle is remaining, the cluster is transformed into a point defect.


Complex implementation

XmAn complex is a defect with "n" atoms of B, As, C, F, O or P (called front particles), and "m" I or V (called back particles). DADOS does not take into account the different posible microscopic configurations of XmAn and uses effective numbers for each combination.

I and V can be single neutral native defects or associated with the other atoms, for instance, boron in interstitial position.

Back particle emission

Back particles are emitted as follows:

XmAn -> Xm-1An + X

The emission frequency is calculated by DADOS as follows:

Where:

  • B is the back particle.

  • λ is the jump distance.

  • D0F_ComplexProp is a prefactor in diffusivities units.

  • Em is the migration energy.

  • Ebarr is an optional energetic barrier.

  • Eb is the binding energy of the back particle, calculated as follows:

Eb(m,n) =
Etotal(m-1,n) -
Etotal(m,n)

  • See symbol list.

After emission, if only one particle (or two particles that can form a pair) is remaining, the complex is transformed into a point defect.

The energies associated to this process are plotted below:

Front particle emission

Front particles are emitted:

Mobile single impurity (F, O,...)

XmAn -> XmAn-1 + A

The emission frequency is calculated by DADOS as follows:

Where:

  • F is the back particle.

  • λ is the jump distance.

  • D0F_ComplexProp is a prefactor in diffusivities units.

  • Em is the migration energy.

  • Ebarr is an optional energetic barrier.

  • Eb is the binding energy of the front particle, calculated as follows:

Eb(m,n) =
Etotal(m,n-1) -
Etotal(m,n)

  • See symbols list.

After emission, if only one particle (or two particles that can form a pair) is remaining, the complex is transformed into a point defect.

The energies associated to this process are plotted below:

Immobile single impurity (B, As, C,...)

It is emitted within a mobile pair:

XmAn -> Xm-1An-1 + XA

The emission frequency is calculated by DADOS as follows:

Where:

  • F is the back particle.

  • λ is the jump distance.

  • D0F_ComplexProp is a prefactor in diffusivities units.

  • Em is the migration energy.

  • Ebarr is an optional energetic barrier.

  • Eb is the binding energy of the front particle, calculated as follows:

Eb(m,n) = Etotal(m-1,n-1) - EbXA-Etotal(m,n)

  • See symbols list.

The energies associated to this process are plotted below:

Back particle capture

Complexes can capture single neutral "native defects".

XmAn + X -> Xm+1An

These captures are not automatic, because of the associated energies. DADOS uses a capture probability defined as follows:

Where:

  • B is the back particle.

  • Ebarr is an optional energetic barrier.

  • Eb is the binding energy of the back particle, calculated as follows:

Eb(m,n) =
Etotal(m,n)
- Etotal(m+1,n)

If there is no energy included in the DDP file, DADOS assumes that this configuration is unstable and it gives a value of +5 eV to the potential energy to avoid the creation of this kind of complexes.

  • See symbols list.

The energies associated to this process are plotted below:

Front particle capture

Complexes can capture single impurities:

Mobile single impurity (F, O,...)

XmAn + A -> XmAn+1

These captures are not automatic, because of the associated energies. DADOS uses a capture probability defined as follows:

Where:

  • F is the front particle.

  • Ebarr is an optional energetic barrier.

  • Eb is the binding energy of the back particle, calculated as follows:

Eb(m,n) =
Etotal(m,n) -
Etotal(m,n+1)

  • See symbols list.

The energies associated to this process are plotted below:

Immobile single impurity (B, As, C,...)

XmAn + XA -> Xm+1An+1

These captures are not automatic, because of the associated energies. DADOS uses a capture probability defined as follows:

Where:

  • F is the front particle.

  • Ebarr is an optional energetic barrier.

  • Eb is the binding energy of the back particle, calculated as follows:

Eb(m,n) =
Etotal(m,n) -
Etotal(m+1,n+1)

  • See symbols list.

The energies associated to this process are plotted below:

Shrinkage

Complexes can capture interstitials or vacancies that are recombined with complementary particles. For instance, let's call X' to the complementary particle to X, i. e., interstitials for vacancies and vice versa:

XmAn + X' -> Xm-1An

The capture probability is calculated as follows:

Where:

  • Erec is:

Erec(m,n) = Eform_I + Eform_V - (Etotal(m-1,n) - Etotal(m,n)) = Eform_I + Eform_V - EbB(m,n)

  • EbB(m,n) is the binding energy for the back particle.

  • Eform_I is the formation energy of interstitial.

  • Eform_V is the formation energy of vacancy.

  • See symbols list.

The energies associated to this process are plotted below:

Complementary emission

Some impurities can diffuse by means of both interstitals and vacancies, for example, arsenic. In this case, complexes can emit not only interstitials and vacancies but also point defects, with complementary particles, i.e., a AsnVm complex can emit Asi.

XmAn -> Xm+1An-1 + X'A

The emission frequency is given as follows (the same for AV):

Where:

  • λ is the jump distance.

  • D0F_ComplexProp is a prefactor in diffusivities units.

  • Em is the migration energy.

  • Ebarr is an optional energetic barrier.

  • Eb is the binding energy, calculated as follows:

    Eb(m,n) =
Etotal(m+1,n-1) -
Etotal(m,n)

  • See symbols list.

Complementary recombination

Some impurities can diffuse by means of both interstitals and vacancies, for example, arsenic. In this case, complexes can recombine not only interstitials and vacancies but also point defects:

XmAn + X'A -> Xm-1An+1

The capture probability is calculated as follows:

Where:

  • Ecapture is the capture energy.

  • See symbols list.

And the recombination energy is calculated with the total energies:

Where:

  • Ef is the formation energy.

  • Em is the migration energy.

  • EAi->A is an internal, fixed parameter.


Dislocation loops implementation

Dislocation loop implementation

Faulted dislocation loops are implemented in DADOS as round-shaped structures of immobile interstitials, oriented in one of the four {111} planes. The orientation is randomly taken (from these four) when the dislocation loop is created.

The density of atoms in the dislocation loop is given by this expression:

By simplicity, DADOS implements the dislocation loop using a square in-plane lattice with planar density r.

In consequence, the distance between consecutive atoms is:

And the radius can be calculated by:

Emission

Dislocation loops emit interstitials from their edge end and they release them as a point defect from a randomly consen orientation of its surface.

The emission frequency is given by the expression:

Where:

  • λ is the jump distance.

  • D0DLoopProp is proportional to the prefactor.

  • n is the dislocation loop size.

  • Eb is the binding energy.

  • Em is the migration energy of the released point defect.

  • See symbol list.

Growth

When a mobile neutral interstitial is near enough to the dislocation loop (closer than the capture distance), it is captured by it and inserted into the edge.

Formation energy

Formation energy for faulted dislocation loops as a function of the radius is (Cristiano et al. 2000):

Where:

  • r is the radius of the defect.

  • g is the stacking fault energy per unit area.

  • m is the shear modulus.

  • n is the Poisson's ratio.

  • r0 is the dislocation core radius, where b is the modulus of the Burgers vector.

  • See symbol list.

Shrinkage

As dislocation loops are relevant near equilibrium conditions (low supersaturation), the following process is not implemented:

V + In -> In-1

Complementary emission

Vacancy emission from dislocation loop (generation of a vacancy and a bound interstitial) is not currently implemented because it is not likely to occur.


I311 implementation

I311 are implemented in DADOS as planar defects in {311} orientations, formed by interstitials arranged in parallel rows along <0-11> directions.

When a I311 is formed, its orientation is randomly chosen from the 12 equivalent {311} orientations.

The distance between rows is:

I311 are supposed to have an areal density of r = 5 interstitials / nm2.

The distance between consecutive interstitials in the I311 is theoretically given theoretically by:

But, as it is experimentally known, only a 61 % of the rows are occupied. DADOS uses a higher value of dL in order to maintain the correct areal density keeping all the positions occupied. Thus, the distance between consecutive interstitials (in a row) is taken to be:

The total number of interstitials in the structure is n = nL · nW, where nL is the number of interstitials per row and nW is the number of rows.

I311 length: L = nL · dL
I311 width: W = nW · dW

The relation between width and lenght is assumed to be:

Taking into account above expressions, the number of rows of a given number of interstitials n will be

What DADOS does is to establish a threshold in the middle between two consecutive values for nW. However, the values around this threshold are complicated to handle because small changes can yield a lot of changes in nW. That is why DADOS implements a histeresis cycle, as shown in the figure:

Emission

I311s emit interstitials by taking one from the end of the row and releasing as a point defect it at any point randomly chosen in the surface. The emission rate is the same to the one described for clusters, and with the same binding energy:

Where:

  • λ is the jump distance.

  • D0ClusterProp is proportional to the prefactor.

  • n is the cluster size.

  • Eb is the binding energy.

  • Em is the migration energy of the released point defect.

  • See symbol list.

Growth

When a mobile interstitial is near enough to the I311 (closer than the capture distance), it is captured by it and is inserted into one of the ends of the defect (the closest one to the particle position).

The number of interstitials captures depends on the width: when the number of rows is reduced, then the structure gets a bigger length, and therefore, more captures will take place.

Shrinkage

When a mobile vacancy is near enough the I311 (closer than the capture distance), it is captured by it and it is recombined with an interstitial. When only one interstitial is remaining, the I311 is transformed into a point defect.


Interfaces implementation

Interface implementation

Interface geometry

The figure shows a DADOS interface implementation example. As the program makes a box division, the interface will be simulated as the interface among boxes of different materials (Rubio et al. 2003).

Native defect recombination length

The probability of recombination of single neutral native defects on the interface is:

Where:

  • λ is the capture distance.

  • L is the recombination length, RecLnm_?.

As probabilities must be less or equal than 1:

  • If RecLnm_? < λ, DADOS makes RecLnm_? = λ and the interface will become a perfect sink for the selected particle.

  • If RecLnm_? = -1, DADOS automatically makes that interface neither emit or capture particles.

DADOS captures single neutral native defects with the probability explained.

Native defect generation at the interface

Interface emission is much more frequent than emission in the bulk. Actually, DADOS doesn't implement emission in the bulk, as its frequency is extremely low.

Interface emission is only allowed for single neutral native defects. Frequency of surface emission per unit area is implemented following the expression below:

Where:

  • "?" stands for interstitials or vacancies.

  • p is the probability of recombination of single neutral native defects on the surface.

  • λ is the jump distance.

  • C0relEq_? is the relative single neutral native defects concentration under equilibrium conditions.

  • Dm_? is the prefactor of diffusivity.

  • Eform_? is the formation energy.

  • Em_? is the migration energy.

  • See symbol list.

For dopants, please see trapping mechanism.

Segregation

Dopants have preferences for being emitted to one side from the interface. DADOS uses a coefficient to indicate the concentration of a dopant in the non-silicon side of the interface relative to the one in the silicon side. For calculating that, DADOS uses an Arrhenius plot:

Where:

  • Segreg_pref_? is the prefactor of segregation.

  • Segreg_eV_? is the segregation energy.

  • See symbol list.

Solubility

Solubility is implemented in DADOS by means of "Cmax", which is the maximum solid solubility of dopant in the material, obtained with Csol0_? and Esol_0_? with an Arrhenius plot:

  • For the silicon side:

See symbol list.

  • For the non-silicon side (using segregation):

See symbol list.

Trapping and detrapping

Interfaces in DADOS trap neutral mobile dopants. The flux of these phenomena has been implemented following the Oh-Ward model (Oh et al. 1998).

Net flux can be calculated as the difference between trapping rate and detrapping rate: F = T - D.

Trapping rate is defined as the attempted frequency for the process multiplied by the capture probability; this yields (Oh-Ward):

And detrapping rate can be calculated following the expression below:

Where:

  • "h" is a coefficient obtained with parameters Surf_h0_? and Surf_Eh_?:

  • "Cs" is the volume concentration of dopants at the interface on the material side.

  • "sF" is the current trapped dopants at the interface.

  • "smax" is the maximum concentration of trapped particles allowed in the interface, SurfMaxTrap_?.

  • "e/a" is the relation between emission and absorption probabilities for the interface. It can be calculated using Surf_e_a0_? and Surf_Ee_a_?:

  • "Cmax" is the maximum solid solubility of dopant in the material. See solubility for further information.

  • Addition in trapping rate is calculated for all species present at the simulation.

Dopant diffusion at interfaces

Boron, arsenic and phosphorous are implemented in DADOS to diffuse through interfaces and go into other materials. As the properties here are quite unknown, DADOS only implements the diffusion for oxides and nitrides (neither extended defects formation nor interactions).

DADOS doesn't implement single neutral native defects for other materials different from crystalline silicon.


Point defects implementation

Point defect implementation

Point defects can be:

  • Native defects, such as interstitials, vacancies, neutral (I, V) or charged (IP, IM, VM, VMM, VP, VPP).

  • Substitutional dopants pairs, such as Bi (boron + interstitial), AsV (arsenic + vacancy), etc.

Break-up

Break-up is a mechanism for splitting a point defect: Ai -> A + I or AV -> A + V.

The break-up frequency is calculated by DADOS with an Arrhenius plot:

Where:

  • Do,bk is the prefactor of break-up in diffusivity units for point defect Ai.

  • λ is the jump distance.

  • Eb_? is the binding energy for for point defect Ai.

  • Em_? is the migration energy for I or V.

  • See symbol list.

Captures

A capture can occur when a particle or defect is sufficiently near to another particle or defect and the capture is allowed. DADOS uses a capture distance called λ.

If the particle arrives in a very populated area, where more than one interaction is possible, DADOS randomly selects one.

A capture is always associated to an interaction.

For extended defects, such as amorphous pockets, I311, dislocation loops or voids, the captures depend on the surface, because it is there where the interaction occurs. Therefore, the larger the surface is, the capture will happen more frequently.

Jumps

Mobile particles in DADOS jump at a rate that is determined by both energy and temperature.

The implemented jumping directions are six: +x, -x, +y, -y, +z, -z.

Jump distance

Jump distance is called λ. We take it also to be equal to the capture distance.

  • Its value is 0.384 nm, corresponding to the second neighbors distance in the silicon lattice.

  • It is involved into the relation between the migration rate and the diffusivity:

Jump frequency

Jump frequency is calculated by using Em_? and Dm_?:

Where:

  • Dm? is the prefactor of diffusivity for particle "?", Dm_?.

  • λ is the jump distance.

  • Em? is the migration energy for particle "?", Em_?.

  • See symbol list.

Pile-up

When a mobile dopant meets an amorphous pocket or an extended defect (I311 or void), the interstitial or vacancy is included into the extended defect whereas the dopant keeps very near to the defect but not included in it. It is, then, simulated as a point defect.


Simulation box

DADOS divides the simulation box into smaller boxes. In each direction, x, y or z, it takes a power of two divisions in order to assign an optimum number of bits. The smaller BitsBoxes is, the bigger the boxes will be, because if less bits are used, less divisions will be carried out. Information about box size can be found in the messages window at the beginning of a simulation:

The maximum number of boxes created in each simulation are 2BitsBoxes.

DADOS follows an algorithm to distribute the bits among the directions, in order to get nearly-cubic boxes, but:

  • If the simulation box is very small, DADOS doesn't use all the bits, because there is a minimum limit for box sizes of about 1nm3 per box.

  • Even for a very big simulation box, it is NOT recommended using a value of BitsBoxes higher than 19, because a large amount of computer memory and time would be used.

  • It is not recommended to use a BitsBoxes value much lower than 19 because if the simulation box is very large, the boxes would be large, loosing spacial resolution. This low spacial resolution would affect to the charge mechanisms, to the amorphization mechanisms and to the interface shape.


Transformations

Extended defect transformations

Amorphous pocket to I311

DADOS implements a model which assumes that when the number of interstitials in an amorphous pocket is higher than a threshold, then the structure is automatically transformed into a I311.

The threshold in number of interstitials is given by:

Where:

  • size0_Clusterto311 is the prefactor.

  • EClusterto311 is the activation energy with changed sign.

  • See symbol list.

However, there is a minimum size to create a I311, specified by parameter MIN311SIZE. Therefore, if the threshold is smaller than it, DADOS will discard it and use MIN311SIZE.

Amorphous pocket to void

DADOS implements a model which assumes that when the number of vacancies in an amorphous pocket is higher than a threshold, then the structure is automatically transformed into a void.

The threshold in number of vacancies is given by:

Where:

  • size0_ClustertoVoids is the prefactor.

  • EClustertoVoids is the activation energy with changed sign.

  • See symbol list.

However, there is a minimum size to create a Void, specified by parameter MINVoidSIZE. Therefore, if the threshold is smaller than it, DADOS will discard it and use MINVoidSIZE.

I311 to dislocation loop

Two models are implemented in DADOS to simulate the creation of dislocation loops from I311 (Castrillo et al. 2005). It is highly recommended to have only one of them active.

Transition size model

To deactivate this model, please set size0_311toDLoop to negative.

This model assumes that when the number of particles is higher than a threshold, then the structure is automatically transformed into a dislocation loop.

The threshold in number of interstitials is given by:

Where:

  • size0_311toDLoop is the prefactor.

  • E311toDLoop is the activation energy.

  • See symbol list.

Transition rate model

To activate this model, please set R0_311ToDL to zero.

This model says that the transformation rate follows an Arrhenius plot from a value, as shown in the figure:

The barrier energy to create dislocation loops is dependent on the number of interstitials as follows:

Where:

  • Ebar0_311ToDL is a constant energy. It is the limit barrier energy for high structure sizes.

  • Ebar1_311ToDL is a prefactor used to define the growth level in the rate.

  • N is the number of interstitials in the structure.

  • N0 is a fixed value. It is the number of interstitials for which the formation energy for I311 and dislocation loops is the same.

  • expo_311ToDL is an exponent used to define the growth level in the rate.

The transformation rate is then given by:

Where:

  • R0_311toDLoop is the prefactor.

  • Ebarr is the barrier energy calculated before.

  • See symbol list.


Voids implementation

Void implementation

Voids are implemented in DADOS as spherical-shaped structures of immobile vacancies.

Emission

Voids emit vacancies by taking one from the edge and releasing as a point defect it at any point randomly chosen in the edge. The emission rate is:

Where:

  • λ is the jump distance.

  • D0ClusterProp is proportional to the prefactor.

  • MINVoidsSIZE is the minimum size of a vacancies cluster to be converted into a void.

  • n is the cluster size.

  • Eb is the binding energy.

  • Em is the migration energy of the released point defect.

  • See symbol list.

Growth

When a mobile vacancy is near enough the void (closer than the capture distance), it is captured by it and is inserted into the edge of the structure.

Shrinkage

When a mobile interstitial is near enough the void, it is captured by it and it is recombined with a vacancy. When only one particle is remaining, the void is transformed into a point defect.


Symbols

Symbol | Name | Value | Units
a | Lattice parameter | 0.543 | nm
CSi | Intrinsic atomic concentration in silicon | 5 · 1022 | cm-3
k | Boltzmann constant | 8.6174 · 10-5 | eV/K
T | Temperature |  | K
q | Absolute value of the electron charge | 1.6 · 10-19 | C


References

Bratch, H., Haller, E. E. and Clark-Phelps, R. "Silicon self-diffusion in isotope heterostructures". Physical Review Letters. 1998.

Castrillo, P., Martin-Bragado, I., Pinacho, R., Jaraiz, M., Rubio, J. E., Mok, K. R. C., Miguel-Herrero, F. J. and Barbolla, J. "Physically based modeling of dislocation loops in ion implantation processing in silicon". Materials Science Engineering. 2005.

Cowern, N. E. B., Mannino, G., Stolk, P. A., Roozeboom, F., Huizing, H. G. A., van Berkum, J. G. M., Cristiano, F., Claverie, A. and Jaraiz, M. "Energetics of self-interstitial clusters in silicon". Physical Review Letters. 1999.

Cristiano, F., Grisolia, J., Colombeau, B., Omri, M., de Mauduit, B., Claverie, A., Giles, L. F. and Cowern, N. E. B. "Formation energies and relative stability of perfect and faulted dislocation loops in silicon". Journal of Applied Physics. 2000.

Fahey, R. B., Griffin, P. B. and Plummer, J. D. "Point defects and dopant diffusion in silicon". Reviews of Modern Physics. 1989.

Jain, S. C. and Roulston, D. J. "A simple expression for band gap narrowing". Solid State Electronics. 1991.

Jaraiz, M., Gilmer, G. H., Poate J. M. and de la Rubia, T. "Atomistic calculations of ion implantation in Si: Point defect and transient enhanced diffusion phenomena". Applied Physics Letters. 1996.

Jaraiz, M., Castrillo, P., Pinacho, R., Martin-Bragado, I and Barbolla, J. "Atomistic front-end process modelling: a powerful tool for deep-submicron device fabrication". Simulation of semiconductor processes and devices, SISPAD.

Jaraiz, M., Pelaz, L., Rubio, E., Barbolla, J., Eaglesham, D. J., Gossmann, H . J. and Poate, J. M. "Atomistic modeling of point defect and extended defects in crystalline materials". Materials Research Society. 1998.

Martin Bragado, I. "Process atomistic simulation for Microelectronics". Doctoral thesis. University of Valladolid, 2004.

Martin-Bragado, I., Castrillo, P., Jaraiz, M., Pinacho R., Rubio J. E. and Barbolla, J. "Physical atomistic kinetic Monte Carlo modeling of Fermi-level effects of species diffusing in silicon". Physical Review B. 2005.

Martin-Bragado, I., Castrillo, P., Jaraiz, M., Pinacho R., Rubio J. E., Barbolla, J. and Moroz, V. "Fermi-level effects in semiconductor processing: A modeling scheme for atomistic kinetic Monte Carlo simulators". Journal of Applied Physics. 2005.

Mok, K. R. C., Jaraiz, M., Martin-Bragado, I., Rubio, J. E., Castrillo, P., Pinacho, R., Barbolla, J. and Srinivasan, M. P. "Ion-beam amorphization of semiconductors: A physical model based on the amorphous pocket population". Journal of Applied Physics. 2005.

Oh, Y . S. and Ward, D. E. "A calibrated model for trapping of implanted dopants at material interface during thermal annealing". IEEE/IEDM. 1998.

Pelaz, L., Jaraiz, M., Gilmer, G. H., Gossman, H. J., Rafferty, C. S., Eaglesham, D. J. and Poate, J. M. "B diffusion and clustering in ion implanted Si: The role of B cluster precursors". Applied Physics Letters. 1997.

Pelaz, L., Venezia, V. C., Gossmann, H. J., Gilmer, G. H., Fiory, A. T., Rafferty, C. S., Jaraiz, M. and Barbolla, J. "Activation and deactivation of implanted boron in silicon". Applied Physics Letters. 1999.

Pinacho, R., Jaraiz, M., Castrillo, P., Martin-Bragado, I., Rubio, J. E. and Barbolla, J. "Modeling arsenic deactivation through arsenic-vacancy clusters using an atomistic kinetic Monte Carlo approach". Applied Physics Letters. 2005.

Robinson, M. T. and Torrens, I. M. "Computer simulation of atomic-displacement cascades in solids in the binary-collision approximation". Physical Review B. 1974.

Rubio, J. E., Jaraiz, M., Martin-Bragado, I., Hernandez-Mangas, J. M., Barbolla, J. and Gilmer, G. H. "Atomistic Monte Carlo simulations of three-dimensional polycrystalline thin films". Journal of Applied Physics. 2003

Rubio, J. E., Jaraiz, M., Martin-Bragado, I., Pinacho, R., Castrillo, P. and Barbolla, J. "Physically based modelling of damage, amorphization and recrystallization for predictive device-size process simulation". European MRS conference proceedings. 2004.

Staab, T. E. M., Sieck, A., Haugk, M., Puska, M. J., Fuenheim, Th. and Leipner, H. S. "Stability of large vacancy clusters in silicon". Physical Review B. 2002.

Sze, S. M. "Physics of semiconductor devices". John Wiley & Sons, Inc., New York, 2nd edition.