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DS70094B-page ii
Trademarks

The Microchip name and logo, the Microchip logo, Accuron, 

dsPIC, KEELOQ, MPLAB, PIC, PICmicro, PICSTART, 

PRO MATE and PowerSmart are registered trademarks of 

Microchip Technology Incorporated in the U.S.A. and other 

countries.

AmpLab, FilterLab, microID, MXDEV, MXLAB, PICMASTER, 

SEEVAL, SmartShunt and The Embedded Control Solutions 

Company are registered trademarks of Microchip Technology 

Incorporated in the U.S.A.

Application Maestro, dsPICDEM, dsPICDEM.net, 

dsPICworks, ECAN, ECONOMONITOR, FanSense, 

FlexROM, fuzzyLAB, In-Circuit Serial Programming, ICSP, 

ICEPIC, microPort, Migratable Memory, MPASM, MPLIB, 

MPLINK, MPSIM, PICkit, PICDEM, PICDEM.net, PICtail, 

PowerCal, PowerInfo, PowerMate, PowerTool, rfLAB, rfPIC, 

Select Mode, SmartSensor, SmartTel and Total Endurance 

are trademarks of Microchip Technology Incorporated in the 

U.S.A. and other countries.

Serialized Quick Turn Programming (SQTP) is a service mark 

of Microchip Technology Incorporated in the U.S.A.

All other trademarks mentioned herein are property of their 

respective companies.

© 2003, Microchip Technology Incorporated, Printed in the 

U.S.A., All Rights Reserved.

 Printed on recycled paper.
 2003 Microchip Technology Inc.

Microchip received ISO/TS-16949:2002 quality system certification for 
its worldwide headquarters, design and wafer fabrication facilities in 
Chandler and Tempe, Arizona and Mountain View, California in October 
2003 . The Company’s quality system processes and procedures are 
for its PICmicro® 8-bit MCUs, KEELOQ® code hopping devices, Serial 
EEPROMs, microperipherals, non-volatile memory and analog 
products. In addition, Microchip’s quality system for the design and 
manufacture of development systems is ISO 9001:2000 certified.



dsPIC™ LANGUAGE TOOLS

GETTING STARTED
Table of Contents
Chapter 1. Installation and Overview

1.1 Introduction ..................................................................................................... 1

1.2 Installing MPLAB ASM30, MPLAB LINK30 and Language Tool Utilities ....... 1

1.3 Installing MPLAB C30 .................................................................................... 1

1.4 Uninstalling MPLAB C30 ................................................................................ 1

1.5 Overview ........................................................................................................ 2

1.6 Tutorials .......................................................................................................... 2

Chapter 2. Tutorial 1 - Creating A Project

2.1 Introduction ..................................................................................................... 3

2.2 Creating a File ................................................................................................ 3

2.3 Using the Project Wizard ................................................................................ 4

2.4 Building The Project ..................................................................................... 10

2.5 Debugging with the MPLAB SIM30 Simulator .............................................. 16

2.6 Exploring Further .......................................................................................... 23

Chapter 3. Tutorial 2 - Real-Time Interrupt

3.1 Introduction ................................................................................................... 25

3.2 Using Template Files .................................................................................... 25

3.3 Using the Template in a New Project ........................................................... 30

3.4 Debugging with the MPLAB SIM30 Simulator .............................................. 36

3.5 Exploring Further .......................................................................................... 40

Chapter 4. Tutorial 3 - Mixed C and Assembly Files

4.1 Introduction ................................................................................................... 41

4.2 Getting Project Source Files ......................................................................... 41

4.3 Creating and Building the Project ................................................................. 44

4.4 Examining the Program ................................................................................ 45

4.5 Exploring Further .......................................................................................... 50

4.6 Where to Go from Here ................................................................................ 50

Index ............................................................................................................................. 51

Worldwide Sales and Service .................................................................................... 52
 2003 Microchip Technology Inc. DS70094B-page iii



dsPIC™ Language Tools Getting Started
NOTES:
DS70094B-page iv  2003 Microchip Technology Inc.



dsPIC™ LANGUAGE TOOLS

GETTING STARTED
Chapter 1.  Installation and Overview
1.1 INTRODUCTION

This document is intended to help use dsPIC30F software tools by providing a 

step-by-step guide using of MPLAB® C30 with the MPLAB Integrated Development 

Environment (IDE) v6.30 or later. MPLAB IDE should already be installed on the PC.

MPLAB IDE is provided on CD-ROM and is available from www.microchip.com at no 

charge. The project manager for MPLAB IDE and the dsPIC30F simulator are both 

components of MPLAB IDE and, along with the built-in debugger, will be used 

extensively in this guide.

1.2 INSTALLING MPLAB ASM30, MPLAB LINK30 AND LANGUAGE TOOL 
UTILITIES

MPLAB ASM30 and MPLAB LINK30 are provided free with MPLAB IDE. They are also 

included in the MPLAB C30 compiler installation. To ensure compatibility between all 

dsPIC30F tools, the versions of these tools provided with MPLAB C30 compiler should 

be used.

1.3 INSTALLING MPLAB C30

• When installing MPLAB C30 compiler as an update to a previous version, it may 

overwrite existing files on the PC. A backup should be made to retain files which 

may have been modified.

• Insert the CD-ROM into the PC and execute the installation MPLAB C30 vX.XX 

(where X.XX is the curent version number) file. A series of dialogs will step 

through the installation process. The installation may take a few minutes as it 

searches for MPLAB IDE and other related files on the PC.

• To follow the examples in this guide, make sure that the check box for 

EXAMPLES is checked.

1.4 UNINSTALLING MPLAB C30

To uninstall MPLAB C30, open the folder where the compiler is installed and 

double-click on UNWISE.EXE.

Note: When uninstalling an upgraded version of MPLAB C30, the entire 

installation will be removed. If files have been added to directories after the 

previous installation, these will not be removed.
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1.5 OVERVIEW

The following tutorials are intended to help an engineer familiar with the 

C programming language and embedded systems concepts get started using the 

MPLAB C30 compiler with MPLAB Integrated Development Environment (IDE). This 

document shows how to create and build projects, how to write code using features of 

dsPIC30F devices and how to verify and debug code written with MPLAB C30.

These tutorials assume that the MPLAB C30 compiler and MPLAB IDE v6.30 (or later) 

are installed. Please refer to the dsPIC literature, such as the dsPIC30F Enhanced 

Flash 16-Bit Digital Signal Controller General Purpose and Sensor Families Data Sheet 

(DS70083) and dsPIC30F Programmer’s Reference Manual (DS70030) for information 

regarding processor-specific items such as the special function registers, instruction 

set and interrupt logic.

1.6 TUTORIALS

Tutorials presented in these chapters for using the MPLAB C30 compiler include:

• Chapter 2 which demonstrates how to:

- set up and build a project

- run, step and set breakpoints in the example code

- debug the code.

• Chapter 3 which demonstrates how to:

- use templates to create a source file

- use a real-time interrupt in C

• Chapter 4 which demonstrates how to:

- use MPLAB C30 compiler with an assembly language DSP routine

- pass parameters to and from an assembly language module
DS70094B-page 2  2003 Microchip Technology Inc.
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Chapter 2.  Tutorial 1 - Creating A Project
2.1 INTRODUCTION

The simple source code in this tutorial is designed for an MPLAB IDE v6.XX project 

which will be created next. It will use the MPLAB SIM30 simulator and the PIC30F6014 

device. The tutorial assumes that the directory c:\pic30_tools is the MPLAB C30 

compiler installation directory.

2.2 CREATING A FILE

Start MPLAB IDE v6.30 (or later) and select File>New to bring up a new empty source 

file. The source code that should be typed in (or copy and pasted if viewing this 

electronically) to this new source file window is shown in Example 2-1.

EXAMPLE 2-1: MYFILE.C

TRISB and PORTB are special function registers on the PIC30F6014 device. PORTB is 

a set of general purpose input/output pins. TRISB bits configure the PORTB pins as 

inputs (1) or outputs (0).

Use File>Save As... to save this file with the file name MyFile.c in the \examples 

folder under the installation folder (usually c:\pic30_tools\examples).

#include "p30f6014.h"

int counter;

int main (void)
{

counter = 1;
TRISB = 0;
while(1)
{

PORTB = counter;
counter++;

}
return 0;

}

// for TRISB and PORTB declarations

// configure PORTB for output
// do forever

// send value of ‘counter’ out PORTB
 2003 Microchip Technology Inc. DS70094B-page 3
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2.3 USING THE PROJECT WIZARD

Select Project>Project Wizard to create a new project. This is the Welcome page. Click 

Next> to continue.

FIGURE 2-1: PROJECT WIZARD - START 

At Step One, select a dsPIC30F device. Use the pull-down menu to select the 

dsPIC30F6014. Press Next> to continue to the next dialog.

FIGURE 2-2: PROJECT WIZARD - SELECT DEVICE

At Step Two choose “Microchip C30 Toolsuite” as the Active Toolsuite. Then make 

sure that MPLAB knows where the C30 tools are located. If the MPLAB C30 compiler 

has been installed, these will have already been set up. Verify that the compiler, 

assembler and linker are shown in the Location of Selected Tool field. Figure 2-3, 

Figure 2-4 and Figure 2-5 show the default locations of MPLAB C30, MPLAB ASM30 

and MPLINK30, respectively.
DS70094B-page 4  2003 Microchip Technology Inc.
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FIGURE 2-3: PROJECT WIZARD - TOOLSUITE: ASM30

FIGURE 2-4: PROJECT WIZARD - TOOLSUITE: C30

FIGURE 2-5: PROJECT WIZARD - TOOLSUITE: MPLINK30
 2003 Microchip Technology Inc. DS70094B-page 5
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Press the Next> button to advance to the next wizard dialog.

At Step Three select the name of the project. Type in MyProject and then use the 

Browse button to go the \examples folder in the installation folder of MPLAB C30.

FIGURE 2-6: PROJECT WIZARD - PROJECT NAME AND DIRECTORY

Press Next> to go to the next dialog in the Project Wizard. 

At Step Four, files to be added to the project can be set up. First, select the source file 

created earlier, MyFile.c in the \examples folder under the installation folder.

FIGURE 2-7: PROJECT WIZARD - ADD C SOURCE FILE0
DS70094B-page 6  2003 Microchip Technology Inc.
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Place the cursor over MyFile.c in the left window and click to highlight. Press ADD>> 

to add it to the list of files to be used for this project (in the right window).

FIGURE 2-8: PROJECT WIZARD - ADDED C SOURCE FILE

In addition to the source file, a linker script is required to tell the linker about the memory 

organization of the dsPIC30F6014. Linker scripts are located in the \support\gld 

directory in the dsPIC30F tools installation directory.

FIGURE 2-9: PROJECT WIZARD - ADD LINKER SCRIPT
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Scroll down to the p30f6014.gld file, click on it to highlight, and press ADD>> to add 

the file to the right window for the project.

FIGURE 2-10: PROJECT WIZARD - ADDED ALL FILES

Select Next> to add these files to the project. 

At the summary screen review the Project Parameters to verify that the device, tool 

suite and project file location are correct.

FIGURE 2-11: PROJECT WIZARD - END
DS70094B-page 8  2003 Microchip Technology Inc.
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The wizard will create the new project and workspace. Press Finish, and locate the 

project window on the MPLAB IDE workspace. The file name of the workspace should 

appear in the top title bar of the project window, MyProject.mcw, with the file name 

as the top “node” in the project, MyProject.mcp. 

The project window should now look like this:

FIGURE 2-12: PROJECT WINDOW

Note: If an error was made, highlight a file name and press the Delete key or use 

the right mouse menu to delete a file. Place the cursor over Source Files or 

Linker Scripts and use the right mouse menu to add the proper files to the 

project.
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2.4 BUILDING THE PROJECT

The dsPIC30F tools are almost ready to be invoked to build the project. First, double 

check that the system is correctly set up for the dsPIC30F tools directories. This should 

be automatic, but select Project>Build Options and click on “project” to display the Build 

Options dialog for the entire project. Look at the General tab to see that the Include 

Path and Library path are pointing to the appropriate folders under the dsPIC30F tools 

installation directory.

FIGURE 2-13: BUILD OPTIONS DIALOG 
DS70094B-page 10  2003 Microchip Technology Inc.
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2.4.1 Verify Compiler and Linker Settings

The various command-line options that are passed to the compiler and linker can be 

set on the MPLAB C30 and MPLINK LINK30 tabs, respectively, in the Build Options 

dialog. There are three dialogs of options for MPLAB C30:

• General

• Memory Model

• Optimizations

These are selected in the Categories pull-down. For this example accept the default 

command-line options for MPLAB C30.

FIGURE 2-14: COMPILER GENERAL BUILD OPTIONS
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FIGURE 2-15: COMPILER MEMORY MODEL BUILD OPTIONS

FIGURE 2-16: COMPILER OPTIMIZATION BUILD OPTIONS
DS70094B-page 12  2003 Microchip Technology Inc.
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MPLAB LINK30 needs to have a heap setting added to its Build Options in order to run 

Tutorial 3 in this guide. Enter 512 as the Heap size in the following dialog:

FIGURE 2-17: LINKER BUILD OPTIONS - GENERAL

The build options for the linker have two other dialogs besides this “General” screen 

that are not shown – Diagnostics and Symbols & Output. These dialogs do not need to 

be changed from their default values.

Finally, look at the MPLAB ASM30 build options. They should look like this:

FIGURE 2-18: ASSEMBLER BUILD OPTIONS - GENERAL 

MPLAB ASM30 also has another dialog besides “General”, called Diagnostics (not 

shown), no changes to it are required.
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2.4.2 Build the Project

Select Project>Build All to compile, assemble and link the project. If there are any error 

or warning messages, they will appear in the output window.

FIGURE 2-19: BUILD ALL

For this tutorial, the output window should display no errors and should show a 

message stating the project “BUILD SUCCEEDED.” If there were any errors, check to 

see that the content of the source file matches the text of myfile.c displayed in 

Example 2-1.

FIGURE 2-20: BUILD OUTPUT WINDOW
DS70094B-page 14  2003 Microchip Technology Inc.
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2.4.3 Build Errors

If errors were reported after building the project, double click on the line with the error 

message to go directly to the source code line that caused the error. If the example was 

typed in, the most common errors are misspellings, missing semicolons or unmatched 

braces. In the following screen, a typo was made. In this example, the letter “i” was 

accidentally omitted in the “int” declaration of main(). The error message will appear 

in the output window.

FIGURE 2-21: BUILD ERROR

After double clicking on the third line in the output window above, the desktop looks like 

this:

FIGURE 2-22: DOUBLE CLICK TO GO TO SOURCE

Note that the offending typo “nt” is in black text rather than blue – a good indication 

that something is wrong, since key words are shown in blue color fonts. Typing an “i” 

to make the “nt” the proper key word “int,” results in the text turning blue. Selecting 

Project>Project Build All again produces a successful build. 
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2.5 DEBUGGING WITH THE MPLAB SIM30 SIMULATOR

With the MPLAB SIM30 Simulator, breakpoints can be set in the source code and the 

value of variables can be observed with a watch window. First, make sure that the 

MPLAB SIM30 Simulator is set as the debugging tool by selecting Debugger>Select 

Tool>MPLAB SIM30.

FIGURE 2-23: SELECT SIM30 

Open the source file by double-clicking on its name in the project tree. In the source 

file, place the cursor over the line PORTB = counter;, click the right mouse button 

and select “Set Breakpoint”.

FIGURE 2-24: SET BREAKPOINT
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The red stop sign symbol in the margin along the left side of the source window 

indicates that the breakpoint has been set and is enabled.

FIGURE 2-25: BREAKPOINT IN SOURCE WINDOW

To open a Watch window on the variable counter, select View>Watch.

FIGURE 2-26: SELECT WATCH WINDOW

Select counter from the pull down expandable menu next to Add Symbol, and select 

Add Symbol.

FIGURE 2-27: ADD WATCH VARIABLE

Note: There are three ways to enter Watch variables. In the method described 

above a variable can be picked from a list. The symbol’s name can also 

be typed directly in the Symbol Name column in the Watch window. 

Alternatively, the variable’s name can be highlighted in the source text and 

dragged to the Watch window. 
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Press Run on the toolbar to run the program.

The program should halt just before the statement at the breakpoint is executed. The 

green arrow in the left margin of the source window points to the next statement to be 

executed. The watch window should show counter with a value of ‘1’. The value of 

‘1’ will be shown in red, indicating that this variable has changed.

FIGURE 2-28: RUN TO BREAKPOINT

Press Run again to continue the program. Execution will continue in the while loop 

until it halts again at the line with the breakpoint. The Watch window should show 

counter with a value of ‘2’.

FIGURE 2-29: WATCH WINDOW INSPECTION
DS70094B-page 18  2003 Microchip Technology Inc.
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To step through the source code one statement at a time, use Step Into on the toolbar.

As each statement executes, the green arrow in the margin of the source window 

moves to the next statement to be executed.

Place the cursor on the line with the breakpoint, and use the right mouse button menu 

to select “Remove Breakpoint”. Now press the Run button. The “Running...” message 

should appear on the lower left of the Status bar, and next to it, a moving bar will 

indicate that the program is running. The Step icon to the right of the Run Icon will be 

grayed out. If the Debugger menu is pulled down, the Step options will also be grayed 

out. While in the Run mode, these operations are disabled.

When the program is running, it can be interrupted by pressing Halt on the toolbar:

Press this button now. Note that the step icons are no longer grayed out.

Note: There are two basic modes while debugging: Halt or Run. Most debugging 

operations are done in Halt mode. In Run mode, most debug functions are 

not operational. Registers cannot be inspected, changed or a project 

rebuilt. Functions that try to access the memory or internal registers of the 

running target will not be available in Run mode. 
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2.5.1 Map Files

A map file can be generated by setting the appropriate switch in Project>Build Options. 

Go to the MPLAB LINK30 tab and select the Diagnostics dialog.

FIGURE 2-30: GENERATE MAP FILE

Click on Generate map file, then click on OK to save the settings and close the dialog. 

Then rebuild the project.

The map file (MyProject.map) is present in the project directory and may be opened 

by selecting File>Open, and then browsing to the project directory. Select Files of Type 

“All files(*.)” in order to see the map file. This file provides additional information that 

may be useful in debugging, such as details of memory allocation. For example, this 

excerpt from the MyProject.map file shows the program and data memory area 

usage after MyProject.C was compiled:

EXAMPLE 2-2: MAP FILE EXCERPT

Program Memory Usage

section address length (PC units) length (bytes) (dec)
------- ------- ----------------- --------------------
.reset 0 0x4 0x6 (6)
.ivt 0x4 0x7c 0xba (186)
.aivt 0x84 0x7c 0xba (186)
.text 0x100 0xa0 0xf0 (240)
.dinit 0x1a0 0x8 0xc (12)

Total program memory used (bytes): 0x276 (630)

Data Memory Usage

section address alignment gaps total length (dec)
------- ------- -------------- -------------------
.bss 0x800 0 0x4 (4)

Total data memory used (bytes): 0x4 (4)
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2.5.2 Debugging at Assembly Code Level

So far all debugging has been done from the C source file, using functions and 

variables as defined in the C code. For embedded systems programming, it may be 

necessary to dig down deeper into the assembly code level. MPLAB IDE provides tools 

to do both, and shows the correlation between the C code and the generated machine 

code.

Select the MPLAB IDE View>Disassembly Listing window to see the source code 

interspersed with the generated machine and assembly code. This is useful when 

debugging mixed C and assembly code, and when it is necessary to see the machine 

code generated from the C source code.

FIGURE 2-31: DISASSEMBLY WINDOW

The C source code is shown with the line number from the source code file shown on 

the left column. The generated machine HEX code and the corresponding disassem-

bled instructions are shown with the address in the left column. For the machine code 

instructions the left column is the address of the instruction in program memory, fol-

lowed by the hexadecimal bytes for the instruction and then the dsPIC30F disassem-

bled instruction. 

Select View>Program Memory window to see only the machine and assembly code in 

program memory. 
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FIGURE 2-32: PROGRAM MEMORY WINDOW - SYMBOLIC

By selecting the various tabs at the bottom of the Program Memory window, the code 

can be viewed with or without symbolic labels, as a raw HEX dump, as mixed PSV code 

and data, or just as PSV data.

Breakpoints can be set, single-stepped, and all debug functions perform in any of the 

Source code, Disassembly and Program Memory windows.

Make sure the program is halted by pressing the Halt button. In the Program Memory 

window click on the Symbolic tab at the bottom to view the code tagged with symbols. 

Scroll down and click on the line named main, which corresponds to the main() 

function in the C file. Use the right mouse button to set a breakpoint on main. Press 

the Reset icon (or select to Debugger>Reset and select Processor Reset).
 

Now press Run. The program should halt at the breakpoint set at main.

Note: See the dsPIC® device data sheet for more information about PSV data.
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FIGURE 2-33: BREAKPOINT IN PROGRAM MEMORY

2.6 EXPLORING FURTHER 

Go back and look at the Source file window and the Disassembly window. The break-

point should be seen in all three windows. The step function can now be used in any 

window to single step through C source lines or to single step through the machine 

code.

Go ahead and experiment with this example program. Things to explore include:

Changing the value of counter by clicking on its value in the Watch window and typing 

in a new number.

Assigning counter an initial value of one in its definition. Inspect the source code to 

see where counter is loaded with this value.
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Chapter 3.  Tutorial 2 - Real-Time Interrupt
3.1 INTRODUCTION

This next tutorial demonstrates real-time interrupt code implemented using the basic 

“template” file that comes with MPLAB® IDE software. Timer 1 on the dsPIC30F6104 

will be used to generate a recurring interrupt to measure one-second intervals.

3.2 USING TEMPLATE FILES

Template files are source code files that can serve as a structure to build an application. 

They make it easy to start a project for an application since the C constructs and 

formats are provided in a simple file where details of an application can be added. The 

templates have example C statements for many common features of C30 source code, 

including variables and constants, processor-specific include files, interrupt vectors 

and associated interrupt code, plus areas to insert application code.

The template has comments to help identify key constructs. In many cases macros are 

defined to make some things easier. In the simplest form, here is a “stripped-down” 

template without these comments and macros so its basic structure can be seen:

EXAMPLE 3-1: ELEMENTS OF A TEMPLATE FILE

This template code starts out with the #include statement to include the header file 

that has the processor-specific special function register definitions for this particular 

processor (dsPIC30F6014). Following this is a simple constant definition that can be 

modified and copied to make a list of constants for the application.

Two array definitions follow to show how to define an array with various attributes, 

specifying its section in memory, and how it is aligned in the memory architecture of the 

dsPIC device. The second array definition, array5, is a simple array.

Like arrays, variables can be assigned with attributes (variable1), or with no 

attributes (variable3).

A code fragment for main() follows. This is where code for the application can be 

placed. Following main() is the code framework for an interrupt.

#include "p30F6014.h"                           /* proc specific header */

#define CONSTANT1 10                            /* sample constant definition */

int array1[CONSTANT1] __attribute__((__section__(".xbss"), __aligned__(32))); 
                                                /* array with dsPIC30F attributes */
int array5[CONSTANT2];                          /* simple array */

int variable1 __attribute__((__section__(".xbss"))); 
                                                /* variable with attributes */
int variable3;                                  /* simple variable */

int main ( void )                               /* start of main application code */
  {
  /* Application code goes here */
  }

void __attribute__((__interrupt__(__save__(variable1,variable2)))) _INT0Interrupt(void)
                                                /* interrupt routine code */
  {
  /* Interrupt Service Routine code goes here  */
  }
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Actual applications may use different interrupts, different attributes, and will be more 

complicated than this, but this template provides a simple place to start. Along with the 

appropriate linker file, the unmodified template can be added to a new project, and the 

project will build with no errors.

Templates are stored in a folder with the dsPIC tools installation directory named 

\support\templates, and are provided for both assembler and compiler source 

files in the corresponding \asm and \c folders.

Here is the full source code for the C template file for the dsPIC30F6014:

EXAMPLE 3-2: TEMP_6014.C TEMPLATE FILE 

/***********************************************************************
 * This file is a basic template for creating C code for a dsPIC30F    *
 * device.  Copy this file into your project directory and modify or   *
 * add to it as needed.                                                *
 * Add the suitable linker script (e.g., p30f6014.gld) to the project. *
 *                                                                     *
 * If interrupts are not used, all code presented for that interrupt   *
 * can be removed or commented out with C-style comment declarations.  *
 *                                                                     *
 * For additional information about dsPIC architecture and language    *
 * tools, refer to the following documents:                            *
 *                                                                     *
 * MPLAB C30 Compiler User's Guide                        : C30.pdf    *
 * MPLAB C30 Compiler Reference Guide                     : R30.pdf    *
 * dsPIC 30F Assembler, Linker and Utilities User's Guide : ALU.pdf    *
 * dsPIC 30F 16-bit MCU Family Reference Manual           : DS70046    *
 * dsPIC 30F Sensor and General Purpose Family Data Sheet : DS70083    *
 * dsPIC 30F Programmer's Reference Manual                : DS70030    *
 *                                                                     *
 * Template file has been compiled with MPLAB C30 V 1.0.               *
 *                                                                     *
 ***********************************************************************
 *                                                                     *
 *    Author:                                                          *
 *    Company:                                                         *
 *    Filename:       temp_6014.c                                      *
 *    Date:           06/14/2002                                       *
 *    File Version:   1.00                                             *
 *    Other Files Required: p30F6014.gld, libpic30.a                   *
 *    Tools Used: MPLAB GL  -> 6.00                                    *
 *                Compiler  -> 1.00                                    *
 *                Assembler -> 1.00                                    *
 *                Linker    -> 1.00                                    *
 *                                                                     *
 *    Devices Supported:                                               *
 *                dsPIC30F2011                                         *
 *                dsPIC30F3012                                         *
 *                dsPIC30F2012                                         *
 *                dsPIC30F3013                                         *
 *                dsPIC30F3014                                         *
 *                dsPIC30F5011                                         *
 *                dsPIC30F6011                                         *
 *                dsPIC30F6012                                         *
 *                dsPIC30F5013                                         *
 *                dsPIC30F6013                                         *
 *                dsPIC30F6014                                         *
 *                                                                     *
 ***********************************************************************
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EXAMPLE 3-2: TEMP_6014.C TEMPLATE FILE (CONTINUED)

 ***********************************************************************
 *                                                                     *
 * Other Comments:                                                     *
 *                                                                     *
 * 1) C attributes, designated by the __attribute__ keyword, provide a *
 *    means to specify various characteristics of a variable or        *
 *    function, such as where a particular variable should be placed   *
 *    in memory, whether the variable should be aligned to a certain   *
 *    address boundary, whether a function is an Interrupt Service     *
 *    Routine (ISR), etc. If no special characteristics need to be     *
 *    specified for a variable or function, then attributes are not    *
 *    required. For more information about attributes, refer to the    *
 *    C30 User's Guide.                                                *
 *                                                                     *
 * 2) The __section__(".xbss") and __section__(".ybss") attributes are *
 *    used to place a variable in X data space and Y data space,       *
 *    respectively. Variables accessed by dual-source DSP instructions *
 *    must be defined using these attributes.                          *
 *                                                                     *
 * 3) The aligned(k) attribute, used in variable definitions, is used  *
 *    to align a variable to the nearest higher 'k'-byte address       *
 *    boundary. 'k' must be substituted with a suitable constant       *
 *    number when the ModBuf_X(k) or ModBuf_Y(k) macro is invoked.     *
 *    In most cases, variables are aligned either to avoid potential   *
 *    misaligned memory accesses, or to configure a modulo buffer.     *
 *                                                                     *
 * 4) The __interrupt__ attribute is used to qualify a function as an  *
 *    interrupt service routine. An interrupt routine can be further   *
 *    configured to save certain variables on the stack, using the     *
 *    __save__(var-list) directive.                                    *
 *                                                                     *
 * 5) The __shadow__ attribute is used to set up any function to       *
 *    perform a fast context save using shadow registers.              *
 *                                                                     *
 * 6) Note the use of double-underscores (__) at the start and end of  *
 *    all the keywords mentioned above.                                *
 *                                                                     *
 **********************************************************************/
 

/* Include the appropriate header (.h) file, depending on device used */
/* Replace the path shown here with the header path in your system    */
/* Example (for dsPIC30F5013): #include "Your_path\p30F5013.h"        */

/* Alternatively, the header file may be inserted from the Project    */
/* window in the MPLAB IDE                                            */

#include "p30F6014.h"

/* Define constants here                            */

#define CONSTANT1 10
#define CONSTANT2 20

/* Define macros to simplify attribute declarations */

#define ModBuf_X(k) __attribute__((__section__(".xbss"), __aligned__(k)))
#define ModBuf_Y(k) __attribute__((__section__(".ybss"), __aligned__(k)))
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EXAMPLE 3-2: TEMP_6014.C TEMPLATE FILE (CONTINUED)

/************* START OF GLOBAL DEFINITIONS **********/

/* Define arrays: array1[], array2[], etc.          */
/* with attributes, as given below                  */

/* either using the entire attribute                */
int array1[CONSTANT1] __attribute__((__section__(".xbss"), __aligned__(32)));
int array2[CONSTANT1] __attribute__((__section__(".ybss"), __aligned__(32)));

/* or using macros defined above                    */
int array3[CONSTANT1] ModBuf_X(32);
int array4[CONSTANT1] ModBuf_Y(32);

/* Define arrays without attributes                 */

int array5[CONSTANT2];   /* array5 is NOT an aligned buffer */

/* ------------------------------------------------ */

/* Define global variables with attributes          */

int variable1 __attribute__((__section__(".xbss")));
int variable2 __attribute__((__section__(".ybss")));

/* Define global variables without attributes       */

int variable3;

/************** END OF GLOBAL DEFINITIONS ***********/

/************* START OF MAIN FUNCTION ***************/

int main ( void )
{

/* Code goes here                                   */

}
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EXAMPLE 3-2: TEMP_6014.C TEMPLATE FILE (CONTINUED)

/****** START OF INTERRUPT SERVICE ROUTINES *********/

/* Replace the interrupt function names with the    */
/* appropriate names depending on interrupt source. */

/* The names of various interrupt functions for     */
/* each device are defined in the linker script.    */

/* Interrupt Service Routine 1                      */
/* No fast context save, and no variables stacked   */

void __attribute__((__interrupt__)) _ADCInterrupt(void)
{

/* Interrupt Service Routine code goes here         */
        
}

/* Interrupt Service Routine 2                      */
/* Fast context save (using push.s and pop.s)       */

void __attribute__((__interrupt__, __shadow__)) _T1Interrupt(void)
{

/* Interrupt Service Routine code goes here         */
        
}

/* Interrupt Service Routine 3: INT0Interrupt       */
/* Save and restore variables var1, var2, etc.      */

void __attribute__((__interrupt__(__save__(variable1,variable2)))) 
_INT0Interrupt(void)
{

/* Interrupt Service Routine code goes here         */

}

/********* END OF INTERRUPT SERVICE ROUTINES ********/
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3.3 USING THE TEMPLATE IN A NEW PROJECT

For this tutorial, copy the template described above to a new project directory, following 

these steps. Go to Windows® Explorer for these folder/file operations.

1. Make a new folder named \T1_Interrupt in the \Examples directory under 

the MPLAB C30 installation directory.

2. Copy C:\pic30_tools\support\templates\c\temp_6014.C to the new 

\T1_Interrupt folder.

3. Rename the copied template file temp_6014.c in the \T1_Interrupt folder 

to T1Clock.c.

4. Return to MPLAB IDE.

Use the project wizard to create a new project in this directory, using this as the only 

source file, then add the linker script for the dsPIC30F6014 as done in Chapter 2. After 

double clicking on the file name T1Clock.c in the Project window, the desktop should 

look something like this:

FIGURE 3-1: VIEW T1CLOCK.C
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Some of the header comments for this generic template can now be removed and 

application specific information entered for the new project. The header area at the 

beginning of the file should contain information on the new project. After editing is 

finished, it might look something like this:

FIGURE 3-2: EDITED T1CLOCK.C

For this tutorial, one constant, two variables and an array need to be defined. The 

constants defined in the template are named CONSTANT1 and CONSTANT2. 

Comment those out, and below the CONSTANT2 line add a comment and the 

definition for TMR1_PERIOD 0x1388:

/* Timer1 period for 1 ms with FOSC = 20 MHz */
#define TMR1_PERIOD 0x1388

Define some variables to track the code operation in this example. Position these in the 

GLOBAL DEFINITIONS area, after the definition of variable3. Add two new integer 

variables, main_counter and irq_counter. Then, for the interrupt timer routine, 

create a structure of three unsigned integer variable elements, timer, ticks and 

seconds, named RTclock:

EXAMPLE 3-3: VARIABLE DEFINITIONS

Note: The period 0x1388 = 5000 decimal. The timer will count at a rate one fourth 

the oscillator frequency. 5000 cycles at 5 MHz (the 20 MHz oscillator is 

divided by four) yields a time-out for the counter at every 1 ms.

/* Define global variables without attributes       */

int variable3;

int main_counter;
int irq_counter;

struct clockType
    {
    unsigned int timer;    /* countdown timer, milliseconds */
    unsigned int ticks;    /* absolute time, milliseconds */
    unsigned int seconds;  /* absolute time, seconds */
    } RTclock;
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The other template code in this tutorial can be left in or commented out. It is probably 

better to comment it out at this time since these definitions will get compiled and take 

up memory space. Make sure to comment out all the sample arrays, since they use the 

macros which can be commented out. Also, as the code grows, it may be difficult to 

remember which code is used by the application and which was part of the original 

template.

After the section labelled END OF GLOBAL DEFINITIONS type in this routine to 

initialize Timer 1 as an interrupt timer using the internal clock (the bolded text is the 

code that should be typed in):

EXAMPLE 3-4: RESET_CLOCK CODE

This routine uses special function register names, such as TMR1 and T1CONbits.TCS 

that are defined in the header file p30F6014.h. Refer to the data sheet for more 

information on these control bits and registers for Timer 1.

Note: When using the template, remember that when beginning to code the 

application, only a few elements of the template may be needed. It may be 

helpful to comment out those portions of code that are not being used so 

that later, when similar elements are needed, they can be referred back to 

as models.

/************** END OF GLOBAL DEFINITIONS ***********/

void reset_clock(void)
{
RTclock.timer = 0; /* clear software registers */
RTclock.ticks = 0;
RTclock.seconds = 0;
TMR1 = 0; /* clear timer1 register */
PR1 = TMR1_PERIOD; /* set period1 register */
T1CONbits.TCS = 0; /* set internal clock source */
IPC0bits.T1IP = 4; /* set priority level */
IFS0bits.T1IF = 0; /* clear interrupt flag */
IEC0bits.T1IE = 1; /* enable interrupts */
SRbits.IPL = 3; /* enable CPU priority levels 4-7 */
T1CONbits.TON = 1; /* start the timer */
}

/************* START OF MAIN FUNCTION ***************/
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A main routine and an interrupt service routine may need to be written. The most 

complex routine is the interrupt service routine. It is executed when Timer 1 counts 

down 0x1388 cycles. It increments a counter sticks at each of these 1 ms interrupt 

until it exceeds one thousand. Then it increments the seconds variable in the 

RTclock structure and resets sticks. This routine should count time in seconds. In 

the section labelled “START OF INTERRUPT SERVICE ROUTINES” where a template 

for the _T1Interrupt() code is written, replace the comment 

“/* Interrupt Service Routine code goes here */”

 with these lines of code (added code is bold):

EXAMPLE 3-5: INTERRUPT SERVICE ROUTINE

There are three sample interrupt functions in the template file. Comment out 

_INT0Interrupt() because it uses two of the template file sample variables and, as 

a result, will not compile. _ADCInterrupt() can be commented out too, since it will 

not be used in this tutorial.

By comparison to the Timer 1 interrupt code, the main() code is simple. Type this in 

for the body, replacing the line “/* code goes here */” (added code is bold):

EXAMPLE 3-6: MAIN CODE

The main() code is simply a call to our Timer 1 initialization routine, followed by an 

infinite loop, allowing the Timer 1 interrupt to function. Typically, an application that 

made use of this timer would be placed in this loop in place of this test variable, 

main_counter.

/* Interrupt Service Routine 2                      */
/* Fast context save (using push.s and pop.s)       */

void __attribute__((__interrupt__, __shadow__)) _T1Interrupt(void)
{
static int sticks=0;

irq_counter++;

if (RTclock.timer > 0) /* if timer is active */
RTclock.timer -= 1; /* decrement it */

RTclock.ticks++; /* increment ticks counter */

if (sticks++ == 1000)
{ /* if time to rollover */
sticks = 0; /* clear seconds ticks */
RTclock.seconds++; /* and increment seconds */
}

IFS0bits.T1IF = 0; /* clear interrupt flag */

}
        

/* Interrupt Service Routine 3: INT0Interrupt       */
/* Save and restore variables var1, var2, etc.      */

/************* START OF MAIN FUNCTION ***************/

int main ( void )
    {
    reset_clock();

    for (;;)
        main_counter++;
    }

/****** START OF INTERRUPT SERVICE ROUTINES *********/
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The final code should now look like this:

EXAMPLE 3-7: FINAL C CODE FILE

/***********************************************************************
 *                                                                     *
 *    Author:         F. Bar                                           *
 *    Company:        Widgets, Inc.                                    *
 *    Filename:       T1Clock.c                                        *
 *    Date:           7/7/2003                                         *
 *    File Version:   1.00                                             *
 *    Other Files Required: p30F6014.gld, libpic30.a                   *
 *    Tools Used: MPLAB GL  -> 6.30                                    *
 *                Compiler  -> 1.10                                    *
 *                Assembler -> 1.10                                    *
 *                Linker    -> 1.10                                    *
***********************************************************************/

#include "c:\pic30_tools\support\h\p30F6014.h"

/* Define constants here                            */
/* #define CONSTANT1 10
   #define CONSTANT2 20                             */
/* Timer1 period for 1 ms with FOSC = 20 MHz        */
#define TMR1_PERIOD 0x1388

/* Define macros to simplify attribute declarations */

#define ModBuf_X(k) __attribute__((__section__(".xbss"), __aligned__(k)))
#define ModBuf_Y(k) __attribute__((__section__(".ybss"), __aligned__(k)))

/************* START OF GLOBAL DEFINITIONS **********/
/* Define arrays: array1[], array2[], etc.          */
/* with attributes, as given below                  */

/* either using the entire attribute                */
/*
 int array1[CONSTANT1] __attribute__((__section__(".xbss"), __aligned__(32)));
 int array2[CONSTANT1] __attribute__((__section__(".ybss"), __aligned__(32)));
*/
/* or using macros defined above                   */
/* int array3[CONSTANT1] ModBuf_X(32);
   int array4[CONSTANT1] ModBuf_Y(32);             */
/* Define arrays without attributes                */
/* int array5[CONSTANT2]; */  /* array5 is NOT an aligned buffer */

/* ------------------------------------------------ */

/* Define global variables with attributes           */
/* int variable1 __attribute__((__section__(".xbss")));
   int variable2 __attribute__((__section__(".ybss")));*/

/* Define global variables without attributes       */
/* int variable3; */
int main_counter;
int irq_counter;

struct clockType
    {
    unsigned int timer;     /* countdown timer, milliseconds */
    unsigned int ticks;     /* absolute time, milliseconds */
    unsigned int seconds;   /* absolute time, seconds */
    } RTclock;

/************** END OF GLOBAL DEFINITIONS ***********/

void reset_clock(void)
    {
    RTclock.timer = 0;   /* clear software registers */
    RTclock.ticks = 0;
    RTclock.seconds = 0;
    TMR1 = 0;            /* clear timer1 register */
    PR1 = TMR1_PERIOD;   /* set period1 register */
    T1CONbits.TCS = 0;   /* set internal clock source */
    IPC0bits.T1IP = 4;   /* set priority level */
    IFS0bits.T1IF = 0;   /* clear interrupt flag */
    IEC0bits.T1IE = 1;   /* enable interrupts */
    SRbits.IPL = 3;      /* enable CPU priority levels 4-7 */
    T1CONbits.TON = 1;   /* start the timer */
}
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EXAMPLE 3-7: FINAL C CODE FILE (CONTINUED)

If everything is typed correctly, then selecting Project>Build All should result in a 

successful compilation. Double click on any errors appearing in the output window to 

return to the source code to fix typos and rebuild the project until it builds with no errors.

/************* START OF MAIN FUNCTION ***************/
int main ( void )
    {
    reset_clock();

    while (1)
        main_counter++;
    }

/****** START OF INTERRUPT SERVICE ROUTINES *********/
/* Interrupt Service Routine 1                      */
/* No fast context save, and no variables stacked   */
/* void __attribute__((__interrupt__)) _ADCInterrupt(void)
*/

/* Interrupt Service Routine 2                      */
/* Fast context save (using push.s and pop.s)       */

void __attribute__((__interrupt__, __shadow__)) _T1Interrupt(void)
    {
    static int sticks=0;

    irq_counter++;

    if (RTclock.timer > 0)   /* if countdown timer is active */
        RTclock.timer -= 1;  /* decrement it */

    RTclock.ticks++;         /* increment ticks counter */

    if (sticks++ > 1000)
        {                    /* if time to rollover */
        sticks = 0;          /* clear seconds ticks */
        RTclock.seconds++;   /* and increment seconds */
        }
    
    IFS0bits.T1IF = 0;        /* clear interrupt flag */

    return;
    }

/* Interrupt Service Routine 3: INT0Interrupt       */
/* Save and restore variables var1, var2, etc.      */
/* void __attribute__((__interrupt__(__save__(variable1)))) _INT0Interrupt(void)
*/

/********* END OF INTERRUPT SERVICE ROUTINES ********/
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3.4 DEBUGGING WITH THE MPLAB SIM30 SIMULATOR

The MPLAB SIM30 simulator can now be used to test the code. Make sure that 

Debugger>Select Tool>MPLAB SIM30 is selected. Then set the processor clock speed 

for the simulator by selecting Debugger>Settings. The Oscillator tab is a dialog to set 

the clock frequency of the simulated dsPIC30F6014. Set it to 20 MHz. 

FIGURE 3-3: STIMULUS OSCILLATOR FREQUENCY

One way to measure time with the simulator is to use the Stopwatch. Select 

Debugger>Stopwatch to view the Stopwatch dialog, and make sure that the box 

labeled “Clear Simulation on Reset” is checked.

FIGURE 3-4: SIMULATOR STOPWATCH

Note: The simulator runs at a speed determined by the PC, so it will not run at the 

actual dsPIC30F MCU speed as set by the clock in this dialog. However, all 

timing calculations are based on this clock setting, so when timing 

measurements are made using the simulator, times will correspond to those 

of an actual device running at this frequency.
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Often a good first test is to verify that the program minimally runs. For this purpose, set 

a breakpoint at the line in main() that increments main_counter (right mouse click 

on the line and select Set Breakpoint), then press the Run icon or select 

Debugger>Run. The Stopwatch and the screen should like this after the breakpoint is 

reached.

FIGURE 3-5: TIME MEASUREMENT

If everything looks OK, then a watch window can be set to inspect the program’s 

variables. Select View>Watch to bring up the watch window, then add the variable 

RTclock so it looks like this:

FIGURE 3-6: WATCH
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RTclock is a structure, as indicated by the small plus symbol in the box to the left of 

its name. Click on the box to expand the structure so it looks like this:

FIGURE 3-7: WATCH STRUCTURE

Also add the variables sticks, irq_counter, and main_counter to the watch 

window.

FIGURE 3-8: WATCH VARIABLES

The Value column may be expanded wider in order to read the text on the sticks 

variable. Note that it says “Out of Scope.” This means, that unlike RTclock, 

irq_counter, and main_counter, this is not a global variable, and its value can only 

be accessed while the function _T1Interrupt()is executing. 

When inspecting the variables in the watch window at this first breakpoint, all of them 

should be equal to zero. This is to be expected, since Timer 1 just got initialized and 

counter has not yet been incremented for the first time.

Press the Step-Into icon to step once around the main() loop. The value of 

main_counter should now show 0001. The interrupt routine has not yet fired. 

Looking at the Stopwatch window, the elapsed time only increments by a microsecond 

each time through the main() loop. To reach the first interrupt we’d have to step a 

thousand times (1000 x 1 us = 1 ms).

Note: The Address column for sticks does not have a value. This is another 

indication that sticks is a local variable.
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In order to see that the interrupt seems to be working as designed, remove the break-

point at main_counter++ by clicking on the highlighted line with the right mouse but-

ton and select Remove Breakpoint. Now select Enable Breakpoint in the right mouse 

menu to put a breakpoint in the interrupt service routine at the irq_counter++ state-

ment, then press Run. The Stopwatch should look like this:

FIGURE 3-9: STOPWATCH AT FIRST INTERRUPT

The value shown in the Time window is 1.0304 ms. This is about what was expected, 

since the interrupt should happen every millisecond. There was some time since 

RESET that was counted by the Stopwatch, including the C start-up code and the Timer 

1 initialization.

Look at the Watch window. The variable main_counter is showing a value of 0x3E8. 

Change the radix of this display to decimal by placing the cursor over main_counter 

in the Watch window, using the right mouse button, choose “Properties”. A dialog will 

be displayed. Go to the Format pull-down and select Decimal, then press OK. 

FIGURE 3-10: SET WATCH RADIX

The main_counter value should now show 1000. Press the Step-Into icon a few more 

times to see the changing variables, especially sticks and irq_counter, which are 

incrementing each time the interrupt happens.
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Remove the breakpoint from the irq_counter++; line, and put a breakpoint inside 

the conditional statement that increments sticks, at the line sticks = 0; Press Run 

to run and halt at this breakpoint. The window should look like this:

FIGURE 3-11: MEASURE INTERRUPT PERIOD

The Stopwatch Time window shows 1.0012346 seconds, which is close to a one 

second interrupt. A good time measurement would be to measure the time to the next 

interrupt. That value could then be subtracted from the current time. Or, since it doesn’t 

matter how much time it took to get here – the main interest is the time between 

interrupts – press Zero on the Stopwatch and then press Run.

3.5 EXPLORING FURTHER

Measure the overhead of the interrupt, calculate how this will affect the timing, and try 

to adjust the constant TMR1_Period to adjust the interrupt to get better 1 second 

accuracy.

What is the maximum time (in minutes) measured by this routine? What can be done 

to extend it?

Add a routine that outputs a two millisecond pulse every second from a port. Verify the 

pulse duration with the stopwatch.

Note: The Stopwatch always tracks total time in the windows on the right side of 

the dialog. The left windows can be used to time individual measurements. 

Pressing zero will not cause the total time to change. 
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GETTING STARTED
Chapter 4.  Tutorial 3 - Mixed C and Assembly Files
4.1 INTRODUCTION

This tutorial will show how to make a project that uses an assembly language routine 

that is called from a C source file.

4.2 GETTING PROJECT SOURCE FILES

The files for this tutorial are available in the \Examples folder and are called 

example3.c, a C source code file, and modulo.s, an assembly language file. Create 

a folder in the \Examples folder called \DSP_ASM and copy these two files to that new 

folder. 

For reference, Example 4-1and Example 4-2 show listings of these two files.
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EXAMPLE 4-1: C SOURCE FILE

 /**********************************************************************
 *    Filename:       example3.c                                       *
 *    Date:           04/16/2003                                       *
 *    File Version:   1.00                                             *
 *    Tools used: MPLAB     -> 6.30                                    *
 *                Compiler  -> 1.10                                    *
 *                Assembler -> 1.10                                    *
 *                Linker    -> 1.10                                    *
 *    Linker File:    p30f6014.gld                                     *
 ***********************************************************************/

#include "p30f6014.h"
#include <stdio.h>

/* Length of output buffer (in words) */
#define PRODLEN 20

/* source arrays of 16-bit elements */
unsigned int array1[PRODLEN/2] __attribute__((__section__(".xbss"), aligned(32)));
unsigned int array2[PRODLEN/2] __attribute__((__section__(".ybss"), aligned(32)));

/* output array of 32-bit products defined here */
long array3[PRODLEN/2];   /* array3 is NOT a circular buffer */

/* Pointer for traversing array */
unsigned int array_index;

/* 'Point-by-point array multiplication' assembly function prototype */
extern void modulo( unsigned int *, unsigned int *, unsigned int *, unsigned int );

int main ( void )
{   
/* Set up Modulo addressing for X AGU using W8 and for Y AGU using W10 */
/* Actual Modulo Mode will be turned on in the assembly language routine */

    CORCON |= 0x0001;     /* Enable integer arithmetic */
    XMODSRT = (unsigned int)array1;
    XMODEND = (unsigned int)array1 + PRODLEN - 1;
    YMODSRT = (unsigned int)array2;
    YMODEND = (unsigned int)array2 + PRODLEN - 1;
    
/* Initialize 10-element arrays, array1 and array2 */
/* to values 1, 2, ...., 10 */
   while (1)           /* just do this over and over */
    {    
                  
            for (array_index = 0; array_index < PRODLEN/2; array_index++)
        {
            array1[array_index] = array1[array_index] + array_index + 1;
            array2[array_index] = array2[array_index] + (array_index+1) * 3; 
        }

/* Call assembly subroutine to do point-by-point multiply      */
/* of array1 and array2, with 4 parameters:                    */
/* start addresses of array1, array2 and array3, and PRODLEN-1 */
/* in that order                                               */
        modulo( array1, array2, array3, PRODLEN-1 );
    }
}
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EXAMPLE 4-2: MODULO.S ASM SOURCE FILE

 /**********************************************************************
 *    Filename:       modulo.s                                         *
 *    Date:           04/27/2003                                       *
 *    File Version:   1.00                                             *
 *                                                                     *
 *    Tools used: MPLAB     -> 6.30                                    *
 *                Compiler  -> 1.10                                    *
 *                Assembler -> 1.10                                    *
 *                Linker    -> 1.10                                    *
 *                                                                     *
 *    Linker File:    p30f6014.gld                                     *
 *    Description: Assembly routine used in example3.C                 *
 **********************************************************************/

         .text

         .global _modulo
_modulo:

             ; If any of the registers W8 - W15 are used, they should be saved
         ; W0 - W7 may be used without saving
         PUSH   W8
         PUSH   W10
         
         ; turn on modulo addressing
         MOV    #0xC0A8, W8 
         MOV    W8, MODCON
         
             ; The 3 pointers were passed in W0, W1 and W2 when function was called
         ; Transfer pointers to appropriate registers for MPY
         MOV    W0,  W8    ; Initializing X pointer
         MOV    W1,  W10   ; Initializing Y pointer 
         
         ; Clear Accumulator and prefetch 1st pair of numbers
         CLR    A, [W8]+=2, W4, [W10]+=2, W7
         
         LSR    W3, W3
         RCALL  array_loop ; do multiply set
         INC2   W8,  W8    ; Change alignment of X pointer
         RCALL  array_loop ; second multiply set
         
         POP    W10
         POP    W8
         
         RETURN
         ; Return to main C program

array_loop:
             ; Set up DO loop with count 'PRODLEN - 1' (passed in W3)
         DO     W3,   here

         ; Do  a point-by-point multiply
         MPY    W4*W7, A, [W8]+=2, W4, [W10]+=2, W7

         ; Store result in a 32-bit array pointed by W2
         MOV    ACCAL, W5
         MOV    W5, [W2++]

         MOV    ACCAH, W5
here:    MOV    W5, [W2++]

         ; turn off modulo addressing
         CLR    MODCON

         RETURN 

 .end
 2003 Microchip Technology Inc. DS70094B-page 43



dsPIC™ Language Tools Getting Started
4.3 CREATING AND BUILDING THE PROJECT

Using the Project Wizard, create a new project with these two source files and add the 

same linker script as the preceding two tutorials, p30f6014.gld. The project window 

should look like this:

FIGURE 4-1: PROJECT WINDOW

This tutorial will use the standard I/O function printf() to display messages to the 

output window. In order to use printf(), the build options for the linker need to have 

the heap enabled. Make sure that the linker build option is set as shown in Figure 2-17 

with 512 bytes allocated for the heap.

When building the project (Project>Build All), it should compile with no error messages. 

If an error is received, make sure the project is set up with the same options as for the 

previous two tutorials.

This tutorial sets up three arrays. It fills two of them with a test numerical sequence, 

then calls an assembly language routine that multiplies the values in the two 16-bit 

arrays and puts the result into the third 32-bit array. Using modulo arithmetic for 

addressing, the two source arrays are traversed twice to generate two sets of products 

in the output array, with the pointer to one array adjusted at the second pass through 

the multiply loop to change the alignment between the multipliers. Using an assembly 

language routine ensures that the arithmetic will be done using the DSP features of the 

dsPIC30F6014.

The assembly language routine takes four parameters: the addresses of each of the 

three arrays and the array length. It returns its result in the product array.

This routine runs in a continual loop, with the source arrays getting increasingly larger 

numbers as the program repeatedly executes the main endless loop.
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4.4 EXAMINING THE PROGRAM

Once the project is set up and successfully built, the operation of the program can be 

inspected. Set and run to a breakpoint on the function that calls the assembly language 

routine, modulo().

FIGURE 4-2: BREAKPOINT

Set up a watch window to look at the variables involved in this calculation. Add the three 

arrays, array1, array2 and array3. Also add the SFRs (Special Function 

Registers), ACCA, WREG8 and WREG10. The watch window should look like this:

FIGURE 4-3: WATCH WINDOW
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Click on the plus symbol to the left of the symbol name to expand the arrays. At this 

point in the program, both array1 and array2 should have been set up with initial 

values, but array3 should be all zeros, since the modulo() routine has not yet been 

called.

FIGURE 4-4: ARRAY3

Right click on any element in the arrays to change the radix of the display. Change the 

radix for all three arrays to decimal. 

Note: Changing the radix for any element of an array changes the radix for all 

elements in that array.
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Set a breakpoint in the modulo.s file at the start of the DO loop.

FIGURE 4-5: BREAKPOINT IN ASSEMBLY CODE FILE

Run to the breakpoint and scroll the watch window to look at array3. It should still be 

all zeroes. Press Run again, to run once through the DO loop. Now the first half of 

array3 should show values representing the product of each element pair from the 

source arrays:

FIGURE 4-6: ARRAY3 RESULTS - 1ST PASS
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Press Run again to see the results for the second pass through the DO loop:

FIGURE 4-7: ARRAY3 RESULTS - 2ND PASS

Remove the breakpoint from modulo.s and press Run to see the next time through 

the loop. Press Run a few more times to see the values change with subsequent 

executions of this multiplication process.

With Watch windows, data can be examined as breakpoints are run and halted. The 

simulator can also output data as it executes, providing a log of data that can be 

inspected and sent to other tools for graphing and analysis. Insert a printf() 

statement after the modulo() function call to monitor the values in the output array. 

The code should look like this (added code is bold):

EXAMPLE 4-3: printf() MONITOR

modulo( array1, array2, array3, PRODLEN-1 );

printf("Product Array\n");

  for (array_index=0; array_index<PRODLEN/2; array_index++)
     printf("%ld\n",array3[array_index]);
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The printf() function uses the UART1 functions of the dsPIC being simulated to 

write messages either to a file or to the output window. Select Debugger>Settings to 

bring up the simulator Settings dialog. Go to the tab labelled CLIB I/O, click on the 

check Enable Standard C Library I/O, and then select the radio button to send text from 

the printf() statement to the output window.

FIGURE 4-8: CLIB I/O

Now when the simulator is recompiled and run, a log of the contents of array3 will be 

generated in the output window. Press Run, let it run for a few seconds, then press Halt. 

If the output window is not present, enable it on View>Output.

FIGURE 4-9: printf() OUTPUT
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4.5 EXPLORING FURTHER

Some of the other DSP instructions can be tried to further process the numbers in these 

arrays.

Use the printf() function to output lists of values that can then be imported into a 

spreadsheet. Graph the values.

Further generalize the code so that all of the modulo indexing is set up from within 

modulo.s (i.e., convert these lines from Example 4-1 C Source File into assembly 

code that sets up the modulo addressing parameters from the parameters passed into 

the array).

4.6 WHERE TO GO FROM HERE

These tutorials were designed to gain familiarity using the MPLAB C30 compiler in the 

MPLAB IDE environment. There are many features of MPLAB IDE and the MPLAB 

C30 compiler that were not covered here. For more information, reference the current 

MPLAB IDE on-line help, MPLAB C30 C Compiler User’s Guide and MPLAB ASM30, 

MPLAB LINK30 and Utilities User’s Guide to start using these tools for individual appli-

cations.

Instant help can be obtained from MPLAB IDE’s on-line help or by logging on to 

Microchip’s web conference for MPLAB C products at www.microchip.com. Go to the 

Technical Support section and then to the On-line Discussion Groups. The 

Development Systems web board also has a section devoted to MPLAB C30 compiler 

discussion.

By subscribing to the Customer Change Notification service on Microchip’s web site, 

customers can register to be notified of changes to the MPLAB C30 C compiler. 

Choose the MPLAB C compiler category in Development Tools to receive notices when 

new versions are available and to receive timely information on the MPLAB C30 

compiler.

    XMODSRT = (unsigned int)array1;
    XMODEND = (unsigned int)array1 + PRODLEN - 1;
    YMODSRT = (unsigned int)array2;
    YMODEND = (unsigned int)array2 + PRODLEN - 1;
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